]> git.pld-linux.org Git - packages/kde4-kmines.git/blob - kde4-kmines.spec
- rebuild for g++ ABI changes
[packages/kde4-kmines.git] / kde4-kmines.spec
1 %define         _state          stable
2 %define         orgname         kmines
3 %define         qtver           4.8.0
4
5 Summary:        KDE minesweeper game
6 Summary(pl.UTF-8):      Saper dla KDE
7 Summary(pt_BR.UTF-8):   Versão do jogo 'caça-minas' para o KDE
8 Name:           kde4-%{orgname}
9 Version:        4.14.3
10 Release:        2
11 License:        GPL
12 Group:          X11/Applications/Games
13 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
14 # Source0-md5:  a1bc886a9d473598ef5e8d14e9d565e0
15 BuildRequires:  automoc4 >= 0.9.88
16 BuildRequires:  cmake >= 2.8.0
17 BuildRequires:  kde4-kdelibs-devel >= %{version}
18 BuildRequires:  kde4-libkdegames-devel >= %{version}
19 BuildRequires:  qt4-build >= %{qtver}
20 BuildRequires:  qt4-qmake >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.600
22 Obsoletes:      kde4-kdegames-%{orgname}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This is a very classical minesweeper written from scratch.
27 - 3 predefined levels (Easy: 8x8 with 10 mines, Normal: 16x16 with 40
28   mines, Expert: 30x16 with 99 mines)
29 - Custom levels
30 - High Scores.
31
32 %description -l pl.UTF-8
33 Wersja klasycznej gry "saper" dla KDE, napisana od zera. Cechy:
34 - 3 predefiniowane poziomy (łatwy - 8x8 z 10 minami, normalny - 16x16
35   z 40 minami, dla ekspertów - 30x16 z 99 minami)
36 - definiowalne poziomy
37 - lista najlepszych wyników.
38
39 %description -l pt_BR.UTF-8
40 Versão do jogo 'caça-minas' para o KDE.
41
42 %prep
43 %setup -q -n %{orgname}-%{version}
44
45 %build
46 install -d build
47 cd build
48 %cmake \
49         ../
50
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} -C build install \
57         DESTDIR=$RPM_BUILD_ROOT \
58         kde_htmldir=%{_kdedocdir}
59
60 install -d $RPM_BUILD_ROOT/var/games
61 # remove locolor icons
62 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/locolor
63
64 %find_lang %{orgname}   --with-kde
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files -f %{orgname}.lang
70 %defattr(644,root,root,755)
71 %attr(755,root,root) %{_bindir}/kmines
72 %{_desktopdir}/kde4/kmines.desktop
73 %{_datadir}/apps/kmines
74 %{_datadir}/config/kmines.knsrc
75 %{_iconsdir}/*/*/apps/kmines.png
This page took 0.09384 seconds and 3 git commands to generate.