]> git.pld-linux.org Git - packages/kde4-cervisia.git/blob - kde4-cervisia.spec
- rebuild for g++ ABI changes
[packages/kde4-cervisia.git] / kde4-cervisia.spec
1 #
2 # TODO:
3 # - add man files
4 #
5 %define         orgname         cervisia
6 %define         _state          stable
7 %define         qtver           4.8.1
8
9 Summary:        A KDE CVS frontend
10 Summary(pl.UTF-8):      Frontend do CVS dla KDE
11 Name:           kde4-cervisia
12 Version:        4.14.3
13 Release:        2
14 License:        GPL
15 Group:          X11/Development/Tools
16 Requires:       cvs-client >= 1.10
17 Requires:       kde4-kdebase >= %{version}
18 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
19 # Source0-md5:  25fb6ddc4ab3c249e7f398d3b03814e4
20 URL:            http://www.kde.org/
21 BuildRequires:  QtNetwork-devel >= %{qtver}
22 BuildRequires:  automoc4 >= 0.9.88
23 BuildRequires:  cmake >= 2.8.0
24 BuildRequires:  kde4-kdelibs-devel >= %{version}
25 BuildRequires:  qt4-build >= %{qtver}
26 BuildRequires:  qt4-qmake >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.600
28 Obsoletes:      kde4-kdesdk-cervisia
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _gimpdir        %{_datadir}/gimp/2.0
32 %define         _appdefsdir     %{_datadir}/X11/app-defaults
33 %define         _emacspkgdir    /usr/share/emacs/%(rpm -q --qf %{V} emacs-common | tr -d '[a-z]')
34 %define         _xemacspkgdir   /usr/share/xemacs-packages
35 %define         _zshfcdir       /usr/share/zsh/latest/functions
36
37 %description
38 A KDE CVS frontend. It features:
39 - updating or retrieving the status of a working directory or single
40   files. Files are displayed in different colors depending on their
41   status, and the shown files can be filtered according to their status
42 - common operations like adding, removing and commiting files.
43 - advanced operations like adding and removing watches, editing and
44   unediting files, locking and unlocking.
45 - checking out and importing modules.
46 - graphical diff against the repository and between different
47   revisions.
48 - blame-annotated view of a file.
49 - view of the log messages in tree and list form.
50 - resolving of conflicts in a file.
51 - tagging and branching.
52 - updating to a tag, branch or date.
53 - a Changelog editor coupled with the commit dialog.
54
55 %description -l pl.UTF-8
56 Frontend do CVS dla KDE. Ma następujące możliwości:
57 - uaktualnianie lub odtwarzanie stanu katalogu lub pojedynczych
58   plików; pliki są wyświetlane w różnych kolorach zależnie od ich stanu,
59   a pokazywane pliki mogą być filtrowane według ich stanu
60 - podstawowe operacje, takie jak dodawanie, usuwanie i commitowanie
61   plików
62 - zaawansowane operacje, takie jak dodawanie i usuwanie śledzenia,
63   włączanie i wyłączanie edycji plików, blokowanie i odblokowywanie
64 - pobieranie i importowanie modułów
65 - graficzne wyświetlanie różnic względem repozytorium i między różnymi
66   rewizjami
67 - widok pliku opisany winnymi
68 - widok loga komentarzy do zmian w postaci drzewa i listy
69 - rozwiązywanie konfliktów w pliku
70 - tagowanie i branchowanie
71 - uaktualnianie do taga, brancha lub daty
72 - edytor changelogów połączony z oknem dialogowym do commitowania.
73
74 %prep
75 %setup -q -n %{orgname}-%{version}
76
77 %build
78 install -d build
79 cd build
80 %cmake \
81         ../
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 install -d $RPM_BUILD_ROOT{%{_gimpdir}/palettes,%{_appdefsdir}}
89
90 %{__make} -C build install \
91         DESTDIR=$RPM_BUILD_ROOT \
92         kde_htmldir=%{_kdedocdir}
93
94 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/locolor
95
96 %find_lang      cervisia        --with-kde
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post           -p /sbin/ldconfig
102 %postun         -p /sbin/ldconfig
103
104 %files -f cervisia.lang
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_bindir}/cervisia
107 %attr(755,root,root) %{_bindir}/cvsaskpass
108 %attr(755,root,root) %{_bindir}/cvsservice
109 %attr(755,root,root) %{_libdir}/libkdeinit4_cervisia.so
110 %attr(755,root,root) %{_libdir}/libkdeinit4_cvsservice.so
111 %attr(755,root,root) %{_libdir}/libkdeinit4_cvsaskpass.so
112 %attr(755,root,root) %{_libdir}/kde4/*cervisia*.so
113 %{_datadir}/apps/cervisia*
114 %{_datadir}/config.kcfg/cervisiapart.kcfg
115 %{_datadir}/dbus-1/interfaces/*.cervisia.*.xml
116 %{_datadir}/kde4/services/cvsservice.desktop
117 %{_datadir}/kde4/services/cervisiapart.desktop
118 %{_desktopdir}/kde4/cervisia.desktop
119 %{_iconsdir}/*/*/actions/vcs-*-cvs-*.*
120 %{_iconsdir}/*/*/*/cervisia.png
121 %{_mandir}/man1/cervisia.1*
This page took 0.096031 seconds and 4 git commands to generate.