- updated to 19.04.1 auto/th/ka5-pimcommon-19.04.1-1
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 13 May 2019 09:23:56 +0000 (11:23 +0200)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Mon, 13 May 2019 09:23:56 +0000 (11:23 +0200)
- packaged docs
- macro kframever

ka5-pimcommon.spec

index 0b8d5174e4cbd00b20317ffed0d32c4840cd7a5f..63d2a0ce817a9e3bb0213f19817ce8f26fd3d000 100644 (file)
@@ -1,14 +1,15 @@
-%define                kdeappsver      18.12.1
+%define                kdeappsver      19.04.1
+%define                kframever       5.56.0
 %define                qtver           5.9.0
 %define                kaname          pimcommon
 Summary:       Common PIM libraries
 Name:          ka5-%{kaname}
-Version:       18.12.1
+Version:       19.04.1
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: bfddb74f7d5f214ca870ca04acd890a4
+# Source0-md5: 4bd4c9e0faa27a2c3a38ccbba3667ffc
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5DBus-devel
@@ -30,24 +31,26 @@ BuildRequires:      ka5-kimap-devel >= %{kdeappsver}
 BuildRequires: ka5-kmime-devel >= %{kdeappsver}
 BuildRequires: ka5-kpimtextedit-devel >= %{kdeappsver}
 BuildRequires: ka5-libkdepim-devel >= %{kdeappsver}
-BuildRequires: kf5-extra-cmake-modules >= 5.53.0
-BuildRequires: kf5-karchive-devel >= 5.51.0
-BuildRequires: kf5-kcodecs-devel >= 5.51.0
-BuildRequires: kf5-kcompletion-devel >= 5.51.0
-BuildRequires: kf5-kconfig-devel >= 5.51.0
-BuildRequires: kf5-kconfigwidgets-devel >= 5.51.0
-BuildRequires: kf5-kcoreaddons-devel >= 5.51.0
-BuildRequires: kf5-kdbusaddons-devel >= 5.51.0
-BuildRequires: kf5-ki18n-devel >= 5.51.0
-BuildRequires: kf5-kiconthemes-devel >= 5.51.0
-BuildRequires: kf5-kio-devel >= 5.51.0
-BuildRequires: kf5-kitemmodels-devel >= 5.51.0
-BuildRequires: kf5-kjobwidgets-devel >= 5.51.0
-BuildRequires: kf5-knewstuff-devel >= 5.51.0
-BuildRequires: kf5-kservice-devel >= 5.51.0
-BuildRequires: kf5-kwidgetsaddons-devel >= 5.51.0
-BuildRequires: kf5-kxmlgui-devel >= 5.51.0
+BuildRequires: kf5-extra-cmake-modules >= %{kframever}
+BuildRequires: kf5-karchive-devel >= %{kframever}
+BuildRequires: kf5-kcodecs-devel >= %{kframever}
+BuildRequires: kf5-kcompletion-devel >= %{kframever}
+BuildRequires: kf5-kconfig-devel >= %{kframever}
+BuildRequires: kf5-kconfigwidgets-devel >= %{kframever}
+BuildRequires: kf5-kcoreaddons-devel >= %{kframever}
+BuildRequires: kf5-kdbusaddons-devel >= %{kframever}
+BuildRequires: kf5-kdesignerplugin-devel >= %{kframever}
+BuildRequires: kf5-ki18n-devel >= %{kframever}
+BuildRequires: kf5-kiconthemes-devel >= %{kframever}
+BuildRequires: kf5-kio-devel >= %{kframever}
+BuildRequires: kf5-kitemmodels-devel >= %{kframever}
+BuildRequires: kf5-kjobwidgets-devel >= %{kframever}
+BuildRequires: kf5-knewstuff-devel >= %{kframever}
+BuildRequires: kf5-kservice-devel >= %{kframever}
+BuildRequires: kf5-kwidgetsaddons-devel >= %{kframever}
+BuildRequires: kf5-kxmlgui-devel >= %{kframever}
 BuildRequires: libxslt-progs
+BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: shared-mime-info
@@ -76,15 +79,15 @@ Pliki nagłówkowe dla programistów używających %{kaname}.
 %build
 install -d build
 cd build
-%cmake \
+%cmake -G Ninja \
+       -DHTML_INSTALL_DIR=%{_kdedocdir} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
-%{__make}
+%ninja_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{kaname} --all-name --with-kde
 
This page took 0.104409 seconds and 4 git commands to generate.