- updated to 20.12.3 auto/th/ka5-libkdepim-20.12.3-1
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Tue, 16 Mar 2021 13:16:39 +0000 (14:16 +0100)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Tue, 16 Mar 2021 13:16:39 +0000 (14:16 +0100)
ka5-libkdepim.spec

index 55b6a8c8dcd27f0b598303f7971f33f53ab47766..5cc95e96f8032759960b9ae4a548a4707b8103b8 100644 (file)
@@ -1,15 +1,15 @@
-%define                kdeappsver      19.04.1
+%define                kdeappsver      20.12.3
 %define                kframever       5.56.0
 %define                qtver           5.9.0
 %define                kaname          libkdepim
 Summary:       libkdepim
 Name:          ka5-%{kaname}
-Version:       19.04.1
+Version:       20.12.3
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: d70d9afa3aefeeb98bf642dd14e75fc1
+Source0:       http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
+# Source0-md5: ede8ea4b20129c7aa20c43c78102d0c9
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5DBus-devel
@@ -25,15 +25,15 @@ BuildRequires:      ka5-akonadi-contacts-devel >= %{kdeappsver}
 BuildRequires: ka5-akonadi-devel >= %{kdeappsver}
 BuildRequires: ka5-akonadi-mime-devel >= %{kdeappsver}
 BuildRequires: ka5-akonadi-search-devel >= %{kdeappsver}
-BuildRequires: ka5-kcalcore-devel >= %{kdeappsver}
-BuildRequires: ka5-kcontacts-devel >= %{kdeappsver}
 BuildRequires: ka5-kldap-devel >= %{kdeappsver}
 BuildRequires: kf5-extra-cmake-modules >= %{kframever}
+BuildRequires: kf5-kcalendarcore-devel >= %{kframever}
 BuildRequires: kf5-kcmutils-devel >= %{kframever}
 BuildRequires: kf5-kcodecs-devel >= %{kframever}
 BuildRequires: kf5-kcompletion-devel >= %{kframever}
 BuildRequires: kf5-kconfig-devel >= %{kframever}
 BuildRequires: kf5-kconfigwidgets-devel >= %{kframever}
+BuildRequires: kf5-kcontacts-devel >= %{kframever}
 BuildRequires: kf5-kcoreaddons-devel >= %{kframever}
 BuildRequires: kf5-kdesignerplugin-devel >= %{kframever}
 BuildRequires: kf5-ki18n-devel >= %{kframever}
@@ -92,37 +92,20 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{kaname}_qt.lang
 %defattr(644,root,root,755)
-/etc/xdg/libkdepim.categories
-/etc/xdg/libkdepim.renamecategories
 %attr(755,root,root) %ghost %{_libdir}/libKF5Libkdepim.so.5
 %attr(755,root,root) %{_libdir}/libKF5Libkdepim.so.5.*.*
-%attr(755,root,root) %ghost %{_libdir}/libKF5LibkdepimAkonadi.so.5
-%attr(755,root,root) %{_libdir}/libKF5LibkdepimAkonadi.so.5.*.*
-%attr(755,root,root) %{_libdir}/qt5/plugins/designer/kdepimakonadiwidgets.so
 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/kdepimwidgets.so
-%attr(755,root,root) %{_libdir}/qt5/plugins/kcm_ldap.so
 %{_datadir}/dbus-1/interfaces/org.kde.addressbook.service.xml
 %{_datadir}/dbus-1/interfaces/org.kde.mailtransport.service.xml
-%dir %{_datadir}/kdepimwidgets
-%dir %{_datadir}/kdepimwidgets/pics
-%{_datadir}/kdepimwidgets/pics/addresseelineedit.png
-%{_datadir}/kdepimwidgets/pics/clicklineedit.png
-%{_datadir}/kdepimwidgets/pics/kdateedit.png
-%{_datadir}/kdepimwidgets/pics/ktimeedit.png
-%{_datadir}/kservices5/kcmldap.desktop
+%{_datadir}/qlogging-categories5/libkdepim.categories
+%{_datadir}/qlogging-categories5/libkdepim.renamecategories
 
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/KF5/Libkdepim
-%{_includedir}/KF5/LibkdepimAkonadi
 %{_includedir}/KF5/libkdepim
 %{_includedir}/KF5/libkdepim_version.h
-%{_includedir}/KF5/libkdepimakonadi
-%{_includedir}/KF5/libkdepimakonadi_version.h
 %{_libdir}/cmake/KF5Libkdepim
-%{_libdir}/cmake/KF5LibkdepimAkonadi
 %{_libdir}/cmake/MailTransportDBusService
 %attr(755,root,root) %{_libdir}/libKF5Libkdepim.so
-%attr(755,root,root) %{_libdir}/libKF5LibkdepimAkonadi.so
 %{_libdir}/qt5/mkspecs/modules/qt_Libkdepim.pri
-%{_libdir}/qt5/mkspecs/modules/qt_LibkdepimAkonadi.pri
This page took 0.086022 seconds and 4 git commands to generate.