]> git.pld-linux.org Git - packages/ka5-klines.git/blob - ka5-klines.spec
- updated to 23.08.5
[packages/ka5-klines.git] / ka5-klines.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          klines
8 Summary:        klines
9 Name:           ka5-%{kaname}
10 Version:        23.08.5
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications/Games
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  fd84c33036b29017ec8690080dab8aaf
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Qml-devel >= 5.11.1
20 BuildRequires:  Qt5Quick-devel >= 5.11.1
21 BuildRequires:  Qt5Widgets-devel
22 BuildRequires:  cmake >= 3.20
23 BuildRequires:  gettext-devel
24 BuildRequires:  ka5-libkdegames-devel >= %{kdeappsver}
25 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
26 BuildRequires:  kf5-kconfig-devel >= %{kframever}
27 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
28 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
29 BuildRequires:  kf5-kcrash-devel >= %{kframever}
30 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
31 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
32 BuildRequires:  kf5-ki18n-devel >= %{kframever}
33 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
34 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
35 BuildRequires:  ninja
36 BuildRequires:  qt5-build >= %{qtver}
37 BuildRequires:  rpmbuild(macros) >= 1.164
38 BuildRequires:  shared-mime-info
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 KLines is a simple but highly addictive one player game. The player
45 has to move the colored balls around the game board, gathering them
46 into the lines of the same color by five. Once the line is complete it
47 is removed from the board, therefore freeing precious space.
48
49 %description -l pl.UTF-8
50 KLines jest prostą albo bardzo wciągającą grą dla jednej osoby. Gracz
51 ma przemieszczać kolorowe piłki po planszy, zbierając je po pięć
52 w linii jednego koloru. Kompletne linie są usuwane z planszy
53 zwalniając cenne miejsce.
54
55 %prep
56 %setup -q -n %{kaname}-%{version}
57
58 %build
59 %cmake \
60         -B build \
61         -G Ninja \
62         %{!?with_tests:-DBUILD_TESTING=OFF} \
63         -DHTML_INSTALL_DIR=%{_kdedocdir} \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
65 %ninja_build -C build
66
67 %if %{with tests}
68 ctest --test-dir build
69 %endif
70
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %ninja_install -C build
75
76 %find_lang %{kaname} --all-name --with-kde
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files -f %{kaname}.lang
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/klines
84 %{_desktopdir}/org.kde.klines.desktop
85 %{_datadir}/config.kcfg/klines.kcfg
86 %{_iconsdir}/hicolor/128x128/apps/klines.png
87 %{_iconsdir}/hicolor/16x16/apps/klines.png
88 %{_iconsdir}/hicolor/22x22/apps/klines.png
89 %{_iconsdir}/hicolor/32x32/apps/klines.png
90 %{_iconsdir}/hicolor/48x48/apps/klines.png
91 %{_iconsdir}/hicolor/64x64/apps/klines.png
92 %{_datadir}/klines
93 %{_datadir}/metainfo/org.kde.klines.appdata.xml
94 %{_datadir}/qlogging-categories5/klines.categories
This page took 0.374744 seconds and 4 git commands to generate.