]> git.pld-linux.org Git - packages/ka5-kcolorchooser.git/blob - ka5-kcolorchooser.spec
- updated to 23.08.5
[packages/ka5-kcolorchooser.git] / ka5-kcolorchooser.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.04.1
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kcolorchooser
8 Summary:        KColorChooser
9 Name:           ka5-%{kaname}
10 Version:        23.04.1
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  d5701744f803b15f181bbb245632f060
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  gettext-devel
20 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
21 BuildRequires:  kf5-ki18n-devel >= %{kframever}
22 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
23 BuildRequires:  ninja
24 BuildRequires:  qt5-build >= %{qtver}
25 BuildRequires:  rpmbuild(macros) >= 1.164
26 BuildRequires:  shared-mime-info
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 KColorChooser is a simple application to select the color from the
33 screen or from a pallete.
34
35 Features:
36
37 Select colors from any location on the screen. Select colors from a
38 range of standard palletes available. Color values shown in
39 Hue-Saturation-Value (HSV), Red-Green-Blue (RGB) and HTML formats.
40
41 %description -l pl.UTF-8
42 KColorChooser jest prostą aplikacją do wybrania koloru z ekranu
43 lub z palety.
44
45 Właściwości:
46
47 Zaznaczenie kolorów z dowolnej lokalizacji na ekranie. Wybieranie
48 kolorów z zestawu standardowych palet. Wartości są pokazywane
49 W Hue-Saturation-Value (HSV), Red-Green-Blue (RGB) i w formacie
50 HTML.
51
52 %prep
53 %setup -q -n %{kaname}-%{version}
54
55 %build
56 install -d build
57 cd build
58 %cmake \
59         -G Ninja \
60         %{!?with_tests:-DBUILD_TESTING=OFF} \
61         -DHTML_INSTALL_DIR=%{_kdedocdir} \
62         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
63         ..
64 %ninja_build
65
66 %if %{with tests}
67 ctest
68 %endif
69
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %ninja_install -C build
74
75 %find_lang %{kaname} --all-name --with-kde
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files -f %{kaname}.lang
81 %defattr(644,root,root,755)
82 %attr(755,root,root) %{_bindir}/kcolorchooser
83 %{_desktopdir}/org.kde.kcolorchooser.desktop
84 %{_iconsdir}/hicolor/16x16/apps/kcolorchooser.png
85 %{_iconsdir}/hicolor/22x22/apps/kcolorchooser.png
86 %{_datadir}/metainfo/org.kde.kcolorchooser.appdata.xml
This page took 0.10987 seconds and 3 git commands to generate.