]> git.pld-linux.org Git - packages/ka5-akonadi-notes.git/blob - ka5-akonadi-notes.spec
- updated to 23.08.5
[packages/ka5-akonadi-notes.git] / ka5-akonadi-notes.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          akonadi-notes
8 Summary:        Akonadi Notes
9 Name:           ka5-%{kaname}
10 Version:        23.08.5
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  e22307bd0d49d152e11da58e1baf7394
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Test-devel >= 5.9.0
20 BuildRequires:  Qt5Xml-devel >= 5.9.0
21 BuildRequires:  cmake >= 3.20
22 BuildRequires:  gettext-devel
23 BuildRequires:  ka5-akonadi-devel >= %{kdeappsver}
24 BuildRequires:  ka5-kmime-devel >= %{kdeappsver}
25 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
26 BuildRequires:  kf5-ki18n-devel >= %{kframever}
27 BuildRequires:  ninja
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  shared-mime-info
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Library for akonadi notes integration.
37
38 %description -l pl.UTF-8
39 Biblioteka do integracji z notatkami akonadi.
40
41 %package devel
42 Summary:        Header files for %{kaname} development
43 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for %{kaname} development.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe dla programistów używających %{kaname}.
52
53 %prep
54 %setup -q -n %{kaname}-%{version}
55
56 %build
57 %cmake \
58         -B build \
59         -G Ninja \
60         %{!?with_tests:-DBUILD_TESTING=OFF} \
61         -DHTML_INSTALL_DIR=%{_kdedocdir} \
62         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
63 %ninja_build -C build
64
65 %if %{with tests}
66 ctest --test-dir build
67 %endif
68
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %ninja_install -C build
73
74 %find_lang %{kaname} --all-name --with-kde
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files -f %{kaname}.lang
83 %defattr(644,root,root,755)
84 %ghost %{_libdir}/libKPim5AkonadiNotes.so.5
85 %attr(755,root,root) %{_libdir}/libKPim5AkonadiNotes.so.*.*.*
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_libdir}/qt5/mkspecs/modules/qt_AkonadiNotes.pri
90 %{_includedir}/KPim5/AkonadiNotes
91 %{_libdir}/cmake/KF5AkonadiNotes
92 %{_libdir}/cmake/KPim5AkonadiNotes
93 %{_libdir}/libKPim5AkonadiNotes.so
This page took 0.131156 seconds and 4 git commands to generate.