]> git.pld-linux.org Git - packages/irssi.git/commitdiff
fix/workaround ac problems
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 12 Sep 2001 20:02:26 +0000 (20:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    irssi-am_ac.patch -> 1.1
    irssi.spec -> 1.43

irssi-am_ac.patch [new file with mode: 0644]
irssi.spec

diff --git a/irssi-am_ac.patch b/irssi-am_ac.patch
new file mode 100644 (file)
index 0000000..64103e2
--- /dev/null
@@ -0,0 +1,108 @@
+diff -urN irssi-0.7.98.4.org/configure.in irssi-0.7.98.4/configure.in
+--- irssi-0.7.98.4.org/configure.in    Tue Sep 11 23:32:08 2001
++++ irssi-0.7.98.4/configure.in        Tue Sep 11 23:53:17 2001
+@@ -9,28 +9,7 @@
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_STDC_HEADERS
+-AC_ARG_PROGRAM
+-AM_PROG_LIBTOOL
+-
+-dnl * ahem.. :) we don't want static libraries for modules
+-if test "x$lt_target" = "x"; then
+-        if test "$target" = "NONE"; then
+-              lt_target="$host"
+-      else
+-              lt_target="$target"
+-      fi
+-fi
+-dnl * --disable-static isn't a good idea, complain if it's used
+-if test "x$enable_static" = "xno"; then
+-      AC_ERROR([Don't give --disable-static option to configure])
+-fi
+-
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+-$libtool_flags --disable-static --output=libtool-shared --no-verify $ac_aux_dir/ltmain.sh $lt_target \
+-|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+-$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
+-|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
++AC_PROG_LIBTOOL
+ AC_CHECK_HEADERS(string.h stdlib.h unistd.h dirent.h sys/ioctl.h libintl.h)
+@@ -341,60 +320,7 @@
+ PROG_LIBS="$PROG_LIBS $GLIB_LIBS"
+-dnl **
+-dnl ** check if we can link dynamic libraries to modules
+-dnl ** also checks if libraries are built to .libs dir
+-dnl **
+-
+-AC_MSG_CHECKING([if we can link dynamic libraries with modules])
+-DYNLIB_MODULES=no
+-
+-dnl ** compile object file
+-cat > conftest.c <<EOF
+-#include <math.h>
+-int modfunc(void){return (int)floor(1.2);}
+-EOF
+-./libtool --mode=compile $CC $CFLAGS -c conftest.c 2> /dev/null > /dev/null
+-if test ! -s conftest.lo; then
+-  AC_ERROR([error compiling test module])
+-fi
+-
+-dnl ** link to library
+-./libtool --mode=link $CC $CFLAGS $LDFLAGS -rpath /usr/lib conftest.lo -lm -o libconftest.la > /dev/null
+-if test ! -s .libs/libconftest.a; then
+-  AC_ERROR([error, can't even find .a library])
+-fi
+-
+-dnl ** check if dynamic linking worked
+-libfile=`grep ^library_names libconftest.la|$sedpath "s/library_names='\(.*\)'.*/\1/"|$sedpath 's/.* \([[^ ]]*\)$/\1/'`
+-if test ! -s .libs/$libfile; then
+-  AC_MSG_RESULT([no, error linking test module])
+-else
+-  cat > conftest.c <<EOF
+-#include <gmodule.h>
+-main() {
+-GModule *m; int (*modfunc)(void);
+-m = g_module_open(".libs/$libfile", 0);
+-if (!m) g_print("error loading: %s", g_module_error());
+-else if (!g_module_symbol(m, "modfunc", (gpointer *) &modfunc))
+-  g_print("modfunc() symbol not found from module");
+-else if (modfunc() == 1) g_print("ok"); else g_print("wrong result?! 1 vs %d", modfunc());
+-return 0; }
+-EOF
+-  $CC $CFLAGS conftest.c -o conftest $GLIB_CFLAGS $GLIB_LIBS 2> /dev/null > /dev/null
+-  if test ! -s conftest; then
+-    AC_MSG_RESULT([no, error compiling test program])
+-  else
+-    status="`./conftest`"
+-    if test "x$status" = "xok"; then
+-      DYNLIB_MODULES=yes
+-      AC_MSG_RESULT([yes])
+-    else
+-      AC_MSG_RESULT([no, error running: $status])
+-    fi
+-  fi
+-fi
+-rm -rf conftest conftest.* libconftest.* .libs
++DYNLIB_MODULES=yes
+ dnl **
+ dnl ** curses checks
+diff -urN irssi-0.7.98.4.org/curses.m4 irssi-0.7.98.4/curses.m4
+--- irssi-0.7.98.4.org/curses.m4       Tue Sep 11 23:32:09 2001
++++ irssi-0.7.98.4/curses.m4   Wed Sep 12 00:10:58 2001
+@@ -210,8 +210,7 @@
+           AC_MSG_RESULT(Found ncurses on $1/$2)
+           CURSES_LIBS="$3"
+-          AC_CHECK_LIB(ncurses, initscr, [
+-          ], [
++          AC_CHECK_LIB(ncurses, initscr,, [
+                 CHECKLIBS=`echo "$3"|sed 's/-lncurses/-lcurses/g'`
+               AC_CHECK_LIB(curses, initscr, [
+                       CURSES_LIBS="$CHECKLIBS"
index 40e402d2c513b4364ff206e356f5f9f9fa2e03f4..1305b3344ce707c08117d290e27a5e056c62f293 100644 (file)
@@ -10,17 +10,16 @@ License:    GPL
 Group:         Applications/Communications
 Group(pl):     Aplikacje/Komunikacja
 Source0:       http://www.irssi.org/files/irssi-%{version}.tar.bz2
-Source1:       http://xlife.dhs.org/irssi/%{name}-icon.png
-Source2:       %{name}.desktop
-Source3:       %{name}.png
+Source1:       %{name}.desktop
+Source2:       %{name}.png
+Patch0:                %{name}-am_ac.patch
+BuildRequires: automake
+BuildRequires: autoconf
+BuildRequires: libtool
 BuildRequires: ncurses-devel >= 5.0
 BuildRequires: gettext-devel
 BuildRequires: glib-devel >= 1.2.0
 %{?!_without_perl:BuildRequires:       perl-devel >= 5.6.1}
-%{?_with_gnome:BuildRequires:  libPropList-devel >= 0.9.1-2}
-%{?_with_gnome:BuildRequires:  imlib-devel}
-%{?_with_gnome:BuildRequires:  gtk+-devel}
-%{?_with_gnome:BuildRequires:  gnome-libs-devel}
 Obsoletes:     %{name}-speech
 Obsoletes:     %{name}-sql
 URL:           http://www.irssi.org/
@@ -37,13 +36,21 @@ Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
+ln -s libtool libtool-shared
 NOCONFIGURE=1 ./autogen.sh
+libtoolize --copy --force
+gettextize --copy --force
+aclocal -I .
+autoheader
+autoconf
+automake -a -c
 %configure \
        --without-socks \
        --with-textui=ncurses \
-       --without-bot \
+       --with-bot \
        --with-proxy \
        --with-modules \
        %{?!_without_perl:--enable-perl=yes} \
This page took 0.037251 seconds and 4 git commands to generate.