]> git.pld-linux.org Git - packages/irssi.git/blobdiff - irssi.spec
- updated to 1.2.1 (solves IRSSI-SA-2019-06)
[packages/irssi.git] / irssi.spec
index 750c3cfb3474e0bda3dbe7e0723d62ee9ee2843c..f5245e28d2c861a43f8a5aeebb8ecab07b945e46 100644 (file)
@@ -1,29 +1,28 @@
+# TODO:
+# - color_support_for_gui_entry needs update or to eb removed
 #
 # Conditional build:
 %bcond_without perl    # without perl support
-%bcond_without ipv6    # without IPv6 support
-%bcond_without ssl     # without SSL  support
 %bcond_without dynamic # without dynamic libraries
 %bcond_without xmpp    # without plugin
 
 %define                no_install_post_check_so        1
 
 %define                idea_ver        0.1.46
-%define                xmpp_ver        0.52
-%define                irssi_perl_version 20141011
+%define                xmpp_ver        0.53
+%define                irssi_perl_version 20190628
 %{?with_perl:%include  /usr/lib/rpm/macros.perl}
 Summary:       Irssi is a IRC client
 Summary(fr.UTF-8):     Irssi est un client IRC
 Summary(hu.UTF-8):     Irssi egy IRC kliens
 Summary(pl.UTF-8):     Irssi - wygodny w użyciu klient IRC
 Name:          irssi
-Version:       0.8.17
+Version:       1.2.1
 Release:       1
 License:       GPL
 Group:         Applications/Communications
-#Source0:      http://www.irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
-Source0:       http://www.irssi.org/files/%{name}-%{version}.tar.gz
-# Source0-md5: 00cde2ba7ba37af9e3df451f430ecdea
+Source0:       https://github.com/irssi/irssi/releases/download/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: f48f655ac3f13d0cc2d8e5b80b9ac042
 Source1:       %{name}.desktop
 Source2:       %{name}.png
 # NXDOMAIN
@@ -31,27 +30,32 @@ Source2:    %{name}.png
 Source3:       %{name}-idea-%{idea_ver}.tar.gz
 # Source3-md5: c326efe317b8f67593a3cd46d5557280
 Source4:       http://cybione.org/~irssi-xmpp/files/irssi-xmpp-%{xmpp_ver}.tar.gz
-# Source4-md5: f48d66ddf6a6d8e4d04bfc44b83dc3c7
+# Source4-md5: 8c9906e4efbd6f3c8bd8420f0ac8fd91
 Patch0:                %{name}-dcc-send-limit.patch
 Patch1:                %{name}-home_etc.patch
 Patch2:                %{name}-idea-listlen.patch
 Patch3:                %{name}-gcc4.patch
 Patch4:                %{name}-dynamic.patch
-Patch5:                %{name}-invalid_free.patch
+
 Patch6:                %{name}-color_support_for_gui_entry.patch
 Patch7:                %{name}-libs-nopoison.patch
 Patch8:                am.patch
+Patch9:                %{name}-idea-glib.patch
+Patch10:       %{name}-xmpp.patch
 URL:           http://www.irssi.org/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
 # for idea only
 BuildRequires: glib-devel
 BuildRequires: glib2-devel >= 2.24.0
+BuildRequires: libgcrypt-devel >= 1.2.0
+BuildRequires: libotr-devel >= 4.1.0
 BuildRequires: libtool
+BuildRequires: libutf8proc-devel
 %{?with_xmpp:BuildRequires:    loudmouth-devel}
 BuildRequires: ncurses-devel >= 5.0
-%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+BuildRequires: openssl-devel >= 0.9.7d
 %{?with_perl:BuildRequires:    perl-devel >= 1:5.8.4}
 BuildRequires: pkgconfig
 BuildRequires: popt-devel
@@ -118,8 +122,8 @@ Ten pakiet zawiera wtyczkę do Irssi z obsługą XMPP.
 %if %{with dynamic}
 %patch4 -p1
 %endif
-%patch5 -p1
-%patch6 -p0
+
+#%patch6 -p0
 %patch7 -p1
 
 echo 'AC_DEFUN([AM_PATH_GLIB],[:])' > glib1.m4
@@ -127,6 +131,8 @@ echo 'AC_DEFUN([AM_PATH_GLIB],[:])' > glib1.m4
 mv irssi-idea{-%{idea_ver},}
 mv irssi-xmpp{-%{xmpp_ver},}
 %patch8 -p1
+%patch9 -p0
+%patch10 -p0
 
 # hack
 %{__sed} -i -e 's#\./libtool#%{_bindir}/libtool#g' 'configure.ac'
@@ -143,19 +149,17 @@ fi
 %{__autoconf}
 %{__automake}
 %configure \
+       --disable-silent-rules \
        --without-socks \
        --with-bot \
        --with-textui \
        --with-proxy \
-       --with-terminfo \
        --with-modules \
+       --with-otr \
        %{?with_perl:--with-perl=yes} \
        %{?with_perl:--with-perl-lib=vendor} \
        %{!?with_perl:--with-perl=no} \
-       %{?with_ipv6:--enable-ipv6} \
-       --enable-true-color \
-       --enable-nls \
-       --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
+       --enable-true-color
 
 %{__make}
 
@@ -166,10 +170,11 @@ cd irssi-idea
 %{__aclocal} -I .
 %{__autoconf}
 %{__automake}
-%configure
+%configure \
+       --disable-silent-rules
 %{__make}
-
 cd ..
+
 export IRSSI_INCLUDE=`pwd`
 cd irssi-xmpp
 %{__make}
@@ -178,8 +183,8 @@ cd irssi-xmpp
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       docdir=%{_datadir}/%{name}-%{version}
+       docdir=%{_datadir}/%{name}-%{version} \
+       DESTDIR=$RPM_BUILD_ROOT
 
 # scripts packaged by irssi-scripts.spec
 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/scripts/*
@@ -220,6 +225,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/irssi
 %dir %{_libdir}/irssi/modules
 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
+%attr(755,root,root) %{_libdir}/irssi/modules/libotr_core.so*
 %if %{with dynamic}
 %attr(755,root,root) %{_libdir}/libirssi*.so.*
 %endif
This page took 0.070208 seconds and 4 git commands to generate.