]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- added bcond to disable support for SSL
[packages/irssi.git] / irssi.spec
1 # Conditional build:
2 %bcond_without  perl    # without perl support
3 %bcond_without  ipv6    # without IPv6 support
4 %bcond_without  ssl     # without SSL  support
5 #
6 %define         _idea_ver       0.1.46
7 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
8 Summary:        Irssi is a IRC client
9 Summary(fr):    Irssi est un client IRC
10 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
11 Name:           irssi
12 Version:        0.8.9
13 Release:        1
14 License:        GPL
15 Group:          Applications/Communications
16 Source0:        http://real.irssi.org/files/%{name}-%{version}.tar.bz2
17 # Source0-md5:  6610ee0e27922f447e40828cf7dee507
18 Source1:        %{name}.desktop
19 Source2:        %{name}.png
20 Source3:        http://www.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
21 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
22 #Patch0:                %{name}-dcc-send-limit.patch
23 Patch1:         %{name}-channel_auto_who.patch
24 Patch2:         %{name}-tinfo.patch
25 Patch3:         %{name}-home_etc.patch
26 URL:            http://www.irssi.org/
27 BuildRequires:  automake
28 BuildRequires:  autoconf
29 BuildRequires:  libtool
30 BuildRequires:  gettext-devel
31 BuildRequires:  glib-devel
32 BuildRequires:  glib2-devel >= 2.1.0
33 BuildRequires:  ncurses-devel >= 5.0
34 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7c}
35 %{?with_perl:BuildRequires:     perl-devel >= 5.6.1}
36 BuildRequires:  pkgconfig
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38 Obsoletes:      %{name}-speech
39 Obsoletes:      %{name}-sql
40
41 %description
42 Irssi is a textUI IRC client with IPv6 support.
43
44 %description -l fr
45 Irssi est client IRC.
46
47 %description -l pl
48 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
49
50 %package plugin-idea
51 Summary:        Irssi plugin IDEA crypt
52 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
53 Group:          Applications/Communications
54 Requires:       %{name} = %{version}
55
56 %description plugin-idea
57 This package contains IDEA Crypt plugin for Irssi.
58
59 %description plugin-idea
60 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
61
62 %prep
63 %setup -q -a3
64 #%patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67 %patch3 -p1
68
69 %build
70 rm -f missing
71 %{__libtoolize}
72 %{__aclocal} -I .
73 %{__autoconf}
74 %{__automake}
75 %configure \
76         --without-socks \
77         --with-bot \
78         --with-textui \
79         --with-proxy \
80         --with-terminfo \
81         --with-modules \
82         %{?with_perl:--with-perl=yes} \
83         %{?with_perl:--with-perl-lib=vendor} \
84         %{!?with_perl:--with-perl=no} \
85         %{?with_ipv6:--enable-ipv6} \
86         --enable-nls \
87         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
88
89 %{__make}
90
91 cd irssi-idea-%{_idea_ver}
92 rm -f missing
93 %{__libtoolize}
94 %{__aclocal} -I .
95 %{__autoconf}
96 %{__automake}
97 %configure
98
99 %{__make}
100
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         docdir=%{_datadir}/%{name}-%{version}
109
110 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
111 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
112
113 cd irssi-idea-%{_idea_ver}
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog README TODO NEWS docs/*.txt
123 %attr(755,root,root) %{_bindir}/*
124 %dir %{_libdir}/irssi
125 %dir %{_libdir}/irssi/modules
126 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
127 %{_datadir}/%{name}
128 %{_desktopdir}/irssi.desktop
129 %{_pixmapsdir}/*
130 %{_sysconfdir}/irssi.conf
131 %{_mandir}/man1/*
132
133 %if %{with perl}
134 %{perl_vendorarch}/*.pm
135 %dir %{perl_vendorarch}/Irssi
136 %{perl_vendorarch}/Irssi/*.pm
137
138 %dir %{perl_vendorarch}/auto/Irssi
139 %{perl_vendorarch}/auto/Irssi/*.bs
140 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
141
142 %dir %{perl_vendorarch}/auto/Irssi/Irc
143 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
144 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
145
146 %dir %{perl_vendorarch}/auto/Irssi/TextUI
147 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
148 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
149
150 %dir %{perl_vendorarch}/auto/Irssi/UI
151 %{perl_vendorarch}/auto/Irssi/UI/*.bs
152 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
153 %endif
154
155 %files plugin-idea
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.111441 seconds and 4 git commands to generate.