]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- removed obsolete channel_auto_who patch
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 #
7 %define         _rel rc5
8 %define         _idea_ver       0.1.46
9 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
10 Summary:        Irssi is a IRC client
11 Summary(fr):    Irssi est un client IRC
12 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
13 Name:           irssi
14 Version:        0.8.10
15 Release:        0.%{_rel}
16 License:        GPL
17 Group:          Applications/Communications
18 Source0:        http://real.irssi.org/files/%{name}-%{version}-%{_rel}.tar.gz
19 # Source0-md5:  7c0b6c1533c85e918f41ded1238e4ca1
20 Source1:        %{name}.desktop
21 Source2:        %{name}.png
22 Source3:        http://www.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
23 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
24 Patch0:         %{name}-dcc-send-limit.patch
25 Patch1:         %{name}-tinfo.patch
26 Patch2:         %{name}-home_etc.patch
27 Patch3:         %{name}.conf.patch
28 Patch4:         %{name}-idea-listlen.patch
29 URL:            http://www.irssi.org/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  gettext-devel
33 BuildRequires:  glib-devel
34 BuildRequires:  glib2-devel >= 2.1.0
35 BuildRequires:  libtool
36 BuildRequires:  ncurses-devel >= 5.0
37 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
38 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
39 BuildRequires:  pkgconfig
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41 Obsoletes:      %{name}-speech
42 Obsoletes:      %{name}-sql
43
44 %description
45 Irssi is a textUI IRC client with IPv6 support.
46
47 %description -l fr
48 Irssi est client IRC.
49
50 %description -l pl
51 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
52
53 %package plugin-idea
54 Summary:        Irssi plugin IDEA crypt
55 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
56 Group:          Applications/Communications
57 Requires:       %{name} = %{version}
58
59 %description plugin-idea
60 This package contains IDEA Crypt plugin for Irssi.
61
62 %description plugin-idea
63 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
64
65 %prep
66 %setup -q -n %{name}-%{version}-%{_rel} -a3
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70 %patch3 -p1
71 %patch4 -p1
72
73 %build
74 rm -f missing
75 %{__libtoolize}
76 %{__aclocal} -I .
77 %{__autoconf}
78 %{__automake}
79 %configure \
80         --without-socks \
81         --with-bot \
82         --with-textui \
83         --with-proxy \
84         --with-terminfo \
85         --with-modules \
86         %{?with_perl:--with-perl=yes} \
87         %{?with_perl:--with-perl-lib=vendor} \
88         %{!?with_perl:--with-perl=no} \
89         %{?with_ipv6:--enable-ipv6} \
90         --enable-nls \
91         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
92
93 %{__make}
94
95 cd irssi-idea-%{_idea_ver}
96 rm -f missing
97 %{__libtoolize}
98 %{__aclocal} -I .
99 %{__autoconf}
100 %{__automake}
101 %configure
102
103 %{__make}
104
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT \
112         docdir=%{_datadir}/%{name}-%{version}
113
114 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
115 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
116
117 %{__make} -C irssi-idea-%{_idea_ver} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
126 %attr(755,root,root) %{_bindir}/*
127 %dir %{_libdir}/irssi
128 %dir %{_libdir}/irssi/modules
129 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
130 %{_datadir}/%{name}
131 %{_desktopdir}/irssi.desktop
132 %{_pixmapsdir}/*
133 %{_sysconfdir}/irssi.conf
134 %{_mandir}/man1/*
135
136 %if %{with perl}
137 %{perl_vendorarch}/*.pm
138 %dir %{perl_vendorarch}/Irssi
139 %{perl_vendorarch}/Irssi/*.pm
140
141 %dir %{perl_vendorarch}/auto/Irssi
142 %{perl_vendorarch}/auto/Irssi/*.bs
143 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
144
145 %dir %{perl_vendorarch}/auto/Irssi/Irc
146 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
147 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
148
149 %dir %{perl_vendorarch}/auto/Irssi/TextUI
150 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
151 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
152
153 %dir %{perl_vendorarch}/auto/Irssi/UI
154 %{perl_vendorarch}/auto/Irssi/UI/*.bs
155 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
156 %endif
157
158 %files plugin-idea
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.067047 seconds and 4 git commands to generate.