]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- rel 6; hack for configure tests
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 %bcond_without  dynamic # without dynamic libraries
7 #
8 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
9
10 Summary:        Irssi is a IRC client
11 Summary(fr.UTF-8):      Irssi est un client IRC
12 Summary(pl.UTF-8):      Irssi - wygodny w użyciu klient IRC
13 Name:           irssi
14 Version:        0.8.12
15 Release:        6
16 License:        GPL
17 Group:          Applications/Communications
18 #Source0:       http://www.irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
19 Source0:        http://www.irssi.org/files/%{name}-%{version}.tar.gz
20 # Source0-md5:  ddf717a430e1c13a272f528c4f529430
21 Source1:        %{name}.desktop
22 Source2:        %{name}.png
23 %define         idea_ver        0.1.46
24 # NXDOMAIN
25 #Source3:       http://real.irssi.org/files/plugins/idea/%{name}-idea-%{idea_ver}.tar.gz
26 Source3:        %{name}-idea-%{idea_ver}.tar.gz
27 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
28 Patch0:         %{name}-dcc-send-limit.patch
29 Patch1:         %{name}-tinfo.patch
30 Patch2:         %{name}-home_etc.patch
31 Patch3:         %{name}.conf.patch
32 Patch4:         %{name}-idea-listlen.patch
33 Patch5:         %{name}-gcc4.patch
34 Patch6:         %{name}-dynamic.patch
35 Patch7:         %{name}-invalid_free.patch
36 URL:            http://www.irssi.org/
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 BuildRequires:  gettext-devel
40 # for idea only
41 BuildRequires:  glib-devel >= 1:1.2.10-13
42 BuildRequires:  glib2-devel >= 2.1.0
43 BuildRequires:  libtool
44 BuildRequires:  ncurses-devel >= 5.0
45 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
46 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
47 BuildRequires:  pkgconfig
48 BuildRequires:  popt-devel
49 %{?with_perl:BuildRequires:     rpm-perlprov}
50 BuildRequires:  rpmbuild(macros) >= 1.315
51 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
52 Obsoletes:      irssi-speech
53 Obsoletes:      irssi-sql
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %if %{with dynamic}
57 %define         filterout_ld    -Wl,--as-needed
58 %endif
59
60 %description
61 Irssi is a textUI IRC client with IPv6 support.
62
63 %description -l fr.UTF-8
64 Irssi est client IRC.
65
66 %description -l pl.UTF-8
67 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
68
69 %package plugin-idea
70 Summary:        Irssi plugin IDEA crypt
71 Summary(pl.UTF-8):      Wtyczka do irssi do szyfrowania IDEA
72 Group:          Applications/Communications
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       glib >= 1:1.2.10-13
75
76 %description plugin-idea
77 This package contains IDEA Crypt plugin for Irssi.
78
79 %description plugin-idea -l pl.UTF-8
80 Ten pakiet zawiera wtyczkę do Irssi z szyfrowaniem IDEA.
81
82 %prep
83 %setup -q -a3
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88 %patch4 -p1
89 %patch5 -p1
90 %if %{with dynamic}
91 %patch6 -p1
92 %endif
93 %patch7 -p1
94
95 echo 'AC_DEFUN([AM_PATH_GLIB],[:])' > glib1.m4
96
97 # hack
98 sed -i -e 's#\./libtool#%{_bindir}/libtool#g' configure.in
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I .
103 %{__autoconf}
104 %{__automake}
105 %configure \
106         --without-socks \
107         --with-bot \
108         --with-textui \
109         --with-proxy \
110         --with-terminfo \
111         --with-modules \
112         %{?with_perl:--with-perl=yes} \
113         %{?with_perl:--with-perl-lib=vendor} \
114         %{!?with_perl:--with-perl=no} \
115         %{?with_ipv6:--enable-ipv6} \
116         --enable-nls \
117         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
118
119 %{__make}
120
121 # to fool idea configure script
122 touch irssi-config
123 cd irssi-idea-%{idea_ver}
124 %{__libtoolize}
125 %{__aclocal} -I .
126 %{__autoconf}
127 %{__automake}
128 %configure
129
130 %{__make}
131
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT \
139         docdir=%{_datadir}/%{name}-%{version}
140
141 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
142 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
143
144 %{__make} -C irssi-idea-%{idea_ver} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
153 %attr(755,root,root) %{_bindir}/*
154 %dir %{_libdir}/irssi
155 %dir %{_libdir}/irssi/modules
156 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
157 %if %{with dynamic}
158 %attr(755,root,root) %{_libdir}/libirssi*.so.*
159 %endif
160 %{_datadir}/%{name}
161 %{_desktopdir}/irssi.desktop
162 %{_pixmapsdir}/*
163 %{_sysconfdir}/irssi.conf
164 %{_mandir}/man1/*
165
166 %if %{with perl}
167 %{perl_vendorarch}/*.pm
168 %dir %{perl_vendorarch}/Irssi
169 %{perl_vendorarch}/Irssi/*.pm
170
171 %dir %{perl_vendorarch}/auto/Irssi
172 %{perl_vendorarch}/auto/Irssi/*.bs
173 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
174
175 %dir %{perl_vendorarch}/auto/Irssi/Irc
176 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
177 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
178
179 %dir %{perl_vendorarch}/auto/Irssi/TextUI
180 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
181 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
182
183 %dir %{perl_vendorarch}/auto/Irssi/UI
184 %{perl_vendorarch}/auto/Irssi/UI/*.bs
185 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
186 %endif
187
188 %files plugin-idea
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.065591 seconds and 4 git commands to generate.