]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- fix desc pl
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 %bcond_without  dynamic # without dynamic libraries
7
8 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
9
10 Summary:        Irssi is a IRC client
11 Summary(fr):    Irssi est un client IRC
12 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
13 Name:           irssi
14 Version:        0.8.10a
15 Release:        3
16 License:        GPL
17 Group:          Applications/Communications
18 #Source0:       http://irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
19 Source0:        http://irssi.org/files/%{name}-%{version}.tar.gz
20 # Source0-md5:  78140796205c6fa1c43e46d2e79e60aa
21 Source1:        %{name}.desktop
22 Source2:        %{name}.png
23 %define         _idea_ver       0.1.46
24 Source3:        http://real.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
25 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
26 Patch0:         %{name}-dcc-send-limit.patch
27 Patch1:         %{name}-tinfo.patch
28 Patch2:         %{name}-home_etc.patch
29 Patch3:         %{name}.conf.patch
30 Patch4:         %{name}-idea-listlen.patch
31 Patch5:         %{name}-gcc4.patch
32 Patch6:         %{name}-dynamic.patch
33 Patch7:         %{name}-invalid_free.patch
34 URL:            http://www.irssi.org/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib-devel >= 1:1.2.10-13
39 BuildRequires:  glib2-devel >= 2.1.0
40 BuildRequires:  libtool
41 BuildRequires:  ncurses-devel >= 5.0
42 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
43 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
44 BuildRequires:  pkgconfig
45 BuildRequires:  popt-devel
46 %{?with_perl:BuildRequires:     rpm-perlprov}
47 BuildRequires:  rpmbuild(macros) >= 1.315
48 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
49 Obsoletes:      irssi-speech
50 Obsoletes:      irssi-sql
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %if %{with dynamic}
54 %define         filterout_ld    -Wl,--as-needed
55 %endif
56
57 %description
58 Irssi is a textUI IRC client with IPv6 support.
59
60 %description -l fr
61 Irssi est client IRC.
62
63 %description -l pl
64 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
65
66 %package plugin-idea
67 Summary:        Irssi plugin IDEA crypt
68 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
69 Group:          Applications/Communications
70 Requires:       %{name} = %{version}-%{release}
71
72 %description plugin-idea
73 This package contains IDEA Crypt plugin for Irssi.
74
75 %description plugin-idea -l pl
76 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
77
78 %prep
79 %setup -q -n %{name}-0.8.10 -a3
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83 %patch3 -p1
84 %patch4 -p1
85 %patch5 -p1
86 %if %{with dynamic}
87 %patch6 -p1
88 %endif
89 %patch7 -p1
90
91 %build
92 rm -f missing
93 %{__libtoolize}
94 %{__aclocal} -I .
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --without-socks \
99         --with-bot \
100         --with-textui \
101         --with-proxy \
102         --with-terminfo \
103         --with-modules \
104         %{?with_perl:--with-perl=yes} \
105         %{?with_perl:--with-perl-lib=vendor} \
106         %{!?with_perl:--with-perl=no} \
107         %{?with_ipv6:--enable-ipv6} \
108         --enable-nls \
109         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
110
111 %{__make}
112
113 cd irssi-idea-%{_idea_ver}
114 rm -f missing
115 %{__libtoolize}
116 %{__aclocal} -I .
117 %{__autoconf}
118 %{__automake}
119 %configure
120
121 %{__make}
122
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT \
130         docdir=%{_datadir}/%{name}-%{version}
131
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
133 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
134
135 %{__make} -C irssi-idea-%{_idea_ver} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
144 %attr(755,root,root) %{_bindir}/*
145 %dir %{_libdir}/irssi
146 %dir %{_libdir}/irssi/modules
147 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
148 %if %{with dynamic}
149 %attr(755,root,root) %{_libdir}/libirssi*.so.*
150 %endif
151 %{_datadir}/%{name}
152 %{_desktopdir}/irssi.desktop
153 %{_pixmapsdir}/*
154 %{_sysconfdir}/irssi.conf
155 %{_mandir}/man1/*
156
157 %if %{with perl}
158 %{perl_vendorarch}/*.pm
159 %dir %{perl_vendorarch}/Irssi
160 %{perl_vendorarch}/Irssi/*.pm
161
162 %dir %{perl_vendorarch}/auto/Irssi
163 %{perl_vendorarch}/auto/Irssi/*.bs
164 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
165
166 %dir %{perl_vendorarch}/auto/Irssi/Irc
167 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
168 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
169
170 %dir %{perl_vendorarch}/auto/Irssi/TextUI
171 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
172 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
173
174 %dir %{perl_vendorarch}/auto/Irssi/UI
175 %{perl_vendorarch}/auto/Irssi/UI/*.bs
176 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
177 %endif
178
179 %files plugin-idea
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.084541 seconds and 4 git commands to generate.