]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- massive attack: added Sources-size
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 #
7 %define         _idea_ver       0.1.46
8 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
9 Summary:        Irssi is a IRC client
10 Summary(fr):    Irssi est un client IRC
11 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
12 Name:           irssi
13 Version:        0.8.10
14 %define         _rc     rc5
15 Release:        0.%{_rc}.3
16 License:        GPL
17 Group:          Applications/Communications
18 Source0:        http://real.irssi.org/files/%{name}-%{version}-%{_rc}.tar.gz
19 # Source0-md5:  7c0b6c1533c85e918f41ded1238e4ca1
20 # Source0-size: 1192158
21 Source1:        %{name}.desktop
22 Source2:        %{name}.png
23 Source3:        http://www.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
24 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
25 # Source3-size: 182673
26 Patch0:         %{name}-dcc-send-limit.patch
27 Patch1:         %{name}-tinfo.patch
28 Patch2:         %{name}-home_etc.patch
29 Patch3:         %{name}.conf.patch
30 Patch4:         %{name}-idea-listlen.patch
31 URL:            http://www.irssi.org/
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  gettext-devel
35 BuildRequires:  glib-devel
36 BuildRequires:  glib2-devel >= 2.1.0
37 BuildRequires:  libtool
38 BuildRequires:  ncurses-devel >= 5.0
39 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
40 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
41 BuildRequires:  pkgconfig
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43 Obsoletes:      %{name}-speech
44 Obsoletes:      %{name}-sql
45
46 %description
47 Irssi is a textUI IRC client with IPv6 support.
48
49 %description -l fr
50 Irssi est client IRC.
51
52 %description -l pl
53 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
54
55 %package plugin-idea
56 Summary:        Irssi plugin IDEA crypt
57 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
58 Group:          Applications/Communications
59 Requires:       %{name} = %{version}
60
61 %description plugin-idea
62 This package contains IDEA Crypt plugin for Irssi.
63
64 %description plugin-idea
65 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
66
67 %prep
68 %setup -q -n %{name}-%{version}-%{_rc} -a3
69 %patch0 -p1
70 %patch1 -p1
71 %patch2 -p1
72 %patch3 -p1
73 %patch4 -p1
74
75 %build
76 rm -f missing
77 %{__libtoolize}
78 %{__aclocal} -I .
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         --without-socks \
83         --with-bot \
84         --with-textui \
85         --with-proxy \
86         --with-terminfo \
87         --with-modules \
88         %{?with_perl:--with-perl=yes} \
89         %{?with_perl:--with-perl-lib=vendor} \
90         %{!?with_perl:--with-perl=no} \
91         %{?with_ipv6:--enable-ipv6} \
92         --enable-nls \
93         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
94
95 %{__make}
96
97 cd irssi-idea-%{_idea_ver}
98 rm -f missing
99 %{__libtoolize}
100 %{__aclocal} -I .
101 %{__autoconf}
102 %{__automake}
103 %configure
104
105 %{__make}
106
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         docdir=%{_datadir}/%{name}-%{version}
115
116 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
117 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
118
119 %{__make} -C irssi-idea-%{_idea_ver} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %triggerpostun -- %{name} <= 0.8.9-4
126 echo "WARNING!!!"
127 echo "Please set your national charset: f.e. /set term_charset ISO8859-2"
128 echo
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
133 %attr(755,root,root) %{_bindir}/*
134 %dir %{_libdir}/irssi
135 %dir %{_libdir}/irssi/modules
136 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
137 %{_datadir}/%{name}
138 %{_desktopdir}/irssi.desktop
139 %{_pixmapsdir}/*
140 %{_sysconfdir}/irssi.conf
141 %{_mandir}/man1/*
142
143 %if %{with perl}
144 %{perl_vendorarch}/*.pm
145 %dir %{perl_vendorarch}/Irssi
146 %{perl_vendorarch}/Irssi/*.pm
147
148 %dir %{perl_vendorarch}/auto/Irssi
149 %{perl_vendorarch}/auto/Irssi/*.bs
150 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
151
152 %dir %{perl_vendorarch}/auto/Irssi/Irc
153 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
154 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
155
156 %dir %{perl_vendorarch}/auto/Irssi/TextUI
157 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
158 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
159
160 %dir %{perl_vendorarch}/auto/Irssi/UI
161 %{perl_vendorarch}/auto/Irssi/UI/*.bs
162 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
163 %endif
164
165 %files plugin-idea
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.035138 seconds and 4 git commands to generate.