]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- such glib version was for a reason (slist_remove fix)
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 %bcond_without  dynamic # without dynamic libraries
7 #
8 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
9
10 Summary:        Irssi is a IRC client
11 Summary(fr.UTF-8):      Irssi est un client IRC
12 Summary(pl.UTF-8):      Irssi - wygodny w użyciu klient IRC
13 Name:           irssi
14 Version:        0.8.11
15 Release:        1
16 License:        GPL
17 Group:          Applications/Communications
18 #Source0:       http://irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
19 Source0:        http://irssi.org/files/%{name}-%{version}.tar.gz
20 # Source0-md5:  ee23aa0f044e92c099c6acb116930e03
21 Source1:        %{name}.desktop
22 Source2:        %{name}.png
23 %define         idea_ver        0.1.46
24 Source3:        http://real.irssi.org/files/plugins/idea/%{name}-idea-%{idea_ver}.tar.gz
25 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
26 Patch0:         %{name}-dcc-send-limit.patch
27 Patch1:         %{name}-tinfo.patch
28 Patch2:         %{name}-home_etc.patch
29 Patch3:         %{name}.conf.patch
30 Patch4:         %{name}-idea-listlen.patch
31 Patch5:         %{name}-gcc4.patch
32 Patch6:         %{name}-dynamic.patch
33 Patch7:         %{name}-invalid_free.patch
34 URL:            http://www.irssi.org/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib-devel >= 1:1.2.10-13
39 BuildRequires:  glib2-devel >= 2.1.0
40 BuildRequires:  libtool
41 BuildRequires:  ncurses-devel >= 5.0
42 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
43 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
44 BuildRequires:  pkgconfig
45 BuildRequires:  popt-devel
46 %{?with_perl:BuildRequires:     rpm-perlprov}
47 BuildRequires:  rpmbuild(macros) >= 1.315
48 Requires:       glib >= 1:1.2.10-13
49 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
50 Obsoletes:      irssi-speech
51 Obsoletes:      irssi-sql
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %if %{with dynamic}
55 %define         filterout_ld    -Wl,--as-needed
56 %endif
57
58 %description
59 Irssi is a textUI IRC client with IPv6 support.
60
61 %description -l fr.UTF-8
62 Irssi est client IRC.
63
64 %description -l pl.UTF-8
65 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
66
67 %package plugin-idea
68 Summary:        Irssi plugin IDEA crypt
69 Summary(pl.UTF-8):      Wtyczka do irssi do szyfrowania IDEA
70 Group:          Applications/Communications
71 Requires:       %{name} = %{version}-%{release}
72
73 %description plugin-idea
74 This package contains IDEA Crypt plugin for Irssi.
75
76 %description plugin-idea -l pl.UTF-8
77 Ten pakiet zawiera wtyczkę do Irssi z szyfrowaniem IDEA.
78
79 %prep
80 %setup -q -a3
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84 %patch3 -p1
85 %patch4 -p1
86 %patch5 -p1
87 %if %{with dynamic}
88 %patch6 -p1
89 %endif
90 %patch7 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I .
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --without-socks \
99         --with-bot \
100         --with-textui \
101         --with-proxy \
102         --with-terminfo \
103         --with-modules \
104         %{?with_perl:--with-perl=yes} \
105         %{?with_perl:--with-perl-lib=vendor} \
106         %{!?with_perl:--with-perl=no} \
107         %{?with_ipv6:--enable-ipv6} \
108         --enable-nls \
109         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
110
111 %{__make}
112
113 cd irssi-idea-%{idea_ver}
114 %{__libtoolize}
115 %{__aclocal} -I .
116 %{__autoconf}
117 %{__automake}
118 %configure
119
120 %{__make}
121
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         docdir=%{_datadir}/%{name}-%{version}
130
131 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
132 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
133
134 %{__make} -C irssi-idea-%{idea_ver} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
143 %attr(755,root,root) %{_bindir}/*
144 %dir %{_libdir}/irssi
145 %dir %{_libdir}/irssi/modules
146 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
147 %if %{with dynamic}
148 %attr(755,root,root) %{_libdir}/libirssi*.so.*
149 %endif
150 %{_datadir}/%{name}
151 %{_desktopdir}/irssi.desktop
152 %{_pixmapsdir}/*
153 %{_sysconfdir}/irssi.conf
154 %{_mandir}/man1/*
155
156 %if %{with perl}
157 %{perl_vendorarch}/*.pm
158 %dir %{perl_vendorarch}/Irssi
159 %{perl_vendorarch}/Irssi/*.pm
160
161 %dir %{perl_vendorarch}/auto/Irssi
162 %{perl_vendorarch}/auto/Irssi/*.bs
163 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
164
165 %dir %{perl_vendorarch}/auto/Irssi/Irc
166 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
167 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
168
169 %dir %{perl_vendorarch}/auto/Irssi/TextUI
170 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
171 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
172
173 %dir %{perl_vendorarch}/auto/Irssi/UI
174 %{perl_vendorarch}/auto/Irssi/UI/*.bs
175 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
176 %endif
177
178 %files plugin-idea
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.102501 seconds and 4 git commands to generate.