]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- massive change: BR openssl-devel >= 0.9.7d
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 #
7 %define         _idea_ver       0.1.46
8 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
9 Summary:        Irssi is a IRC client
10 Summary(fr):    Irssi est un client IRC
11 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
12 Name:           irssi
13 Version:        0.8.9
14 Release:        3
15 License:        GPL
16 Group:          Applications/Communications
17 Source0:        http://real.irssi.org/files/%{name}-%{version}.tar.bz2
18 # Source0-md5:  6610ee0e27922f447e40828cf7dee507
19 Source1:        %{name}.desktop
20 Source2:        %{name}.png
21 Source3:        http://www.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
22 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
23 #Patch0:                %{name}-dcc-send-limit.patch
24 Patch1:         %{name}-channel_auto_who.patch
25 Patch2:         %{name}-tinfo.patch
26 Patch3:         %{name}-home_etc.patch
27 Patch4:         %{name}.conf.patch
28 URL:            http://www.irssi.org/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  gettext-devel
32 BuildRequires:  glib-devel
33 BuildRequires:  glib2-devel >= 2.1.0
34 BuildRequires:  libtool
35 BuildRequires:  ncurses-devel >= 5.0
36 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
37 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.0}
38 BuildRequires:  pkgconfig
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40 Obsoletes:      %{name}-speech
41 Obsoletes:      %{name}-sql
42
43 %description
44 Irssi is a textUI IRC client with IPv6 support.
45
46 %description -l fr
47 Irssi est client IRC.
48
49 %description -l pl
50 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
51
52 %package plugin-idea
53 Summary:        Irssi plugin IDEA crypt
54 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
55 Group:          Applications/Communications
56 Requires:       %{name} = %{version}
57
58 %description plugin-idea
59 This package contains IDEA Crypt plugin for Irssi.
60
61 %description plugin-idea
62 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
63
64 %prep
65 %setup -q -a3
66 #%patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69 %patch3 -p1
70 %patch4 -p1
71
72 %build
73 rm -f missing
74 %{__libtoolize}
75 %{__aclocal} -I .
76 %{__autoconf}
77 %{__automake}
78 %configure \
79         --without-socks \
80         --with-bot \
81         --with-textui \
82         --with-proxy \
83         --with-terminfo \
84         --with-modules \
85         %{?with_perl:--with-perl=yes} \
86         %{?with_perl:--with-perl-lib=vendor} \
87         %{!?with_perl:--with-perl=no} \
88         %{?with_ipv6:--enable-ipv6} \
89         --enable-nls \
90         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
91
92 %{__make}
93
94 cd irssi-idea-%{_idea_ver}
95 rm -f missing
96 %{__libtoolize}
97 %{__aclocal} -I .
98 %{__autoconf}
99 %{__automake}
100 %configure
101
102 %{__make}
103
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         docdir=%{_datadir}/%{name}-%{version}
112
113 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
114 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
115
116 %{__make} -C irssi-idea-%{_idea_ver} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc AUTHORS ChangeLog README TODO NEWS docs/*.txt
125 %attr(755,root,root) %{_bindir}/*
126 %dir %{_libdir}/irssi
127 %dir %{_libdir}/irssi/modules
128 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
129 %{_datadir}/%{name}
130 %{_desktopdir}/irssi.desktop
131 %{_pixmapsdir}/*
132 %{_sysconfdir}/irssi.conf
133 %{_mandir}/man1/*
134
135 %if %{with perl}
136 %{perl_vendorarch}/*.pm
137 %dir %{perl_vendorarch}/Irssi
138 %{perl_vendorarch}/Irssi/*.pm
139
140 %dir %{perl_vendorarch}/auto/Irssi
141 %{perl_vendorarch}/auto/Irssi/*.bs
142 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
143
144 %dir %{perl_vendorarch}/auto/Irssi/Irc
145 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
146 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
147
148 %dir %{perl_vendorarch}/auto/Irssi/TextUI
149 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
150 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
151
152 %dir %{perl_vendorarch}/auto/Irssi/UI
153 %{perl_vendorarch}/auto/Irssi/UI/*.bs
154 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
155 %endif
156
157 %files plugin-idea
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.058952 seconds and 4 git commands to generate.