]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- rel 3; disable as-needed for now (needs more serious fixing due to inter-deps)
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 %bcond_without  dynamic # without dynamic libraries
7
8 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
9
10 %define no_build_with_as_needed 1
11
12 Summary:        Irssi is a IRC client
13 Summary(fr):    Irssi est un client IRC
14 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
15 Name:           irssi
16 Version:        0.8.10a
17 Release:        3
18 License:        GPL
19 Group:          Applications/Communications
20 #Source0:       http://irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
21 Source0:        http://irssi.org/files/%{name}-%{version}.tar.gz
22 # Source0-md5:  78140796205c6fa1c43e46d2e79e60aa
23 Source1:        %{name}.desktop
24 Source2:        %{name}.png
25 %define         _idea_ver       0.1.46
26 Source3:        http://real.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
27 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
28 Patch0:         %{name}-dcc-send-limit.patch
29 Patch1:         %{name}-tinfo.patch
30 Patch2:         %{name}-home_etc.patch
31 Patch3:         %{name}.conf.patch
32 Patch4:         %{name}-idea-listlen.patch
33 Patch5:         %{name}-gcc4.patch
34 Patch6:         %{name}-dynamic.patch
35 Patch7:         %{name}-invalid_free.patch
36 URL:            http://www.irssi.org/
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 BuildRequires:  gettext-devel
40 BuildRequires:  glib-devel >= 1:1.2.10-13
41 BuildRequires:  glib2-devel >= 2.1.0
42 BuildRequires:  libtool
43 BuildRequires:  ncurses-devel >= 5.0
44 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
45 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
46 BuildRequires:  pkgconfig
47 BuildRequires:  popt-devel
48 %{?with_perl:BuildRequires:     rpm-perlprov}
49 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
50 Obsoletes:      %{name}-speech
51 Obsoletes:      %{name}-sql
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Irssi is a textUI IRC client with IPv6 support.
56
57 %description -l fr
58 Irssi est client IRC.
59
60 %description -l pl
61 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
62
63 %package plugin-idea
64 Summary:        Irssi plugin IDEA crypt
65 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
66 Group:          Applications/Communications
67 Requires:       %{name} = %{version}
68
69 %description plugin-idea
70 This package contains IDEA Crypt plugin for Irssi.
71
72 %description plugin-idea
73 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
74
75 %prep
76 %setup -q -n %{name}-0.8.10 -a3
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80 %patch3 -p1
81 %patch4 -p1
82 %patch5 -p1
83 %if %{with dynamic}
84 %patch6 -p1
85 %endif
86 %patch7 -p1
87
88 %build
89 rm -f missing
90 %{__libtoolize}
91 %{__aclocal} -I .
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         --without-socks \
96         --with-bot \
97         --with-textui \
98         --with-proxy \
99         --with-terminfo \
100         --with-modules \
101         %{?with_perl:--with-perl=yes} \
102         %{?with_perl:--with-perl-lib=vendor} \
103         %{!?with_perl:--with-perl=no} \
104         %{?with_ipv6:--enable-ipv6} \
105         --enable-nls \
106         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
107
108 %{__make}
109
110 cd irssi-idea-%{_idea_ver}
111 rm -f missing
112 %{__libtoolize}
113 %{__aclocal} -I .
114 %{__autoconf}
115 %{__automake}
116 %configure
117
118 %{__make}
119
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT \
127         docdir=%{_datadir}/%{name}-%{version}
128
129 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
130 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
131
132 %{__make} -C irssi-idea-%{_idea_ver} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
141 %attr(755,root,root) %{_bindir}/*
142 %dir %{_libdir}/irssi
143 %dir %{_libdir}/irssi/modules
144 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
145 %if %{with dynamic}
146 %attr(755,root,root) %{_libdir}/libirssi*.so.*
147 %endif
148 %{_datadir}/%{name}
149 %{_desktopdir}/irssi.desktop
150 %{_pixmapsdir}/*
151 %{_sysconfdir}/irssi.conf
152 %{_mandir}/man1/*
153
154 %if %{with perl}
155 %{perl_vendorarch}/*.pm
156 %dir %{perl_vendorarch}/Irssi
157 %{perl_vendorarch}/Irssi/*.pm
158
159 %dir %{perl_vendorarch}/auto/Irssi
160 %{perl_vendorarch}/auto/Irssi/*.bs
161 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
162
163 %dir %{perl_vendorarch}/auto/Irssi/Irc
164 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
165 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
166
167 %dir %{perl_vendorarch}/auto/Irssi/TextUI
168 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
169 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
170
171 %dir %{perl_vendorarch}/auto/Irssi/UI
172 %{perl_vendorarch}/auto/Irssi/UI/*.bs
173 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
174 %endif
175
176 %files plugin-idea
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.050555 seconds and 4 git commands to generate.