]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- doc/startup-HOWTO.html
[packages/irssi.git] / irssi.spec
1 # TODO:
2 # - package with some nice scripts + forwardfix.pl
3 #
4 # Conditional build:
5 %bcond_without  perl    # without perl support
6 %bcond_without  ipv6    # without IPv6 support
7 %bcond_without  ssl     # without SSL  support
8 #
9 %define         _rel rc5
10 %define         _idea_ver       0.1.46
11 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
12 Summary:        Irssi is a IRC client
13 Summary(fr):    Irssi est un client IRC
14 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
15 Name:           irssi
16 Version:        0.8.10
17 Release:        0.%{_rel}
18 License:        GPL
19 Group:          Applications/Communications
20 Source0:        http://real.irssi.org/files/%{name}-%{version}-%{_rel}.tar.gz
21 # Source0-md5:  7c0b6c1533c85e918f41ded1238e4ca1
22 Source1:        %{name}.desktop
23 Source2:        %{name}.png
24 Source3:        http://www.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
25 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
26 Patch0:         %{name}-dcc-send-limit.patch
27 Patch1:         %{name}-channel_auto_who.patch
28 Patch2:         %{name}-tinfo.patch
29 Patch3:         %{name}-home_etc.patch
30 Patch4:         %{name}.conf.patch
31 Patch5:         %{name}-idea-listlen.patch
32 URL:            http://www.irssi.org/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  gettext-devel
36 BuildRequires:  glib-devel
37 BuildRequires:  glib2-devel >= 2.1.0
38 BuildRequires:  libtool
39 BuildRequires:  ncurses-devel >= 5.0
40 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
41 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
42 BuildRequires:  pkgconfig
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44 Obsoletes:      %{name}-speech
45 Obsoletes:      %{name}-sql
46
47 %description
48 Irssi is a textUI IRC client with IPv6 support.
49
50 %description -l fr
51 Irssi est client IRC.
52
53 %description -l pl
54 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
55
56 %package plugin-idea
57 Summary:        Irssi plugin IDEA crypt
58 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
59 Group:          Applications/Communications
60 Requires:       %{name} = %{version}
61
62 %description plugin-idea
63 This package contains IDEA Crypt plugin for Irssi.
64
65 %description plugin-idea
66 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
67
68 %prep
69 %setup -q -n %{name}-%{version}-%{_rel} -a3
70 #%patch0 -p1
71 #%patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75 %patch5 -p1
76
77 %build
78 rm -f missing
79 %{__libtoolize}
80 %{__aclocal} -I .
81 %{__autoconf}
82 %{__automake}
83 %configure \
84         --without-socks \
85         --with-bot \
86         --with-textui \
87         --with-proxy \
88         --with-terminfo \
89         --with-modules \
90         %{?with_perl:--with-perl=yes} \
91         %{?with_perl:--with-perl-lib=vendor} \
92         %{!?with_perl:--with-perl=no} \
93         %{?with_ipv6:--enable-ipv6} \
94         --enable-nls \
95         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
96
97 %{__make}
98
99 cd irssi-idea-%{_idea_ver}
100 rm -f missing
101 %{__libtoolize}
102 %{__aclocal} -I .
103 %{__autoconf}
104 %{__automake}
105 %configure
106
107 %{__make}
108
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         docdir=%{_datadir}/%{name}-%{version}
117
118 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
119 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
120
121 %{__make} -C irssi-idea-%{_idea_ver} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
130 %attr(755,root,root) %{_bindir}/*
131 %dir %{_libdir}/irssi
132 %dir %{_libdir}/irssi/modules
133 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
134 %{_datadir}/%{name}
135 %{_desktopdir}/irssi.desktop
136 %{_pixmapsdir}/*
137 %{_sysconfdir}/irssi.conf
138 %{_mandir}/man1/*
139
140 %if %{with perl}
141 %{perl_vendorarch}/*.pm
142 %dir %{perl_vendorarch}/Irssi
143 %{perl_vendorarch}/Irssi/*.pm
144
145 %dir %{perl_vendorarch}/auto/Irssi
146 %{perl_vendorarch}/auto/Irssi/*.bs
147 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
148
149 %dir %{perl_vendorarch}/auto/Irssi/Irc
150 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
151 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
152
153 %dir %{perl_vendorarch}/auto/Irssi/TextUI
154 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
155 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
156
157 %dir %{perl_vendorarch}/auto/Irssi/UI
158 %{perl_vendorarch}/auto/Irssi/UI/*.bs
159 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
160 %endif
161
162 %files plugin-idea
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.075033 seconds and 4 git commands to generate.