]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
33d91309052f9ab7f7eb7f2c85a5351f14c4f21b
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 %bcond_without  dynamic # without dynamic libraries
7
8 %define irssi_perl_version 20071006
9 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
10 Summary:        Irssi is a IRC client
11 Summary(fr.UTF-8):      Irssi est un client IRC
12 Summary(pl.UTF-8):      Irssi - wygodny w użyciu klient IRC
13 Name:           irssi
14 Version:        0.8.12
15 Release:        10
16 License:        GPL
17 Group:          Applications/Communications
18 #Source0:       http://www.irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
19 Source0:        http://www.irssi.org/files/%{name}-%{version}.tar.gz
20 # Source0-md5:  ddf717a430e1c13a272f528c4f529430
21 Source1:        %{name}.desktop
22 Source2:        %{name}.png
23 %define         idea_ver        0.1.46
24 # NXDOMAIN
25 #Source3:       http://real.irssi.org/files/plugins/idea/%{name}-idea-%{idea_ver}.tar.gz
26 Source3:        %{name}-idea-%{idea_ver}.tar.gz
27 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
28 Patch0:         %{name}-dcc-send-limit.patch
29 Patch1:         %{name}-tinfo.patch
30 Patch2:         %{name}-home_etc.patch
31 Patch3:         %{name}.conf.patch
32 Patch4:         %{name}-idea-listlen.patch
33 Patch5:         %{name}-gcc4.patch
34 Patch6:         %{name}-dynamic.patch
35 Patch7:         %{name}-invalid_free.patch
36 Patch8:         %{name}-color_support_for_gui_entry.patch
37 Patch9:         %{name}-libs-nopoison.patch
38 URL:            http://www.irssi.org/
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  gettext-devel
42 # for idea only
43 BuildRequires:  glib-devel >= 1:1.2.10-13
44 BuildRequires:  glib2-devel >= 2.1.0
45 BuildRequires:  libtool
46 BuildRequires:  ncurses-devel >= 5.0
47 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
48 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
49 BuildRequires:  pkgconfig
50 BuildRequires:  popt-devel
51 %{?with_perl:BuildRequires:     rpm-perlprov}
52 BuildRequires:  rpmbuild(macros) >= 1.315
53 BuildRequires:  sed >= 4.0
54 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
55 Provides:       perl(Irssi) = %{irssi_perl_version}
56 Obsoletes:      irssi-speech
57 Obsoletes:      irssi-sql
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %if %{with dynamic}
61 %define         filterout_ld    -Wl,--as-needed
62 %endif
63
64 %description
65 Irssi is a textUI IRC client with IPv6 support.
66
67 %description -l fr.UTF-8
68 Irssi est client IRC.
69
70 %description -l pl.UTF-8
71 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
72
73 %package plugin-idea
74 Summary:        Irssi plugin IDEA crypt
75 Summary(pl.UTF-8):      Wtyczka do irssi do szyfrowania IDEA
76 Group:          Applications/Communications
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       glib >= 1:1.2.10-13
79
80 %description plugin-idea
81 This package contains IDEA Crypt plugin for Irssi.
82
83 %description plugin-idea -l pl.UTF-8
84 Ten pakiet zawiera wtyczkę do Irssi z szyfrowaniem IDEA.
85
86 %prep
87 %setup -q -a3
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 %patch4 -p1
93 %patch5 -p1
94 %if %{with dynamic}
95 %patch6 -p1
96 %endif
97 %patch7 -p1
98 %patch8 -p0
99 %patch9 -p1
100
101 echo 'AC_DEFUN([AM_PATH_GLIB],[:])' > glib1.m4
102
103 mv irssi-idea{-%{idea_ver},}
104
105 # hack
106 %{__sed} -i -e 's#\./libtool#%{_bindir}/libtool#g' configure.in
107
108 %build
109 ver=$(awk '/IRSSI_VERSION_DATE/{print $3}' irssi-version.h)
110 if [ "$ver" != "%{irssi_perl_version}" ]; then
111         : update irssi_perl_version to $ver
112         exit 1
113 fi
114
115 %{__libtoolize}
116 %{__aclocal} -I .
117 %{__autoconf}
118 %{__automake}
119 %configure \
120         --without-socks \
121         --with-bot \
122         --with-textui \
123         --with-proxy \
124         --with-terminfo \
125         --with-modules \
126         %{?with_perl:--with-perl=yes} \
127         %{?with_perl:--with-perl-lib=vendor} \
128         %{!?with_perl:--with-perl=no} \
129         %{?with_ipv6:--enable-ipv6} \
130         --enable-nls \
131         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
132
133 %{__make}
134
135 # to fool idea configure script
136 touch irssi-config
137 cd irssi-idea
138 %{__libtoolize}
139 %{__aclocal} -I .
140 %{__autoconf}
141 %{__automake}
142 %configure
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT \
150         docdir=%{_datadir}/%{name}-%{version}
151
152 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
153 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
154
155 %{__make} -C irssi-idea install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
164 %attr(755,root,root) %{_bindir}/*
165 %dir %{_libdir}/irssi
166 %dir %{_libdir}/irssi/modules
167 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
168 %if %{with dynamic}
169 %attr(755,root,root) %{_libdir}/libirssi*.so.*
170 %endif
171 %{_datadir}/%{name}
172 %{_desktopdir}/irssi.desktop
173 %{_pixmapsdir}/*
174 %{_sysconfdir}/irssi.conf
175 %{_mandir}/man1/*
176
177 %if %{with perl}
178 %{perl_vendorarch}/*.pm
179 %dir %{perl_vendorarch}/Irssi
180 %{perl_vendorarch}/Irssi/*.pm
181
182 %dir %{perl_vendorarch}/auto/Irssi
183 %{perl_vendorarch}/auto/Irssi/*.bs
184 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
185
186 %dir %{perl_vendorarch}/auto/Irssi/Irc
187 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
188 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
189
190 %dir %{perl_vendorarch}/auto/Irssi/TextUI
191 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
192 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
193
194 %dir %{perl_vendorarch}/auto/Irssi/UI
195 %{perl_vendorarch}/auto/Irssi/UI/*.bs
196 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
197 %endif
198
199 %files plugin-idea
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.052627 seconds and 2 git commands to generate.