]> git.pld-linux.org Git - packages/irssi.git/blame - irssi.spec
- updated
[packages/irssi.git] / irssi.spec
CommitLineData
a30c64ab 1#
d1d19600 2# Conditional build:
16e18b22 3%bcond_without perl # without perl support
4%bcond_without ipv6 # without IPv6 support
f5036096 5%bcond_without ssl # without SSL support
2176773f 6%bcond_without dynamic # without dynamic libraries
e69c54b0 7
9afd400b
ER
8%define irssi_perl_version 20071006
9%{?with_perl:%include /usr/lib/rpm/macros.perl}
75a558b0 10Summary: Irssi is a IRC client
d6b5098c
ER
11Summary(fr.UTF-8): Irssi est un client IRC
12Summary(pl.UTF-8): Irssi - wygodny w użyciu klient IRC
75a558b0 13Name: irssi
9ccdd399
AM
14Version: 0.8.13
15Release: 0.1
75a558b0 16License: GPL
d4791b42 17Group: Applications/Communications
73da6ec1
ER
18#Source0: http://www.irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
19Source0: http://www.irssi.org/files/%{name}-%{version}.tar.gz
9ccdd399 20# Source0-md5: 226f194576895ff3075c164523806d06
13117eda
AM
21Source1: %{name}.desktop
22Source2: %{name}.png
581cd5fb 23%define idea_ver 0.1.46
2cdf9123
JB
24# NXDOMAIN
25#Source3: http://real.irssi.org/files/plugins/idea/%{name}-idea-%{idea_ver}.tar.gz
26Source3: %{name}-idea-%{idea_ver}.tar.gz
e030c78a 27# Source3-md5: c326efe317b8f67593a3cd46d5557280
ecd062a6 28Patch0: %{name}-dcc-send-limit.patch
ee0d9b12
JR
29Patch1: %{name}-tinfo.patch
30Patch2: %{name}-home_etc.patch
31Patch3: %{name}.conf.patch
32Patch4: %{name}-idea-listlen.patch
eb3d727a 33Patch5: %{name}-gcc4.patch
69fc8ac9 34Patch6: %{name}-dynamic.patch
e69c54b0 35Patch7: %{name}-invalid_free.patch
e459dfd3 36Patch8: %{name}-color_support_for_gui_entry.patch
9afd400b 37Patch9: %{name}-libs-nopoison.patch
c48a9e4d 38URL: http://www.irssi.org/
13117eda 39BuildRequires: autoconf
a30c64ab 40BuildRequires: automake
a0e32961 41BuildRequires: gettext-devel
2cdf9123 42# for idea only
581cd5fb 43BuildRequires: glib-devel >= 1:1.2.10-13
a6f4c972 44BuildRequires: glib2-devel >= 2.1.0
a30c64ab 45BuildRequires: libtool
c694f984 46BuildRequires: ncurses-devel >= 5.0
4f6fa20a 47%{?with_ssl:BuildRequires: openssl-devel >= 0.9.7d}
9ad41241 48%{?with_perl:BuildRequires: perl-devel >= 1:5.8.4}
ed5b13fb 49BuildRequires: pkgconfig
4d2cef65 50BuildRequires: popt-devel
6639e834 51%{?with_perl:BuildRequires: rpm-perlprov}
eeb34517 52BuildRequires: rpmbuild(macros) >= 1.315
b9d2203f 53BuildRequires: sed >= 4.0
1da5a0b0 54Requires: perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
9afd400b 55Provides: perl(Irssi) = %{irssi_perl_version}
071656b5
ER
56Obsoletes: irssi-speech
57Obsoletes: irssi-sql
1da5a0b0 58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
c5c87082 59
eeb34517 60%if %{with dynamic}
61%define filterout_ld -Wl,--as-needed
62%endif
63
738c3ae3 64%description
d4791b42 65Irssi is a textUI IRC client with IPv6 support.
738c3ae3 66
fab8b1be 67%description -l fr.UTF-8
d4791b42 68Irssi est client IRC.
6f85d63f 69
fab8b1be 70%description -l pl.UTF-8
d4791b42 71Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
73c49657 72
74cc6bc5 73%package plugin-idea
f52ef808 74Summary: Irssi plugin IDEA crypt
d6b5098c 75Summary(pl.UTF-8): Wtyczka do irssi do szyfrowania IDEA
f52ef808 76Group: Applications/Communications
071656b5 77Requires: %{name} = %{version}-%{release}
2cdf9123 78Requires: glib >= 1:1.2.10-13
74cc6bc5 79
80%description plugin-idea
39eceb32 81This package contains IDEA Crypt plugin for Irssi.
82
fab8b1be
JR
83%description plugin-idea -l pl.UTF-8
84Ten pakiet zawiera wtyczkę do Irssi z szyfrowaniem IDEA.
74cc6bc5 85
738c3ae3 86%prep
0b1e4c7a 87%setup -q -a3
51b33c8b 88%patch0 -p1
89%patch1 -p1
972ba5d8 90%patch2 -p1
01baf907 91%patch3 -p1
12689c1e 92%patch4 -p1
eb3d727a 93%patch5 -p1
69fc8ac9 94%if %{with dynamic}
95%patch6 -p1
96%endif
e69c54b0 97%patch7 -p1
e459dfd3 98%patch8 -p0
9afd400b 99%patch9 -p1
738c3ae3 100
2cdf9123
JB
101echo 'AC_DEFUN([AM_PATH_GLIB],[:])' > glib1.m4
102
9afd400b
ER
103mv irssi-idea{-%{idea_ver},}
104
ec3bc534 105# hack
9afd400b 106%{__sed} -i -e 's#\./libtool#%{_bindir}/libtool#g' configure.in
ec3bc534 107
738c3ae3 108%build
9afd400b
ER
109ver=$(awk '/IRSSI_VERSION_DATE/{print $3}' irssi-version.h)
110if [ "$ver" != "%{irssi_perl_version}" ]; then
111 : update irssi_perl_version to $ver
112 exit 1
113fi
114
64ee8d3e 115%{__libtoolize}
6932dd71 116%{__aclocal} -I .
d0022294 117%{__autoconf}
118%{__automake}
c694f984 119%configure \
c5c87082 120 --without-socks \
13117eda 121 --with-bot \
be6cd0e4 122 --with-textui \
d4791b42 123 --with-proxy \
cb029a46 124 --with-terminfo \
d4791b42 125 --with-modules \
d1d19600 126 %{?with_perl:--with-perl=yes} \
127 %{?with_perl:--with-perl-lib=vendor} \
128 %{!?with_perl:--with-perl=no} \
129 %{?with_ipv6:--enable-ipv6} \
f5036096
AG
130 --enable-nls \
131 --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
694c1a92 132
feabde7d 133%{__make}
738c3ae3 134
53d15a9c
AM
135# to fool idea configure script
136touch irssi-config
9afd400b 137cd irssi-idea
74cc6bc5 138%{__libtoolize}
139%{__aclocal} -I .
140%{__autoconf}
141%{__automake}
142%configure
74cc6bc5 143%{__make}
144
738c3ae3
AF
145%install
146rm -rf $RPM_BUILD_ROOT
16afed53 147install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
1352901f 148%{__make} install \
149 DESTDIR=$RPM_BUILD_ROOT \
f29dbe19 150 docdir=%{_datadir}/%{name}-%{version}
bed6758a 151
16afed53 152install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
f29dbe19 153install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
d4791b42 154
9afd400b 155%{__make} -C irssi-idea install \
74cc6bc5 156 DESTDIR=$RPM_BUILD_ROOT
157
738c3ae3 158%clean
bed6758a 159rm -rf $RPM_BUILD_ROOT
738c3ae3 160
be6cd0e4 161%files
75a558b0 162%defattr(644,root,root,755)
0d89b8d9 163%doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
d4791b42 164%attr(755,root,root) %{_bindir}/*
c5c87082 165%dir %{_libdir}/irssi
d4791b42 166%dir %{_libdir}/irssi/modules
74cc6bc5 167%attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
69fc8ac9 168%if %{with dynamic}
169%attr(755,root,root) %{_libdir}/libirssi*.so.*
170%endif
be6cd0e4 171%{_datadir}/%{name}
16afed53 172%{_desktopdir}/irssi.desktop
f29dbe19 173%{_pixmapsdir}/*
c84e79dc 174%{_sysconfdir}/irssi.conf
175%{_mandir}/man1/*
176
d1d19600 177%if %{with perl}
c84e79dc 178%{perl_vendorarch}/*.pm
179%dir %{perl_vendorarch}/Irssi
180%{perl_vendorarch}/Irssi/*.pm
181
182%dir %{perl_vendorarch}/auto/Irssi
183%{perl_vendorarch}/auto/Irssi/*.bs
184%attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
185
186%dir %{perl_vendorarch}/auto/Irssi/Irc
187%{perl_vendorarch}/auto/Irssi/Irc/*.bs
188%attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
189
190%dir %{perl_vendorarch}/auto/Irssi/TextUI
191%{perl_vendorarch}/auto/Irssi/TextUI/*.bs
192%attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
193
194%dir %{perl_vendorarch}/auto/Irssi/UI
195%{perl_vendorarch}/auto/Irssi/UI/*.bs
196%attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
197%endif
74cc6bc5 198
199%files plugin-idea
200%defattr(644,root,root,755)
201%attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.088611 seconds and 4 git commands to generate.