]> git.pld-linux.org Git - packages/ipset.git/commitdiff
- rel 2; build fix auto/th/ipset-7.0-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 3 Dec 2018 18:38:33 +0000 (19:38 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 3 Dec 2018 18:38:33 +0000 (19:38 +0100)
build.patch [new file with mode: 0644]
ipset.spec

diff --git a/build.patch b/build.patch
new file mode 100644 (file)
index 0000000..218a3b6
--- /dev/null
@@ -0,0 +1,37 @@
+commit 21c9f79121abb70324efe9fc19ef0fb3685afb1a
+Author: Florent Fourcot <florent.fourcot@wifirst.fr>
+Date:   Tue Nov 27 17:15:56 2018 +0100
+
+    netfilter: ipset: fix ip_set_byindex function
+    
+    New function added by "Introduction of new commands and protocol
+    version 7" is not working, since we return skb2 to user
+    
+    Signed-off-by: Victorien Molle <victorien.molle@wifirst.fr>
+    Signed-off-by: Florent Fourcot <florent.fourcot@wifirst.fr>
+    Signed-off-by: Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
+
+diff --git a/kernel/net/netfilter/ipset/ip_set_core.c b/kernel/net/netfilter/ipset/ip_set_core.c
+index c2e32ee..b93805c 100644
+--- a/kernel/net/netfilter/ipset/ip_set_core.c
++++ b/kernel/net/netfilter/ipset/ip_set_core.c
+@@ -1976,7 +1976,7 @@ IPSET_CBFN(ip_set_byindex, struct net *net, struct sock *ctnl,
+       if (!nlh2)
+               goto nlmsg_failure;
+       if (nla_put_u8(skb2, IPSET_ATTR_PROTOCOL, protocol(attr)) ||
+-          nla_put_string(skb, IPSET_ATTR_SETNAME, set->name))
++          nla_put_string(skb2, IPSET_ATTR_SETNAME, set->name))
+               goto nla_put_failure;
+       nlmsg_end(skb2, nlh2);
+--- ipset-7.0/configure.ac~    2018-10-27 18:09:10.000000000 +0200
++++ ipset-7.0/configure.ac     2018-12-03 19:36:17.306201572 +0100
+@@ -499,7 +499,7 @@ fi
+ AC_MSG_CHECKING([kernel source for struct net in struct nfnl_callback])
+ if test -f $ksourcedir/include/linux/netfilter/nfnetlink.h && \
+    $AWK '/^struct nfnl_callback /,/^}/' $ksourcedir/include/linux/netfilter/nfnetlink.h | \
+-   $GREP -q 'struct net'; then
++   $GREP 'call)' | $GREP -q 'struct net'; then
+       AC_MSG_RESULT(yes)
+       AC_SUBST(HAVE_NET_IN_NFNL_CALLBACK_FN, define)
+ else
index eeae373250e9c917cb79cd4316a72bf8677d151d..ce0857d83547191b0b14567528c3a9d9c59005f9 100644 (file)
@@ -22,7 +22,7 @@ exit 1
 %define                _enable_debug_packages  0
 %endif
 
-%define                rel     1
+%define                rel     2
 %define                pname   ipset
 Summary:       IP sets utility
 Summary(pl.UTF-8):     Narzędzie do zarządzania zbiorami IP
@@ -35,6 +35,7 @@ Group:                Networking/Admin
 Source0:       http://ipset.netfilter.org/%{pname}-%{version}.tar.bz2
 # Source0-md5: 64c4e2e7123481c9db7ee1df127d9531
 Source1:       %{pname}.init
+Patch0:                build.patch
 URL:           http://ipset.netfilter.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -185,6 +186,7 @@ done\
 
 %prep
 %setup -q -n %{pname}-%{version}
+%patch0 -p1
 
 %build
 %{__aclocal}
This page took 0.115986 seconds and 4 git commands to generate.