]> git.pld-linux.org Git - packages/ipset.git/blob - ipset.spec
- rebuild for kernel-3.7.5-1
[packages/ipset.git] / ipset.spec
1 #
2 # TODO:
3 #       - patch our kernel to provide the needed API and update
4 #         the dependencies here
5 #
6 # Conditional build:
7 %bcond_without  dist_kernel     # allow non-distribution kernel
8 %bcond_without  kernel          # don't build kernel modules
9 %bcond_without  userspace       # don't build userspace tools
10 %bcond_with     verbose         # verbose build (V=1)
11
12 %if %{without kernel}
13 %undefine       with_dist_kernel
14 %endif
15 %if "%{_alt_kernel}" != "%{nil}"
16 %undefine       with_userspace
17 %endif
18 %if %{without userspace}
19 # nothing to be placed to debuginfo package
20 %define         _enable_debug_packages  0
21 %endif
22
23 %define         rel     5
24 %define         pname   ipset
25 Summary:        IP sets utility
26 Summary(pl.UTF-8):      Narzędzie do zarządzania zbiorami IP
27 Name:           %{pname}%{_alt_kernel}
28 Version:        6.16.1
29 Release:        %{rel}
30 License:        GPL v2
31 Group:          Networking/Admin
32 #Source0Download: http://ipset.netfilter.org/install.html
33 Source0:        http://ipset.netfilter.org/%{pname}-%{version}.tar.bz2
34 # Source0-md5:  9fd70c825f052db7dc9d5ba0562b7083
35 Source1:        %{pname}.init
36 Patch0:         %{pname}-no_kernel.patch
37 URL:            http://ipset.netfilter.org/
38 BuildRequires:  autoconf >= 2.50
39 BuildRequires:  automake
40 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.38.6}
41 BuildRequires:  libmnl-devel >= 1
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libtool >= 2:2.0
44 %{?with_userspace:BuildRequires:        linux-libc-headers >= 7:2.6.38.6}
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpmbuild(macros) >= 1.583
47 Suggests:       kernel-net-ipset
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 # unresolved ipset_errcode, defined in the ipset binary
51 %define         skip_post_check_so      libipset\.so.*
52
53 %description
54 IP sets are a framework inside the Linux 2.4.x and 2.6.x kernel, which
55 can be administered by the ipset utility. Depending on the type,
56 currently an IP set may store IP addresses, (TCP/UDP) port numbers or
57 IP addresses with MAC addresses in a way, which ensures lightning
58 speed when matching an entry against a set.
59
60 %description -l pl.UTF-8
61 Zbiory IP to szkielet w jądrze Linuksa 2.4.x i 2.6.x, którym można
62 administrować przy użyciu narzędzia ipset. W zależności od
63 rodzaju aktualnie zbiór IP może przechowywać adresy IP, numery
64 portów (TCP/UDP) lub adresy IP z adresami MAC - w sposób
65 zapewniający maksymalną szybkość przy dopasowywaniu elementu do
66 zbioru.
67
68 %package devel
69 Summary:        Header files for ipset interface
70 Summary(pl.UTF-8):      Pliki nagłówkowe do interfejsu ipset
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       libmnl-devel >= 1
74
75 %description devel
76 Header files for IPset interface.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe do interfejsu IPset.
80
81 %package static
82 Summary:        Static ipset interface library
83 Summary(pl.UTF-8):      Biblioteka statyczna interfejsu ipset
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static IPset interface library.
89
90 %description static -l pl.UTF-8
91 Biblioteka statyczna interfejsu IPset.
92
93 %package init
94 Summary:        IPset init script
95 Summary(pl.UTF-8):      Skrypt startowy IPset
96 Group:          Networking/Admin
97 Requires(post,preun):   /sbin/chkconfig
98 Requires:       %{pname} = %{version}-%{release}
99 Requires:       rc-scripts
100
101 %description init
102 IPset initialization script.
103
104 %description init -l pl.UTF-8
105 Skrypt startowy IPset.
106
107 %package -n kernel%{_alt_kernel}-net-ipset
108 Summary:        IPset kernel modules
109 Summary(pl.UTF-8):      Moduły jądra oferujące wsparcie dla zbiorów IP
110 Release:        %{rel}@%{_kernel_ver_str}
111 Group:          Base/Kernel
112 %{?with_dist_kernel:%requires_releq_kernel}
113 Requires(post,postun):  /sbin/depmod
114
115 %description -n kernel%{_alt_kernel}-net-ipset
116 IP sets are a framework inside the Linux 2.4.x and 2.6.x kernel, which
117 can be administered by the ipset utility. Depending on the type,
118 currently an IP set may store IP addresses, (TCP/UDP) port numbers or
119 IP addresses with MAC addresses in a way, which ensures lightning
120 speed when matching an entry against a set.
121
122 This package contains kernel modules.
123
124 %description -n kernel%{_alt_kernel}-net-ipset -l pl.UTF-8
125 Zbiory IP to szkielet w jądrze Linuksa 2.4.x i 2.6.x, którym można
126 administrować przy użyciu narzędzia ipset. W zależności od
127 rodzaju aktualnie zbiór IP może przechowywać adresy IP, numery
128 portów (TCP/UDP) lub adresy IP z adresami MAC - w sposób
129 zapewniający maksymalną szybkość przy dopasowywaniu elementu do
130 zbioru.
131
132 Ten pakiet zawiera moduły jądra oferujące wsparcie dla zbiorów IP.
133
134 %prep
135 %setup -q -n %{pname}-%{version}
136 %{!?with_kernel:%patch0 -p1}
137
138 %build
139 %{__libtoolize}
140 %{__aclocal} -I m4
141 %{__autoconf}
142 %{__autoheader}
143 %{__automake}
144 %configure \
145         --disable-silent-rules \
146         -with-settype-modules-list=all \
147         --with-kbuild=%{_kernelsrcdir}
148
149 %if %{with userspace}
150 %{__make}
151 %endif
152
153 %if %{with kernel}
154 # a hack not to list all modules: list only ip_set, all other are build anyway
155 %build_kernel_modules -C kernel/net/netfilter -m ipset/ip_set IP_SET_MAX=255 KDIR=$PWD/../..
156 %endif
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %if %{with userspace}
162 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_includedir}/libipset}
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166 cp include/libipset/*.h $RPM_BUILD_ROOT%{_includedir}/libipset
167
168 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{pname}
169 %endif
170
171 %if %{with kernel}
172 cd kernel/net/netfilter
173 %install_kernel_modules -m ipset/ip_set -d kernel/net/ipv4/netfilter/ipset
174 install -p ipset/ip_set_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/ipset
175 install -p xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
176 cd -
177 %endif
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post init
183 /sbin/chkconfig --add %{pname}
184
185 %preun init
186 if [ "$1" = "0" ]; then
187         /sbin/chkconfig --del %{pname}
188 fi
189
190 %post   -n kernel%{_alt_kernel}-net-ipset
191 %depmod %{_kernel_ver}
192
193 %postun -n kernel%{_alt_kernel}-net-ipset
194 %depmod %{_kernel_ver}
195
196 %if %{with userspace}
197 %files
198 %defattr(644,root,root,755)
199 %doc ChangeLog ChangeLog.ippool README UPGRADE
200 %attr(755,root,root) %{_sbindir}/ipset
201 %attr(755,root,root) %{_libdir}/libipset.so.*.*.*
202 %attr(755,root,root) %ghost %{_libdir}/libipset.so.3
203 %{_mandir}/man8/ipset.8*
204
205 %files devel
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/libipset.so
208 %{_libdir}/libipset.la
209 %{_includedir}/libipset
210
211 %files static
212 %defattr(644,root,root,755)
213 %{_libdir}/libipset.a
214
215 %files init
216 %defattr(644,root,root,755)
217 %attr(754,root,root) /etc/rc.d/init.d/ipset
218 %endif
219
220 %if %{with kernel}
221 %files -n kernel%{_alt_kernel}-net-ipset
222 %defattr(644,root,root,755)
223 /lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/xt_*.ko*
224 %dir /lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/ipset
225 /lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/ipset/ip_set.ko*
226 /lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/ipset/ip_set_*.ko*
227 %endif
This page took 0.066661 seconds and 4 git commands to generate.