]> git.pld-linux.org Git - packages/icewm.git/blobdiff - icewm-build-fixes.patch
- new Source URL, updated to 1.3.12
[packages/icewm.git] / icewm-build-fixes.patch
index 69989f809fd2742f259192a08bf298d838a0101b..a9fb5c63b24dfd0e0f78ec959472822c765e05e3 100644 (file)
@@ -1,62 +1,14 @@
-Index: icewm-1.3.7/configure
-===================================================================
---- icewm-1.3.7.orig/configure 2010-10-31 15:09:40.000000000 +0100
-+++ icewm-1.3.7/configure      2011-03-14 15:58:59.000000000 +0100
-@@ -7038,8 +7038,9 @@
-       if test "${PKG_CONFIG}" != ""; then
-       GNOME_VER=2
--      GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 libgnomeui-2.0`
--      GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 libgnomeui-2.0`
-+      GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`
-+      GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`
-+
- $as_echo "#define CONFIG_GNOME_MENUS 1" >>confdefs.h
-Index: icewm-1.3.7/configure.in
-===================================================================
---- icewm-1.3.7.orig/configure.in      2010-10-31 15:09:37.000000000 +0100
-+++ icewm-1.3.7/configure.in   2011-03-14 15:58:59.000000000 +0100
-@@ -836,8 +836,8 @@
-     
-       if test "${PKG_CONFIG}" != ""; then
+--- icewm-1.3.12/configure.ac.orig     2020-11-11 11:21:19.688467839 +0100
++++ icewm-1.3.12/configure.ac  2020-11-11 11:23:25.721118395 +0100
+@@ -347,7 +347,7 @@
+ AC_ARG_ENABLE([menus-gnome2],
+     AC_HELP_STRING([--disable-menus-gnome2],[Disable display of GNOME 2 menus.]))
+ if test x$enable_menus_gnome2 != xno; then
+-    PKG_CHECK_MODULES([GNOME2],[gnome-desktop-2.0 libgnomeui-2.0],[
++    PKG_CHECK_MODULES([GNOME2],[gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0],[
        GNOME_VER=2
--      GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 libgnomeui-2.0`
--      GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 libgnomeui-2.0`
-+      GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`
-+      GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 gnome-vfs-2.0 libgnomeui-2.0 fontconfig`
-       AC_DEFINE(CONFIG_GNOME_MENUS, 1, [Define to make IceWM more GNOME-friendly])
-Index: icewm-1.3.7/po/Makefile.in
-===================================================================
---- icewm-1.3.7.orig/po/Makefile.in    2010-10-31 15:09:37.000000000 +0100
-+++ icewm-1.3.7/po/Makefile.in 2011-03-14 15:58:59.000000000 +0100
-@@ -4,7 +4,9 @@
- prefix  =       @prefix@
- datadir =       @datadir@
--PACKAGE =     @PACKAGE@
-+PACKAGE =     icewm
-+# /*ebloch*/ XXX this should become @PACKAGE@ again when it's passing is fixed
-+
- LOCDIR =        @LOCDIR@
- DESTDIR = 
-Index: icewm-1.3.7/src/WinMgr.h
-===================================================================
---- icewm-1.3.7.orig/src/WinMgr.h      2010-10-31 15:09:36.000000000 +0100
-+++ icewm-1.3.7/src/WinMgr.h   2011-03-14 15:58:59.000000000 +0100
-@@ -128,7 +128,7 @@
-  * this where WIN_WORKSPACE_COUNT comes into play.
-  */
--#define WinWorkspaceInvalid    (-1L)
-+#define WinWorkspaceInvalid    ((unsigned long)-1)
- /* workspaces */
- #define XA_WIN_WORKSPACES "_WIN_WORKSPACES"
+       AC_DEFINE([CONFIG_GNOME_MENUS],[1],[Define to make IceWM more GNOME-friendly])
+       BUILD_MENU_GNOME2=yes
 Index: icewm-1.3.7/src/yapp.cc
 ===================================================================
 --- icewm-1.3.7.orig/src/yapp.cc       2010-10-31 15:09:36.000000000 +0100
@@ -70,36 +22,3 @@ Index: icewm-1.3.7/src/yapp.cc
              struct timeval difftime;
              struct timeval curtime;
              gettimeofday(&curtime, 0);
-Index: icewm-1.3.7/src/Makefile.in
-===================================================================
---- icewm-1.3.7.orig/src/Makefile.in   2011-03-14 16:00:59.012121443 +0100
-+++ icewm-1.3.7/src/Makefile.in        2011-03-14 16:01:08.285521758 +0100
-@@ -37,7 +37,7 @@
- CXXFLAGS =      @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
-               @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`
- LFLAGS =      @LDFLAGS@ 
--LIBS =          @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs` 
-+LIBS =          @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs` -lfontconfig
- CORE_LIBS =     @CORE_LIBS@ # `fc-config --libs`
- IMAGE_LIBS =    @IMAGE_LIBS@
---- icewm-1.3.8/src/icesh.cc.orig      2013-11-17 17:54:39.000000000 +0100
-+++ icewm-1.3.8/src/icesh.cc   2020-11-10 22:44:42.344406358 +0100
-@@ -245,7 +245,7 @@
- };
- SymbolTable layers = {
--    layerIdentifiers, 0, WinLayerCount - 1, WinLayerInvalid
-+    layerIdentifiers, 0, WinLayerCount - 1, (long)WinLayerInvalid
- };
- SymbolTable states = {
-@@ -257,7 +257,7 @@
- };
- SymbolTable trayOptions = {
--    trayOptionIdentifiers, 0, WinTrayOptionCount - 1, WinTrayInvalid
-+    trayOptionIdentifiers, 0, WinTrayOptionCount - 1, (long)WinTrayInvalid
- };
- /******************************************************************************/
This page took 0.060168 seconds and 4 git commands to generate.