]> git.pld-linux.org Git - packages/icemon.git/blob - icemon.spec
Release 4 (by relup.sh)
[packages/icemon.git] / icemon.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # Doxygen based API docs
4
5 %define         qtver   5.4.0
6 Summary:        Icecream GUI Monitor
7 Name:           icemon
8 Version:        3.3
9 Release:        4
10 License:        GPL v2+
11 Group:          Applications/System
12 #Source0Download: https://github.com/icecc/icemon/releases
13 Source0:        https://github.com/icecc/icemon/releases/download/v%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  e7356476ca0f489057723ad9c781679b
15 URL:            https://kfunk.org/tag/icemon/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  cmake >= 3.1.0
19 BuildRequires:  docbook2X
20 %{?with_apidocs:BuildRequires:  doxygen}
21 BuildRequires:  icecream-devel >= 1.3
22 BuildRequires:  kf5-extra-cmake-modules
23 BuildRequires:  libstdc++-devel >= 6:4.8.1
24 BuildRequires:  rpm-build >= 4.6
25 BuildRequires:  rpmbuild(macros) >= 1.605
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires(post,postun):  gtk-update-icon-cache
29 Requires:       Qt5Core >= %{qtver}
30 Requires:       Qt5Widgets >= %{qtver}
31 Requires:       hicolor-icon-theme
32 Requires:       icecream-libs >= 1.3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Icecream GUI Monitor.
37
38 %package apidocs
39 Summary:        icemon API documentation
40 Group:          Documentation
41 BuildArch:      noarch
42
43 %description apidocs
44 API documentation for icemon.
45
46 %prep
47 %setup -q
48
49 %build
50 %cmake -B build \
51         -DDOCBOOK_TO_MAN_EXECUTABLE=/usr/bin/docbook2X2man
52
53 %{__make} -C build
54 %{?with_apidocs:%{__make} -C build doc}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} -C build install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %update_icon_cache hicolor
67 %update_desktop_database
68
69 %postun
70 %update_icon_cache hicolor
71 %update_desktop_database_postun
72
73 %files
74 %defattr(644,root,root,755)
75 %doc CHANGELOG.md README.md
76 %attr(755,root,root) %{_bindir}/icemon
77 %{_desktopdir}/icemon.desktop
78 %{_iconsdir}/hicolor/*/apps/icemon.png
79 %{_mandir}/man1/icemon.1*
80
81 %if %{with apidocs}
82 %files apidocs
83 %defattr(644,root,root,755)
84 %doc build/html/*
85 %endif
This page took 0.108258 seconds and 3 git commands to generate.