]> git.pld-linux.org Git - packages/gtkglextmm.git/commitdiff
- added am patch (avoid automake warning when gtkglextmm-devel is installed) master auto/th/gtkglextmm-1.2.0-3
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 23 Jul 2013 19:31:16 +0000 (21:31 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 23 Jul 2013 19:31:16 +0000 (21:31 +0200)
- added glibmm patch (updates to build with current glibmm)
- release 3

gtkglextmm-am.patch [new file with mode: 0644]
gtkglextmm-glibmm.patch [new file with mode: 0644]
gtkglextmm.spec

diff --git a/gtkglextmm-am.patch b/gtkglextmm-am.patch
new file mode 100644 (file)
index 0000000..6ced603
--- /dev/null
@@ -0,0 +1,11 @@
+--- gtkglextmm-1.2.0/m4macros/gtkglextmm.m4.orig       2004-05-18 08:29:34.000000000 +0200
++++ gtkglextmm-1.2.0/m4macros/gtkglextmm.m4    2013-07-23 17:11:28.056898725 +0200
+@@ -222,7 +222,7 @@
+ dnl AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD([ACTION-IF-SUPPORTED [, ACTION-IF-NOT-SUPPORTED]])
+ dnl Checks whether gtkglextmm supports multihead.
+ dnl
+-AC_DEFUN(AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD,
++AC_DEFUN([AC_GTKGLEXTMM_SUPPORTS_MULTIHEAD],
+ [ AC_LANG_SAVE
+   AC_LANG_CPLUSPLUS
+   AC_CACHE_CHECK([whether gtkglextmm supports multihead],
diff --git a/gtkglextmm-glibmm.patch b/gtkglextmm-glibmm.patch
new file mode 100644 (file)
index 0000000..db220cd
--- /dev/null
@@ -0,0 +1,88 @@
+--- gtkglextmm-1.2.0/configure.in.orig 2006-02-28 02:40:33.000000000 +0100
++++ gtkglextmm-1.2.0/configure.in      2013-07-23 17:40:34.026825455 +0200
+@@ -290,9 +290,8 @@
+ LIBS="$save_LIBS"
+ # gmmproc
+-GLIBMM_CHECK_PERL([5.6.0])
+-GLIBMM_PREFIX=`$PKG_CONFIG --variable=prefix glibmm_pkg`
+-GMMPROC_DIR=$GLIBMM_PREFIX/lib/glibmm_pkg/proc
++MM_CHECK_PERL([5.6.0])
++GMMPROC_DIR="`$PKG_CONFIG --variable=gmmprocdir glibmm_pkg`"
+ AC_SUBST(GMMPROC_DIR)
+ GMMPROC=$GMMPROC_DIR/gmmproc
+ AC_SUBST(GMMPROC)
+--- gtkglextmm-1.2.0/gdkglext/gdkmm/gl/wrap_init.cc.orig       2006-02-28 02:46:15.000000000 +0100
++++ gtkglextmm-1.2.0/gdkglext/gdkmm/gl/wrap_init.cc    2013-07-23 20:34:58.809719624 +0200
+@@ -1,5 +1,9 @@
++#undef G_DISABLE_DEPRECATED
++#define GLIB_DISABLE_DEPRECATION_WARNINGS 1
+ #include <glib.h>
++#undef GLIB_DISABLE_DEPRECATION_WARNINGS
++#define G_DISABLE_DEPRECATED
+ // Disable the 'const' function attribute of the get_type() functions.
+ // GCC would optimize them out because we don't use the return value.
+--- gtkglextmm-1.2.0/gdkglext/gdkmm/gl/query.cc.orig   2003-02-27 10:49:24.000000000 +0100
++++ gtkglextmm-1.2.0/gdkglext/gdkmm/gl/query.cc        2013-07-23 20:41:29.083036578 +0200
+@@ -17,10 +17,10 @@
+  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
+  */
+-#include <gdk/gdkglquery.h>
+-
+ #include "query.h"
++#include <gdk/gdkglquery.h>
++
+ namespace Gdk
+ {
+   namespace GL
+--- gtkglextmm-1.2.0/gdkglext/gdkmm/gl/pixmapext.cc.orig       2004-05-18 08:01:49.000000000 +0200
++++ gtkglextmm-1.2.0/gdkglext/gdkmm/gl/pixmapext.cc    2013-07-23 20:42:02.043035194 +0200
+@@ -17,11 +17,11 @@
+  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
+  */
++#include "pixmapext.h"
++
+ #include <gdk/gdkgldrawable.h>
+ #include <gdk/gdkglpixmap.h>
+-#include "pixmapext.h"
+-
+ namespace Gdk
+ {
+   namespace GL
+--- gtkglextmm-1.2.0/gdkglext/gdkmm/gl/windowext.cc.orig       2004-05-18 08:01:49.000000000 +0200
++++ gtkglextmm-1.2.0/gdkglext/gdkmm/gl/windowext.cc    2013-07-23 20:50:45.153013240 +0200
+@@ -17,11 +17,11 @@
+  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
+  */
++#include "windowext.h"
++
+ #include <gdk/gdkgldrawable.h>
+ #include <gdk/gdkglwindow.h>
+-#include "windowext.h"
+-
+ namespace Gdk
+ {
+   namespace GL
+--- gtkglextmm-1.2.0/gdkglext/gdkmm/gl/font.cc.orig    2004-05-18 08:01:49.000000000 +0200
++++ gtkglextmm-1.2.0/gdkglext/gdkmm/gl/font.cc 2013-07-23 20:51:44.989677398 +0200
+@@ -17,10 +17,10 @@
+  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA.
+  */
+-#include <gdk/gdkglfont.h>
+-
+ #include "font.h"
++#include <gdk/gdkglfont.h>
++
+ namespace Gdk
+ {
+   namespace GL
index 73a9df086ba462b7321daeee1d5fc87c069617dd..e27ca5edca8b915f85a0e88ebcfa9111f3451995 100644 (file)
@@ -2,18 +2,21 @@ Summary:      C++ wrapper for GtkGLExt library
 Summary(pl.UTF-8):     Interfejs C++ do biblioteki GtkGLExt
 Name:          gtkglextmm
 Version:       1.2.0
-Release:       2
-License:       LGPL
+Release:       3
+License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/gtkglext/%{name}-%{version}.tar.bz2
+Source0:       http://downloads.sourceforge.net/gtkglext/%{name}-%{version}.tar.bz2
 # Source0-md5: 27c05f4d45c5fd07b6fb0f044add3056
 Patch0:                gdkspanfunc.patch
+Patch1:                %{name}-am.patch
+Patch2:                %{name}-glibmm.patch
 URL:           http://gtkglext.sourceforge.net/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake >= 1:1.7
 BuildRequires: gtkglext-devel >= 1.0.0
 BuildRequires: gtkmm-devel >= 2.4.0
 BuildRequires: libtool >= 2:1.4d-3
+BuildRequires: mm-common
 BuildRequires: perl-base >= 1:5.6.0
 BuildRequires: pkgconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -55,6 +58,8 @@ Statyczna biblioteka gtkglextmm.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -84,18 +89,25 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README
-%attr(755,root,root) %{_libdir}/libg[dt]kglextmm-x11-1.2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libg[dt]kglextmm-x11-1.2.so.0
+%attr(755,root,root) %{_libdir}/libgdkglextmm-x11-1.2.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgdkglextmm-x11-1.2.so.0
+%attr(755,root,root) %{_libdir}/libgtkglextmm-x11-1.2.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgtkglextmm-x11-1.2.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libg[dt]kglextmm-x11-1.2.so
+%attr(755,root,root) %{_libdir}/libgdkglextmm-x11-1.2.so
+%attr(755,root,root) %{_libdir}/libgtkglextmm-x11-1.2.so
 %{_libdir}/gtkglextmm-1.2
 %{_includedir}/gtkglextmm-1.2
 %{_aclocaldir}/gtkglextmm-1.2.m4
-%{_pkgconfigdir}/g[dt]kglextmm*-1.2.pc
+%{_pkgconfigdir}/gdkglextmm-1.2.pc
+%{_pkgconfigdir}/gdkglextmm-x11-1.2.pc
+%{_pkgconfigdir}/gtkglextmm-1.2.pc
+%{_pkgconfigdir}/gtkglextmm-x11-1.2.pc
 %{_gtkdocdir}/gtkglextmm-1.2
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libg[dt]kglextmm-x11-1.2.a
+%{_libdir}/libgdkglextmm-x11-1.2.a
+%{_libdir}/libgtkglextmm-x11-1.2.a
This page took 0.126434 seconds and 4 git commands to generate.