]> git.pld-linux.org Git - packages/grass.git/blob - grass.spec
Release 5 (by relup.sh)
[packages/grass.git] / grass.spec
1 # TODO
2 # - openDWG
3 #
4 # Conditional build, see http://grass.itc.it/grass61/source/REQUIREMENTS.html
5 # for description of optional requirements.
6 %bcond_without  mysql   # MySQL support
7 %bcond_without  odbc    # unixODBC support
8
9 Summary:        The Geographic Resources Analysis Support System
10 Summary(pl.UTF-8):      System obsługujący analizę zasobów geograficznych
11 Name:           grass
12 Version:        7.6.1
13 %define         gver    %(echo %{version} | awk -F. '{ print $1$2 }')
14 Release:        4
15 Epoch:          1
16 License:        GPL v2+
17 Group:          X11/Applications
18 Source0:        http://grass.osgeo.org/grass76/source/%{name}-%{version}.tar.gz
19 # Source0-md5:  9ca74f9010d013f735737a90c65d8a7f
20 Patch0:         %{name}-soname.patch
21 Patch3:         %{name}-ctypesgen.patch
22 URL:            http://grass.osgeo.org/
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  autoconf >= 2.13
25 BuildRequires:  automake
26 BuildRequires:  bison
27 BuildRequires:  blas-devel
28 BuildRequires:  cairo-devel
29 BuildRequires:  fftw3-devel >= 3
30 BuildRequires:  flex
31 BuildRequires:  freetype-devel >= 2.0.0
32 BuildRequires:  gcc-fortran
33 BuildRequires:  gd-devel
34 BuildRequires:  gdal-devel
35 BuildRequires:  gdbm-devel
36 BuildRequires:  geos-devel
37 BuildRequires:  lapack-devel
38 BuildRequires:  libjpeg-devel
39 BuildRequires:  libpng-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtiff-devel
42 # man or man-db
43 BuildRequires:  /usr/bin/man
44 %{?with_mysql:BuildRequires:    mysql-devel}
45 BuildRequires:  pkgconfig
46 BuildRequires:  postgresql-backend-devel
47 BuildRequires:  postgresql-devel
48 BuildRequires:  proj-devel >= 4.4.6
49 BuildRequires:  proj-progs
50 BuildRequires:  python-devel >= 1:2.3
51 BuildRequires:  python-wxPython
52 BuildRequires:  readline-devel
53 BuildRequires:  sed >= 4.0
54 BuildRequires:  sqlite3-devel >= 3.0
55 %{?with_odbc:BuildRequires:     unixODBC-devel}
56 BuildRequires:  wxGTK2-unicode-devel >= 2.8.1
57 BuildRequires:  xorg-lib-libX11-devel
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXt-devel
60 BuildRequires:  zlib-devel
61 # R language?
62 Requires:       proj >= 4.4.6
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
66 %define         _sysconfdir     /etc/X11
67
68 %description
69 GRASS (the Geographic Resources Analysis Support System) is a software
70 raster- and vector-based GIS (Geographic Information System), image
71 processing system, graphics production system, and spatial modeling
72 system. GRASS contains many modules for raster data manipulation,
73 vector data manipulation, rendering images on the monitor or paper,
74 multispectral image processing, point data management and general data
75 management. It also has tools for interfacing with digitizers,
76 scanners, and the RIM, Informix, Postgres, and Oracle databases.
77
78 %description -l pl.UTF-8
79 GRASS (System Wspierania Analiz Zasobów Geograficznych) jest rastrowym
80 oraz wektorowym systemem GIS (System Informacji Geograficznej),
81 obróbki obrazów, tworzenia grafiki oraz modelowania przestrzennego.
82 GRASS zawiera wiele modułów wspomagających manipulację danymi
83 rastrowymi i wektorowymi, renderowanie obrazów na monitorze lub
84 papierze, obróbkę multispektralnych obrazów, punktowe oraz ogólne
85 zarządzanie danymi. Zawiera również narzędzia do współpracy z
86 digitizerami, skanerami oraz bazami RIM, Informix, Postgres oraz
87 Oracle.
88
89 %package OpenGL
90 Summary:        NVIZ - a 3D-tool for GRASS
91 Summary(pl.UTF-8):      NVIZ - narzędzie 3D dla GRASSa
92 Group:          X11/Applications
93 Requires:       %{name} = %{epoch}:%{version}-%{release}
94
95 %description OpenGL
96 Package contains nviz, which is a GRASS module-in-progress which
97 allows users to realistically render multiple surfaces in a 3D space,
98 optionally using thematic coloring, draping GRASS vector files over
99 the surfaces, and displaying GRASS site files either draped on the
100 surfaces or as 3D point locations.
101
102 %description OpenGL -l pl.UTF-8
103 Pakiet zawiera moduł nviz, który rozszerza funkcjonalność systemu
104 GRASS o możliwość realistycznego renderowania wielu powierzchni w
105 trójwymiarowej przestrzeni. Na renderowanych powierzchniach, które
106 mogą być tematycznie kolorowane, można zawieszać pliki wektorowe
107 GRASSa.
108
109 %package pg
110 Summary:        PostgreSQL database interface
111 Summary(pl.UTF-8):      Interfejs do bazy PostgreSQL
112 Group:          X11/Applications
113 Requires:       %{name} = %{epoch}:%{version}-%{release}
114
115 %description pg
116 PostgreSQL database interface for GRASS.
117
118 %description pg -l pl.UTF-8
119 Interfejs do bazy PostgreSQL dla GRASSa.
120
121 %package odbc
122 Summary:        ODBC database interface
123 Summary(pl.UTF-8):      Interfejs ODBC dla GRASSa
124 Group:          X11/Applications
125 Requires:       %{name} = %{epoch}:%{version}-%{release}
126
127 %description odbc
128 ODBC database interface for GRASS.
129
130 %description odbc -l pl.UTF-8
131 Interfejs ODBC dla GRASSa.
132
133 %package devel
134 Summary:        Header files and static libraries for GRASS
135 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki statyczne systemu GRASS
136 Group:          X11/Development/Libraries
137 Requires:       %{name} = %{epoch}:%{version}-%{release}
138
139 %description devel
140 Header files and static libraries for GRASS.
141
142 %description devel -l pl.UTF-8
143 Pliki nagłówkowe i biblioteki statyczne systemu GRASS.
144
145 %prep
146 %setup -q
147 %patch0 -p1
148 %patch3 -p1
149
150 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
151         display/d.text/test.pl
152         raster/r.topidx/gridatb.to.arc.pl \
153         raster/r.topidx/arc.to.gridatb.pl
154
155 find general gui imagery lib/python/pygrass lib/init raster scripts temporal tools -name '*.py' | xargs grep -l '/usr/bin/env python' | xargs %{__sed} -i -e '1s,/usr/bin/env python,%{__python},'
156
157 %build
158 %configure2_13 \
159 %if "%{_lib}" == "lib64"
160         --enable-64bit \
161 %endif
162         --enable-largefile \
163         --with-includes=%{_includedir} \
164         --with-libs=%{_libdir} \
165         --with-blas \
166         --with-cairo \
167         --with-cxx \
168         --with-freetype \
169         --with-freetype-includes=/usr/include/freetype2 \
170         --with-geos=/usr/bin/geos-config \
171         --with-lapack \
172         %{?with_mysql:--with-mysql} \
173         %{?with_mysql:--with-mysql-includes=/usr/include/mysql} \
174         --with-nls \
175         %{?with_odbc:--with-odbc} \
176         --with-opengl \
177         --with-postgres \
178         --with-postgres-includes=/usr/include/postgresql/server \
179         --with-proj-share=/usr/share/proj \
180         --with-readline \
181         --with-sqlite \
182         --with-wxwidgets=/usr/bin/wx-gtk2-unicode-config
183
184 %{__make}
185
186 %install
187 rm -rf $RPM_BUILD_ROOT
188
189 %{__make} install \
190         prefix=$RPM_BUILD_ROOT%{_libdir} \
191         UNIX_BIN=$RPM_BUILD_ROOT%{_bindir}
192
193 install -d $RPM_BUILD_ROOT{%{_datadir},%{_includedir}/grass%{gver}}
194 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass%{gver}/include/* $RPM_BUILD_ROOT%{_includedir}/grass%{gver}/
195 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass%{gver}/lib/* $RPM_BUILD_ROOT%{_libdir}
196 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass%{gver}/locale $RPM_BUILD_ROOT%{_datadir}
197 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass%{gver}/docs/man $RPM_BUILD_ROOT%{_datadir}
198 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass%{gver}/share/{metainfo,applications,icons} $RPM_BUILD_ROOT%{_datadir}
199
200 # these manual cover topics, not programs, so shouldn't exist in section 1
201 # (maybe in section 7, but names are too common anyway); keep HTML version only
202 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{cairodriver,database,databaseintro,display,displaydrivers,full_index,general,helptext,htmldriver,imagery,imageryintro,index,keywords,pngdriver,postscript,projectionintro,psdriver,raster,rasterintro,raster3d,raster3dintro,sql,temporal,temporalintro,topics,variables,vector,vectorascii,vectorintro}.1
203
204 # non-standard icons
205 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/40x40
206
207 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/grass%{gver}/docs
208
209 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{id_ID,id}
210 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN
211 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_CN}
212
213 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}%{gver}/{AUTHORS,CHANGES,CITING,COPYING,GPL.TXT,INSTALL,REQUIREMENTS.html}
214
215 %{__sed} -i -e "s|$RPM_BUILD_ROOT||g" \
216         $RPM_BUILD_ROOT%{_libdir}/grass%{gver}/etc/fontcap \
217         $RPM_BUILD_ROOT%{_libdir}/grass%{gver}/demolocation/.grassrc%{gver} \
218         $RPM_BUILD_ROOT%{_bindir}/grass%{gver} \
219         $RPM_BUILD_ROOT%{_includedir}/grass%{gver}/Make/Grass.make \
220         $RPM_BUILD_ROOT%{_includedir}/grass%{gver}/Make/Platform.make
221
222 %find_lang %{name} --all-name
223
224 %clean
225 rm -rf $RPM_BUILD_ROOT
226
227 %post   -p /sbin/ldconfig
228 %postun -p /sbin/ldconfig
229
230 %files -f %{name}.lang
231 %defattr(644,root,root,755)
232 %doc AUTHORS CHANGES CITING COPYING README TODO
233 %attr(755,root,root) %{_bindir}/grass%{gver}
234 %attr(755,root,root) %{_libdir}/libgrass_*.*.*.so
235 %dir %{_libdir}/grass%{gver}
236 %{_libdir}/grass%{gver}/*.csv
237 %attr(755,root,root) %{_libdir}/grass%{gver}/config.status
238 %attr(755,root,root) %{_libdir}/grass%{gver}/bin
239 %attr(755,root,root) %{_libdir}/grass%{gver}/driver
240 %dir %{_libdir}/grass%{gver}/etc
241 %{_libdir}/grass%{gver}/etc/VERSIONNUMBER
242 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/clean_temp
243 %{_libdir}/grass%{gver}/etc/colors
244 %{_libdir}/grass%{gver}/etc/colors.desc
245 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/current_time_s_ms
246 %{_libdir}/grass%{gver}/etc/d.mon
247 %{_libdir}/grass%{gver}/etc/d.polar
248 %{_libdir}/grass%{gver}/etc/db.test
249 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/echo
250 %{_libdir}/grass%{gver}/etc/element_list
251 %{_libdir}/grass%{gver}/etc/fontcap
252 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/i.find
253 %{_libdir}/grass%{gver}/etc/license
254 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/lister
255 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/lock
256 %{_libdir}/grass%{gver}/etc/paint
257 %{_libdir}/grass%{gver}/etc/proj
258 %{_libdir}/grass%{gver}/etc/psdriver.ps
259 %{_libdir}/grass%{gver}/etc/python
260 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/r.in.wms
261 %dir %{_libdir}/grass%{gver}/etc/r.watershed
262 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/r.watershed/ram
263 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/r.watershed/seg
264 %{_libdir}/grass%{gver}/etc/renamed_options
265 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/run
266 %{_libdir}/grass%{gver}/etc/sql
267 %{_libdir}/grass%{gver}/etc/symbol
268 %attr(755,root,root) %{_libdir}/grass%{gver}/etc/wxpyimgview_gui.py
269 %{_libdir}/grass%{gver}/fonts
270 %dir %{_libdir}/grass%{gver}/gui
271 %{_libdir}/grass%{gver}/gui/icons
272 %{_libdir}/grass%{gver}/gui/images
273 %dir %{_libdir}/grass%{gver}/gui/scripts
274 %attr(755,root,root) %{_libdir}/grass%{gver}/gui/scripts/d.*
275 %dir %{_libdir}/grass%{gver}/gui/wxpython
276 %{_libdir}/grass%{gver}/gui/wxpython/README
277 %{_libdir}/grass%{gver}/gui/wxpython/animation
278 %{_libdir}/grass%{gver}/gui/wxpython/core
279 %{_libdir}/grass%{gver}/gui/wxpython/datacatalog
280 %{_libdir}/grass%{gver}/gui/wxpython/dbmgr
281 %{_libdir}/grass%{gver}/gui/wxpython/gcp
282 %{_libdir}/grass%{gver}/gui/wxpython/gmodeler
283 %{_libdir}/grass%{gver}/gui/wxpython/gui_core
284 %{_libdir}/grass%{gver}/gui/wxpython/iclass
285 %{_libdir}/grass%{gver}/gui/wxpython/icons
286 %{_libdir}/grass%{gver}/gui/wxpython/image2target
287 %{_libdir}/grass%{gver}/gui/wxpython/iscatt
288 %{_libdir}/grass%{gver}/gui/wxpython/lmgr
289 %{_libdir}/grass%{gver}/gui/wxpython/location_wizard
290 %{_libdir}/grass%{gver}/gui/wxpython/mapdisp
291 %{_libdir}/grass%{gver}/gui/wxpython/mapswipe
292 %{_libdir}/grass%{gver}/gui/wxpython/mapwin
293 %{_libdir}/grass%{gver}/gui/wxpython/modules
294 %{_libdir}/grass%{gver}/gui/wxpython/nviz
295 %{_libdir}/grass%{gver}/gui/wxpython/photo2image
296 %{_libdir}/grass%{gver}/gui/wxpython/psmap
297 %{_libdir}/grass%{gver}/gui/wxpython/rdigit
298 %{_libdir}/grass%{gver}/gui/wxpython/rlisetup
299 %{_libdir}/grass%{gver}/gui/wxpython/startup
300 %{_libdir}/grass%{gver}/gui/wxpython/timeline
301 %{_libdir}/grass%{gver}/gui/wxpython/tplot
302 %{_libdir}/grass%{gver}/gui/wxpython/vdigit
303 %{_libdir}/grass%{gver}/gui/wxpython/vnet
304 %{_libdir}/grass%{gver}/gui/wxpython/web_services
305 %{_libdir}/grass%{gver}/gui/wxpython/wxplot
306 %{_libdir}/grass%{gver}/gui/wxpython/xml
307 %{_libdir}/grass%{gver}/gui/wxpython/gis_set*.py*
308 %{_libdir}/grass%{gver}/gui/wxpython/wxgui.py*
309 %{_libdir}/grass%{gver}/gui/xml
310 %attr(755,root,root) %{_libdir}/grass%{gver}/scripts
311 %dir %{_libdir}/grass%{gver}/tools
312 %attr(755,root,root) %{_libdir}/grass%{gver}/tools/g.echo
313 %attr(755,root,root) %{_libdir}/grass%{gver}/tools/g.html2man.py
314 %{_libdir}/grass%{gver}/tools/ggroff.py*
315 %{_libdir}/grass%{gver}/tools/ghtml.py*
316 %attr(755,root,root) %{_libdir}/grass%{gver}/tools/mkhtml.py
317 %{_libdir}/grass%{gver}/translation_status.json
318 # default (demo?) database - subpackage?
319 %{_libdir}/grass%{gver}/demolocation
320 %{_datadir}/metainfo/org.osgeo.grass.appdata.xml
321 %{_desktopdir}/grass.desktop
322 %{_iconsdir}/hicolor/*x*/apps/grass.png
323 %{_iconsdir}/hicolor/scalable/apps/grass.svg
324 %{_mandir}/man1/d.*.1*
325 %{_mandir}/man1/db.*.1*
326 %{_mandir}/man1/g.*.1*
327 %{_mandir}/man1/*_graphical.1*
328 %{_mandir}/man1/graphical_index.1*
329 %{_mandir}/man1/grass*.1*
330 %{_mandir}/man1/i.*.1*
331 %{_mandir}/man1/lrs.1*
332 %{_mandir}/man1/m.*.1*
333 %{_mandir}/man1/manual_gallery.1*
334 %{_mandir}/man1/miscellaneous.1*
335 %{_mandir}/man1/parser_standard_options.1*
336 %{_mandir}/man1/ps.map.1*
337 %{_mandir}/man1/r.*.1*
338 %{_mandir}/man1/r3.*.1*
339 %{_mandir}/man1/t.*.1*
340 %{_mandir}/man1/topic_*.1*
341 %{_mandir}/man1/v.*.1*
342 %{_mandir}/man1/wxGUI.1*
343 %{_mandir}/man1/wxGUI.*.1*
344 %{_mandir}/man1/wxpyimgview.1*
345 %{_mandir}/man1/ximgview.1*
346
347 %files devel
348 %defattr(644,root,root,755)
349 %doc dist.*/docs/html/*
350 %attr(755,root,root) %{_libdir}/libgrass_*[!0-9].so
351 %attr(755,root,root) %{_libdir}/libgrass_btree2.so
352 %attr(755,root,root) %{_libdir}/libgrass_dig2.so
353 %{_libdir}/libgrass_iostream.*.a
354 %{_includedir}/grass%{gver}
This page took 0.178013 seconds and 3 git commands to generate.