]> git.pld-linux.org Git - packages/gnome-tweaks.git/commitdiff
Update to 3.26.4 auto/th/gnome-tweak-tool-3.26.4-1
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Tue, 12 Dec 2017 20:57:26 +0000 (21:57 +0100)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Tue, 12 Dec 2017 20:57:26 +0000 (21:57 +0100)
- removed obsolete pyc and -import-gobject patches

gnome-tweak-tool-import-gobject.patch [deleted file]
gnome-tweak-tool.spec
pyc.patch [deleted file]

diff --git a/gnome-tweak-tool-import-gobject.patch b/gnome-tweak-tool-import-gobject.patch
deleted file mode 100644 (file)
index 30b1507..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- gnome-tweak-tool-3.8.0/gtweak/mainwindow.py.old    2013-04-10 23:06:30.179200530 +0200
-+++ gnome-tweak-tool-3.8.0/gtweak/mainwindow.py        2013-04-10 23:06:38.552488501 +0200
-@@ -17,6 +17,7 @@
- import os.path
-+from gi.repository import GObject
- from gi.repository import Gtk
- import gtweak
index dc3deb3b65e0c8c6aeb45ee001bb1eacc083a6f1..0a7f94d819d37a3b4152af9e7abe27d0a6fe4eea 100644 (file)
@@ -1,23 +1,21 @@
 Summary:       A tool to customize advanced GNOME 3 options
 Summary(pl.UTF-8):     Narzędzie do dostosowywania zaawansowanych opcji GNOME 3
 Name:          gnome-tweak-tool
-Version:       3.24.1
+Version:       3.26.4
 Release:       1
 License:       GPL v3+
 Group:         X11/Applications
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-tweak-tool/3.24/%{name}-%{version}.tar.xz
-# Source0-md5: 74b346ac732042cf870aafe4c18dbcaa
-Patch0:                pyc.patch
-Patch1:                %{name}-import-gobject.patch
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-tweak-tool/3.26/%{name}-%{version}.tar.xz
+# Source0-md5: 2018fc13a1e61fbaff3ee53b4968d7eb
 URL:           http://live.gnome.org/GnomeTweakTool
 BuildRequires: gettext-tools >= 0.17
 BuildRequires: glib2-devel >= 2.0
 BuildRequires: gsettings-desktop-schemas-devel >= 3.24
-BuildRequires: gtk+3-devel >= 3.12.0
 BuildRequires: intltool >= 0.40.0
+BuildRequires: meson >= 0.40.0
 BuildRequires: pkgconfig
-BuildRequires: python >= 1:2.6
 BuildRequires: python-pygobject3-devel >= 3.10
+BuildRequires: python3 >= 1:3.0
 BuildRequires: rpmbuild(macros) >= 1.311
 BuildRequires: sed >= 4.0
 BuildRequires: tar >= 1:1.22
@@ -29,8 +27,10 @@ Requires:    gobject-introspection
 Requires:      gsettings-desktop-schemas >= 3.24
 Requires:      gtk+3 >= 3.12.0
 Requires:      hicolor-icon-theme
-Requires:      python >= 1:2.6
+Requires:      libnotify >= 0.7
+Requires:      libsoup >= 2.4
 Requires:      python-pygobject3 >= 3.10
+Requires:      python3 >= 1:3.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -41,22 +41,17 @@ Narzędzie do dostosowywania zaawansowanych opcji GNOME 3.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
 
 %{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' gnome-tweak-tool gnome-tweak-tool-lid-inhibitor
 
 %build
-%configure
-%{__make}
+%meson build
+%meson_build -C build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-%py_postclean
+%meson_install -C build
 
 %find_lang %{name}
 
@@ -74,12 +69,9 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS NEWS README
 %attr(755,root,root) %{_bindir}/gnome-tweak-tool
 %attr(755,root,root) %{_libexecdir}/gnome-tweak-tool-lid-inhibitor
-%dir %{py_sitescriptdir}/gtweak
-%{py_sitescriptdir}/gtweak/*.py[co]
-%dir %{py_sitescriptdir}/gtweak/tweaks
-%{py_sitescriptdir}/gtweak/tweaks/*.py[co]
+%{py3_sitedir}/gtweak
 %{_datadir}/gnome-tweak-tool
-%{_datadir}/appdata/gnome-tweak-tool.appdata.xml
+%{_datadir}/metainfo/gnome-tweak-tool.appdata.xml
 %{_desktopdir}/gnome-tweak-tool.desktop
 %{_iconsdir}/hicolor/*x*/apps/gnome-tweak-tool.png
 %{_iconsdir}/hicolor/scalable/apps/gnome-tweak-tool-symbolic.svg
diff --git a/pyc.patch b/pyc.patch
deleted file mode 100644 (file)
index 3d04d60..0000000
--- a/pyc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN gnome-tweak-tool-2.91.92/gtweak/tweakmodel.py gnome-tweak-tool-2.91.92.new//gtweak/tweakmodel.py
---- gnome-tweak-tool-2.91.92/gtweak/tweakmodel.py      2011-03-09 20:33:40.000000000 +0000
-+++ gnome-tweak-tool-2.91.92.new//gtweak/tweakmodel.py 2011-03-19 12:46:22.703334424 +0000
-@@ -67,7 +67,7 @@
-     def load_tweaks(self, main_window):
-         tweak_files = [
-                 os.path.splitext(os.path.split(f)[-1])[0]
--                    for f in glob.glob(os.path.join(self._tweak_dir, "tweak_group_*.py"))]
-+                    for f in glob.glob(os.path.join(self._tweak_dir, "tweak_group_*.pyc"))]
-         if not gtweak.ENABLE_TEST:
-             try:
This page took 0.121283 seconds and 4 git commands to generate.