]> git.pld-linux.org Git - packages/ghc-connection.git/blame - ghc-connection.spec
rebuild with ghc 8.10.7
[packages/ghc-connection.git] / ghc-connection.spec
CommitLineData
0bf44bd1
JR
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname connection
6Summary: Simple and easy network connections API
7Name: ghc-%{pkgname}
8Version: 0.3.1
29d56774 9Release: 2
0bf44bd1
JR
10License: BSD
11Group: Development/Languages
12#Source0Download: http://hackage.haskell.org/package/connection
13Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14# Source0-md5: 6a9647665c357cd33118339b777578eb
15URL: http://hackage.haskell.org/package/connection
16BuildRequires: ghc >= 6.12.3
17BuildRequires: ghc-basement
18BuildRequires: ghc-data-default-class
19BuildRequires: ghc-network >= 2.6.3
20BuildRequires: ghc-socks >= 0.6
21BuildRequires: ghc-tls >= 1.4
22BuildRequires: ghc-x509 >= 1.5
23BuildRequires: ghc-x509-store >= 1.5
24BuildRequires: ghc-x509-system >= 1.5
25BuildRequires: ghc-x509-validation >= 1.5
26%if %{with prof}
27BuildRequires: ghc-prof
28BuildRequires: ghc-basement-prof
29BuildRequires: ghc-data-default-class-prof
30BuildRequires: ghc-network-prof >= 2.6.3
31BuildRequires: ghc-socks-prof >= 0.6
32BuildRequires: ghc-tls-prof >= 1.4
33BuildRequires: ghc-x509-prof >= 1.5
34BuildRequires: ghc-x509-store-prof >= 1.5
35BuildRequires: ghc-x509-system-prof >= 1.5
36BuildRequires: ghc-x509-validation-prof >= 1.5
37%endif
38BuildRequires: rpmbuild(macros) >= 1.608
39%requires_eq ghc
40Requires(post,postun): /usr/bin/ghc-pkg
41Requires: ghc-basement
42Requires: ghc-data-default-class
43Requires: ghc-network >= 2.6.3
44Requires: ghc-socks >= 0.6
45Requires: ghc-tls >= 1.4
46Requires: ghc-x509 >= 1.5
47Requires: ghc-x509-store >= 1.5
48Requires: ghc-x509-system >= 1.5
49Requires: ghc-x509-validation >= 1.5
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52# debuginfo is not useful for ghc
53%define _enable_debug_packages 0
54
55# don't compress haddock files
56%define _noautocompressdoc *.haddock
57
58%description
59This library provides a very simple api to create sockets to a
60destination with the choice of SSL/TLS, and SOCKS.
61
62%package prof
63Summary: Profiling %{pkgname} library for GHC
64Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67Requires: ghc-basement-prof
68Requires: ghc-data-default-class-prof
69Requires: ghc-network-prof >= 2.6.3
70Requires: ghc-socks-prof >= 0.6
71Requires: ghc-tls-prof >= 1.4
72Requires: ghc-x509-prof >= 1.5
73Requires: ghc-x509-store-prof >= 1.5
74Requires: ghc-x509-system-prof >= 1.5
75Requires: ghc-x509-validation-prof >= 1.5
76
77%description prof
78Profiling %{pkgname} library for GHC. Should be installed when
79GHC's profiling subsystem is needed.
80
81%description prof -l pl.UTF-8
82Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
83kiedy potrzebujemy systemu profilującego z GHC.
84
85%prep
86%setup -q -n %{pkgname}-%{version}
87
88%build
89runhaskell Setup.hs configure -v2 \
90 %{?with_prof:--enable-library-profiling} \
91 --prefix=%{_prefix} \
92 --libdir=%{_libdir} \
93 --libexecdir=%{_libexecdir} \
94 --docdir=%{_docdir}/%{name}-%{version}
95
96runhaskell Setup.hs build %{?_smp_mflags}
97runhaskell Setup.hs haddock --executables
98
99%install
100rm -rf $RPM_BUILD_ROOT
101install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
102
103runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
104
105# work around automatic haddock docs installation
106%{__rm} -rf %{name}-%{version}-doc
107cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
108%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
109
110runhaskell Setup.hs register \
111 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post
117%ghc_pkg_recache
118
119%postun
120%ghc_pkg_recache
121
122%files
123%defattr(644,root,root,755)
124%doc CHANGELOG.md README.md %{name}-%{version}-doc/*
125%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
126%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
127%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
128%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
129%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
130
131%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network
132%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.hi
133%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.dyn_hi
134%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Connection
135%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Connection/*.hi
136%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Connection/*.dyn_hi
137
138%if %{with prof}
139%files prof
140%defattr(644,root,root,755)
141%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
142%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.p_hi
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/Connection/*.p_hi
144%endif
This page took 0.112737 seconds and 4 git commands to generate.