]> git.pld-linux.org Git - packages/gettext.git/blob - gettext.spec
- updated to 0.22.5
[packages/gettext.git] / gettext.spec
1 #
2 # Conditional build:
3 %bcond_without  asprintf        # libasprintf C++ library
4 %bcond_with     xemacs          # po-mode for xemacs
5 %bcond_without  java            # convenience bcond to disable Java (any)
6 %bcond_with     gcj             # Java support by gcj (preferred over javac)
7 %bcond_without  javac           # Java support by some javac
8 %bcond_without  dotnet          # .NET support package
9 %bcond_with     bootstrap       # no system GLib, libcroco, libxml2 (for bootstrap)
10
11 %ifnarch %{ix86} %{x8664} %{arm} hppa ppc s390 s390x
12 %undefine with_dotnet
13 %endif
14 %ifarch i386
15 # plain i386 is not supported; mono uses cmpxchg/xadd which require i486
16 %undefine with_dotnet
17 %endif
18 %if %{with javac}
19 %undefine with_gcj
20 %{?use_default_jdk}
21 %endif
22 %if %{without java}
23 %undefine with_gcj
24 %undefine with_javac
25 %endif
26
27 %define build_java      %{?with_gcj:1}%{!?with_gcj:%{?with_javac:1}%{!?with_javac:0}}
28 %define build_javaexe   %{?with_gcj:1}%{!?with_gcj:0}
29 Summary:        Utilties for program national language support
30 Summary(de.UTF-8):      Utilities zum Programmieren von nationaler Sprachunterstützung
31 Summary(es.UTF-8):      Utilitarios para el programa de soporte a lenguas locales
32 Summary(fr.UTF-8):      Utilitaires pour le support de la langue nationnalepar les programmes
33 Summary(ja.UTF-8):      マルチリンガルメッセージを生成するためのGNU ライブラリ/ユーティリティ
34 Summary(pl.UTF-8):      Narzędzia dla programów ze wsparciem dla języków narodowych
35 Summary(pt_BR.UTF-8):   Utilitários para o programa de suporte de línguas locais
36 Summary(ru.UTF-8):      Библиотеки и утилиты для поддержки национальных языков
37 Summary(tr.UTF-8):      Desteği için kitaplık ve araçlar
38 Summary(uk.UTF-8):      Бібліотеки та утиліти для підтримки національних мов
39 Name:           gettext
40 Version:        0.22.5
41 Release:        1
42 License:        LGPL v2.1+ (libintl), GPL v3+ (tools)
43 Group:          Development/Tools
44 Source0:        https://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.lz
45 # Source0-md5:  d82550b0c72b2bf175b682d27c7565fc
46 Patch0:         %{name}-info.patch
47 Patch1:         %{name}-killkillkill.patch
48 Patch3:         %{name}-libdir.patch
49 URL:            http://www.gnu.org/software/gettext/
50 BuildRequires:  acl-devel
51 BuildRequires:  autoconf >= 2.64
52 BuildRequires:  automake >= 1:1.13
53 %{?with_gcj:BuildRequires:      gcc-java >= 3.0}
54 %{!?with_bootstrap:BuildRequires:       glib2-devel >= 2.0}
55 %{?with_gcj:BuildRequires:      jar}
56 %{?with_javac:%buildrequires_jdk}
57 %{!?with_bootstrap:BuildRequires:       libcroco-devel >= 0.6.1}
58 %if "%{cc_version}" >= "4.2"
59 BuildRequires:  libgomp-devel
60 %endif
61 %{?with_asprintf:BuildRequires: libstdc++-devel}
62 BuildRequires:  libtool >= 2:2
63 BuildRequires:  libunistring-devel
64 %{!?with_bootstrap:BuildRequires:       libxml2-devel}
65 BuildRequires:  lzip
66 %{?with_dotnet:BuildRequires:   mono-csharp}
67 BuildRequires:  ncurses-devel
68 %{?with_java:BuildRequires:     rpm-javaprov}
69 BuildRequires:  rpmbuild(macros) >= 2.021
70 BuildRequires:  sed >= 4.0
71 BuildRequires:  tar >= 1:1.22
72 BuildRequires:  texinfo
73 %{?with_xemacs:BuildRequires:   xemacs}
74 Obsoletes:      gettext-base
75 Conflicts:      intltool < 0.28
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 # adjust -f when needed (e.g. 0.18.3.x used ABI 0.18.3, 0.19.5.x uses full version)
79 %define         intabi  %(echo %{version} | cut -d. -f1-3)
80 # similarly for its data
81 %define         dataver %(echo %{version} | cut -d. -f1-3)
82
83 %description
84 The GNU gettext package provides a set of tools and documentation for
85 producing multi-lingual messages in programs. Tools include a set of
86 conventions about how programs should be written to support message
87 catalogs, a directory and file naming organization for the message
88 catalogs, a runtime library which supports the retrieval of translated
89 messages, and stand-alone programs for handling the translatable and
90 the already translated strings. Gettext provides an easy to use
91 library and tools for creating, using, and modifying natural language
92 catalogs and is a powerful and simple method for internationalizing
93 programs.
94
95 %description -l de.UTF-8
96 Die gettext-Library enthält eine einfach anzuwendende Library und
97 Tools zum Erstellen, Verwenden und Ändern von
98 natürlichsprachigen-Kataloge. Es ist ein einfaches und
99 leistungsfähiges Verfahren zum Lokalisieren von Programmen.
100
101 %description -l es.UTF-8
102 La biblioteca gettext nos ofrece una biblioteca fácil de usar y
103 herramientas para creación, uso y modificación de catálogos de
104 lenguaje natural. Es un potente y sencillo método de
105 internacionalización de programas.
106
107 %description -l fr.UTF-8
108 La librarie gettext fournit des outils et une librairie simple à
109 utiliser pour manipuler, créer, et modifier des catalogues de langage
110 naturel. C'est une méthode simple et puissante pour internationnaliser
111 les programmes.
112
113 %description -l ja.UTF-8
114 GNU gettext
115 パッケージはプログラム中でマルチリンガルメッセージを生成する
116 ためのツールと文書を供給する。ツールはメッセージカタログをサポートするために
117 プログラムがどのように書かれるべきかの申し合わせと、メッセージカタログのための
118 ディレクトリとファイル名の組織化と、翻訳されたメッセージの埋め合わせを
119 サポートするためのランタイムライブラリと、翻訳可能でかつすでに翻訳された文字列
120 を取り扱う独立したプログラムを含んでいる。gettext
121 は簡単に使えるライブラリ
122 と自然言語のカタログを生成、使用、修正するツールと、国際化プログラム
123 のための強力かつシンプルな方法を供給する。
124
125 %description -l pl.UTF-8
126 Pakiet gettext dostarcza narzędzi do tworzenia, używania i modyfikacji
127 katalogów języków narodowych. To jest prosta i wydajna metoda
128 lokalizacji (internacjonalizacji) programów.
129
130 %description -l pt_BR.UTF-8
131 A biblioteca gettext oferece uma biblioteca fácil de usar e
132 ferramentas para criação, uso e modificação de catálogos de linguagem
133 natural. Ele é um poderoso e simples método de internacionalização de
134 programas.
135
136 %description -l ru.UTF-8
137 Пакет gettext содержит библиотеку и простые в использовании
138 инструменты для создания, использования и модификации каталогов
139 национальных языков. Это простой и мощный метод для
140 интернационализации программ.
141
142 %description -l tr.UTF-8
143 gettext, yerel dil desteğinde kullanılan katalogları değiştirebilmek
144 için, kolayca kullanılabilen kitaplık ve araçları sağlar. Bu,
145 programları uluslararasılaştırmak için sıkça başvurulan, kuvvetli bir
146 yöntemdir.
147
148 %description -l uk.UTF-8
149 Пакет gettext містить бібліотеку та прості у використанні інструменти
150 для створення, використання та модифікації каталогів національних мов.
151 Це простий та потужний метод для інтернаціоналізації програм.
152
153 %package tools
154 Summary:        Utilties for program national language support
155 Summary(de.UTF-8):      Utilities zum Programmieren von nationaler Sprachunterstützung
156 Summary(fr.UTF-8):      Utilitaires pour le support de la langue nationnalepar les programmes
157 Summary(pl.UTF-8):      Narzędzia dla programów ze wsparciem dla języków narodowych
158 Summary(tr.UTF-8):      Desteği için kitaplık ve araçlar
159 License:        GPL v3+
160 Group:          Development/Tools
161 Requires(post,postun):  /sbin/ldconfig
162 Requires:       %{name}-libs = %{version}-%{release}
163 Requires:       iconv
164 Conflicts:      autoconf < 2.52
165 Conflicts:      rpm-build-macros < 1.744
166
167 %description tools
168 This package contains tools for creating and modifying natural
169 language catalogs.
170
171 %description tools -l pl.UTF-8
172 Ten pakiet zawiera narzędzia do tworzenia i modyfikowania katalogów
173 z obsługą języków naturalnych.
174
175 %package demo
176 Summary:        Demo for gettext
177 Summary(pl.UTF-8):      Pliki demonstracyjne dla pakietu gettext
178 Group:          Documentation
179 Requires:       %{name}-devel = %{version}-%{release}
180
181 %description demo
182 Demonstrations and samples for gettext.
183
184 %description demo -l pl.UTF-8
185 Pliki demonstracyjne i przykłady dla pakietu gettext.
186
187 %package libs
188 Summary:        Shared gettext utility libraries
189 Summary(pl.UTF-8):      Współdzielone biblioteki narzędziowe gettexta
190 License:        GPL v3+
191 Group:          Development/Libraries
192 # relaxed to allow newer package from libtextstyle.spec
193 Requires:       libtextstyle >= %{version}-%{release}
194
195 %description libs
196 This package contains shared versions of gettext utility libraries
197 (libgettextlib, libgettextsrc and libgettextpo).
198
199 %description libs -l pl.UTF-8
200 Ten pakiet zawiera współdzielone wersje bibliotek narzędziowych
201 gettext (libgettextlib, libgettextsrc i libgettextpo).
202
203 %package devel
204 Summary:        Development files for gettext libraries
205 Summary(pl.UTF-8):      Pliki programistyczne bibliotek gettexta
206 License:        GPL v3+
207 Group:          Development/Libraries
208 Requires:       %{name}-libs = %{version}-%{release}
209 # relaxed to allow newer package from libtextstyle.spec
210 Requires:       libtextstyle-devel >= %{version}-%{release}
211
212 %description devel
213 Development files for gettext libraries.
214
215 %description devel -l pl.UTF-8
216 Pliki programistyczne bibliotek gettexta.
217
218 %package static
219 Summary:        Static gettext utility libraries
220 Summary(pl.UTF-8):      Statyczne biblioteki narzędziowe gettext
221 License:        GPL v3+
222 Group:          Development/Libraries
223 Requires:       %{name}-devel = %{version}-%{release}
224
225 %description static
226 This package contains static versions of gettext utility libraries
227 (libgettextlib, libgettextsrc and libgettextpo).
228
229 %description static -l pl.UTF-8
230 Ten pakiet zawiera statyczne wersje bibliotek narzędziowych gettext
231 (libgettextlib, libgettextsrc i libgettextpo).
232
233 %package -n libasprintf
234 Summary:        GNU libasprintf - automatic formatted output to strings in C++
235 Summary(pl.UTF-8):      GNU libasprintf - automatyczne formatowanie wyjścia do łańcuchów w C++
236 License:        LGPL v2.1+
237 Group:          Libraries
238
239 %description -n libasprintf
240 This package makes the C formatted output routines (`fprintf' et al.)
241 usable in C++ programs, for use with the `<string>' strings and the
242 `<iostream>' streams.
243
244 %description -n libasprintf -l pl.UTF-8
245 Ten pakiet czyni funkcje C formatujące wyjście (fprintf i inne)
246 używalnymi w programach w C++, z łańcuchami <string> i strumieniami
247 <iostream>.
248
249 %package -n libasprintf-devel
250 Summary:        Header file and documentation for libasprintf
251 Summary(pl.UTF-8):      Plik nagłówkowy i dokumentacja dla libasprintf
252 License:        LGPL v2.1+
253 Group:          Development/Libraries
254 Requires:       libasprintf = %{version}-%{release}
255
256 %description -n libasprintf-devel
257 Header file and documentation for libasprintf.
258
259 %description -n libasprintf-devel -l pl.UTF-8
260 Plik nagłówkowy i dokumentacja dla libasprintf.
261
262 %package -n libasprintf-static
263 Summary:        Static libasprintf library
264 Summary(pl.UTF-8):      Statyczna biblioteka libasprintf
265 License:        LGPL v2.1+
266 Group:          Development/Libraries
267 Requires:       libasprintf-devel = %{version}-%{release}
268
269 %description -n libasprintf-static
270 Static libasprintf library.
271
272 %description -n libasprintf-static -l pl.UTF-8
273 Statyczna biblioteka libasprintf.
274
275 %package -n libtextstyle
276 Summary:        GNU libtextstyle - Text styling library
277 Summary(pl.UTF-8):      GNU libtextstyle - biblioteka do obsługi stylu tekstu
278 License:        GPL v3+
279
280 %description -n libtextstyle
281 This library provides an easy way to add styling to programs that
282 produce output to a console or terminal emulator window.
283
284 libtextstyle is for you if your application produces text that is more
285 readable when it is accompanied with styling information, such as
286 color, font attributes (weight, posture), or underlining.
287
288 %description -n libtextstyle -l pl.UTF-8
289 Ta biblioteka zapewnia łatwy sposób dodawania styli do programów
290 produkujących wyjście na konsoli lub w oknie emulatora terminala.
291
292 libtextstyle ma zastosowanie tam, gdzie aplikacja produkuje tekst,
293 który jest bardziej czytelny, jeśli jest wzbogacony o informacje o
294 stylu, takie jak kolor, atrybuty czcionek (grubość, nachylenie) lub
295 podkreślenie.
296
297 %package -n libtextstyle-devel
298 Summary:        Header files for libtextstyle library
299 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libtextstyle
300 License:        GPL v3+
301 Group:          Development/Libraries
302 Requires:       libtextstyle = %{version}-%{release}
303 Requires:       ncurses-devel
304
305 %description -n libtextstyle-devel
306 Header files for libtextstyle library.
307
308 %description -n libtextstyle-devel -l pl.UTF-8
309 Pliki nagłówkowe biblioteki libtextstyle.
310
311 %package -n libtextstyle-static
312 Summary:        Static libtextstyle library
313 Summary(pl.UTF-8):      Statyczna biblioteka libtextstyle
314 License:        GPL v3+
315 Group:          Development/Libraries
316 Requires:       libtextstyle-devel = %{version}-%{release}
317
318 %description -n libtextstyle-static
319 Static libtextstyle library.
320
321 %description -n libtextstyle-static -l pl.UTF-8
322 Statyczna biblioteka libtextstyle.
323
324 %package java
325 Summary:        Runtime classes for Java programs internationalization
326 Summary(pl.UTF-8):      Klasy do uruchamiania umiędzynarodowionych programów w Javie
327 License:        LGPL v2.1+
328 Group:          Development/Languages/Java
329 Requires:       %{name} = %{version}-%{release}
330
331 %description java
332 Runtime classes for Java programs internationalization.
333
334 %description java -l pl.UTF-8
335 Klasy do uruchamiania umiędzynarodowionych programów w Javie.
336
337 %package java-devel
338 Summary:        Development classes for Java programs internationalization
339 Summary(pl.UTF-8):      Klasy do umiędzynarodowiania programów w Javie dla programistów
340 License:        GPL v3+
341 Group:          Development/Tools
342 Requires:       %{name}-devel = %{version}-%{release}
343
344 %description java-devel
345 Development classes for Java programs internationalization.
346
347 %description java-devel -l pl.UTF-8
348 Klasy do umiędzynarodowiania programów w Javie dla programistów.
349
350 %package -n xemacs-po-mode-pkg
351 Summary:        Xemacs PO-mode
352 Summary(es.UTF-8):      Facilita la edición de archivos PO (internacionalización) con emacs
353 Summary(pl.UTF-8):      Tryb PO dla Xemacsa
354 Summary(pt_BR.UTF-8):   Facilita a edição de arquivos PO (internacionalização) com o emacs
355 License:        GPL v2+
356 Group:          Applications/Editors/Emacs
357 Requires:       xemacs
358
359 %description -n xemacs-po-mode-pkg
360 Emacs PO-mode.
361
362 %description -n xemacs-po-mode-pkg -l es.UTF-8
363 Este paquete suministra las herramientas para ayudar en la edición de
364 archivos PO, como documentado en el manual del usuario del GNU
365 gettext. Mira este manual para la documentación de uso, que no se
366 incluye aquí.
367
368 %description -n xemacs-po-mode-pkg -l pl.UTF-8
369 Tryb edycji PO dla emacsa.
370
371 %description -n xemacs-po-mode-pkg -l pt_BR.UTF-8
372 Este pacote provê as ferramentas para ajudar na edição de arquivos PO,
373 como documentado no manual do usuário do GNU gettext. Veja este manual
374 para a documentação de uso, a qual não é incluída aqui.
375
376 %package autopoint
377 Summary:        gettextize replacement
378 Summary(pl.UTF-8):      Zamiennik gettextize
379 License:        GPL v3+
380 Group:          Development/Tools
381 Requires:       %{name}-devel >= 0.10.35
382 Requires:       xz
383
384 %description autopoint
385 The `autopoint' program copies standard gettext infrastructure files
386 into a source package. It extracts from a macro call of the form
387 `AM_GNU_GETTEXT_VERSION(VERSION)', found in the package's
388 `configure.in' or `configure.ac' file, the gettext version used by the
389 package, and copies the infrastructure files belonging to this version
390 into the package.
391
392 %description autopoint -l pl.UTF-8
393 Program autopoint kopiuje standardowe pliki infrastruktury gettexta do
394 pakietu źródłowego. Wyciąga użytą wersję gettexta z wywołania makra w
395 postaci AM_GNU_GETTEXT_VERSION(VERSION) w pliku configure.in lub
396 configure.ac i kopiuje do pakietu pliki infrastruktury należące do tej
397 wersji.
398
399 %package -n dotnet-gettext
400 Summary:        GNU gettext for C#
401 Summary(pl.UTF-8):      GNU gettext dla C#
402 License:        LGPL v2.1+ (GNU.Gettext library), GPL v3+ (tools)
403 Group:          Development/Tools
404
405 %description -n dotnet-gettext
406 GNU gettext for C#.
407
408 %description -n dotnet-gettext -l pl.UTF-8
409 GNU gettext dla C#.
410
411 %prep
412 %setup -q
413 %patch0 -p1
414 %patch1 -p1
415 %patch3 -p1
416
417 %{__sed} -i \
418         -e 's@m4_esyscmd(\[build-aux/git-version-gen \.tarball-version\])@[%{version}]@' \
419         configure.ac
420 %{__sed} -i \
421         -e 's@m4_esyscmd(\[\.\./build-aux/git-version-gen \.\./\.tarball-version\])@[%{version}]@' \
422         gettext-runtime/configure.ac \
423         gettext-tools/configure.ac
424
425 %if %{without bootstrap}
426 %{__sed} -i -e '/gl_LIBCROCO\|gl_LIBGLIB\|gl_LIBXML/s/(\[yes\])//' libtextstyle/gnulib-m4/gnulib-comp.m4
427 %endif
428
429 %build
430 cd gettext-runtime
431 %{__libtoolize}
432 %{__aclocal} -I m4 -I ../m4 -I gnulib-m4
433 %{__autoconf}
434 %{__autoheader}
435 %{__automake}
436 cd libasprintf
437 %{__aclocal} -I ../../m4 -I ../m4 -I gnulib-m4
438 %{__autoconf}
439 %{__autoheader}
440 %{__automake}
441 cd ../../libtextstyle
442 %{__libtoolize}
443 %{__aclocal} -I m4 -I gnulib-m4
444 %{__autoconf}
445 %{__autoheader}
446 %{__automake}
447 cd ../gettext-tools
448 %{__aclocal} -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
449 %{__autoconf}
450 %{__autoheader}
451 %{__automake}
452 cd examples
453 %{__aclocal} -I ../../gettext-runtime/m4 -I ../../m4
454 %{__autoconf}
455 %{__automake}
456 cd ../..
457 %{__aclocal} -I m4
458 %{__autoconf}
459 %{__automake}
460 %configure \
461         %{!?with_gcj:GCJ=none} \
462         %{?with_javac:JAVA="%{java_home}/bin/java" JAVAC="%{java_home}/bin/javac" JAR="%{java_home}/bin/jar"} \
463         %{?with_xemacs:--with-lispdir=%{_datadir}/xemacs-packages/lisp/po-mode} \
464         %{!?with_xemacs:--without-emacs} \
465         --enable-csharp=%{?with_dotnet:mono}%{!?with_dotnet:no} \
466 %if !%{build_java}
467         --disable-java \
468 %endif
469         --enable-nls \
470         --disable-silent-rules \
471         --without-bzip2 \
472         --without-git \
473         --without-included-gettext \
474         --with-xz
475 %{__make} \
476         GMSGFMT=`pwd`/gettext-tools/src/msgfmt
477
478 # msgfmt has been built, so now we can update pl.gmos
479 %{__make} pl.gmo -C gettext-runtime/po \
480         GMSGFMT=`pwd`/gettext-tools/src/msgfmt
481 %{__make} pl.gmo -C gettext-tools/po \
482         GMSGFMT=`pwd`/gettext-tools/src/msgfmt
483
484 %if %{with xemacs}
485 cd gettext-tools/misc
486 EMACS=%{_bindir}/xemacs ./elisp-comp ./po-mode.el
487 %endif
488
489 %install
490 rm -rf $RPM_BUILD_ROOT
491 install -d $RPM_BUILD_ROOT{/bin,%{_datadir}/gettext/its}
492
493 %{__make} install \
494         examplesdir=%{_examplesdir}/%{name}-%{version} \
495         examplesbuildauxdir=%{_examplesdir}/%{name}-%{version}/build-aux \
496         DESTDIR=$RPM_BUILD_ROOT
497
498 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{,n}gettext $RPM_BUILD_ROOT/bin
499
500 # these static libs are removed in install-exec-clean
501 cp -a gettext-tools/gnulib-lib/.libs/libgettextlib.a \
502         gettext-tools/src/.libs/libgettextsrc.a $RPM_BUILD_ROOT%{_libdir}
503
504 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/gettext
505 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libasprintf
506 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libtextstyle
507 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
508
509 %find_lang %{name}-runtime
510 %find_lang %{name}-tools
511
512 %clean
513 rm -rf $RPM_BUILD_ROOT
514
515 %post   tools -p /sbin/postshell
516 -/usr/sbin/fix-info-dir -c %{_infodir}
517
518 %postun tools -p /sbin/postshell
519 -/usr/sbin/fix-info-dir -c %{_infodir}
520
521 %post   libs -p /sbin/ldconfig
522 %postun libs -p /sbin/ldconfig
523
524 %post   devel -p /sbin/postshell
525 -/usr/sbin/fix-info-dir -c %{_infodir}
526
527 %postun devel -p /sbin/postshell
528 -/usr/sbin/fix-info-dir -c %{_infodir}
529
530 %post   -n libasprintf -p /sbin/ldconfig
531 %postun -n libasprintf -p /sbin/ldconfig
532
533 %post   -n libasprintf-devel -p /sbin/postshell
534 -/usr/sbin/fix-info-dir -c %{_infodir}
535
536 %postun -n libasprintf-devel -p /sbin/postshell
537 -/usr/sbin/fix-info-dir -c %{_infodir}
538
539 %post   -n libtextstyle -p /sbin/ldconfig
540 %postun -n libtextstyle -p /sbin/ldconfig
541
542 %post   -n libtextstyle-devel -p /sbin/postshell
543 -/usr/sbin/fix-info-dir -c %{_infodir}
544
545 %postun -n libtextstyle-devel -p /sbin/postshell
546 -/usr/sbin/fix-info-dir -c %{_infodir}
547
548 %files -f %{name}-runtime.lang
549 %defattr(644,root,root,755)
550 %attr(755,root,root) /bin/gettext
551 %attr(755,root,root) /bin/ngettext
552 %attr(755,root,root) %{_bindir}/envsubst
553 %attr(755,root,root) %{_bindir}/gettext.sh
554 %{_mandir}/man1/envsubst.1*
555 %{_mandir}/man1/gettext.1*
556 %{_mandir}/man1/ngettext.1*
557 %dir %{_libdir}/gettext
558 %dir %{_datadir}/gettext
559
560 %files tools
561 %defattr(644,root,root,755)
562 %doc AUTHORS ChangeLog NEWS README THANKS
563 %attr(755,root,root) %{_bindir}/gettextize
564 %attr(755,root,root) %{_bindir}/msg*
565 %attr(755,root,root) %{_bindir}/recode-sr-latin
566 %attr(755,root,root) %{_bindir}/xgettext
567 %attr(755,root,root) %{_libdir}/preloadable_libintl.so
568 %attr(755,root,root) %{_libdir}/gettext/cldr-plurals
569 %attr(755,root,root) %{_libdir}/gettext/hostname
570 %attr(755,root,root) %{_libdir}/gettext/project-id
571 %attr(755,root,root) %{_libdir}/gettext/urlget
572 %attr(755,root,root) %{_libdir}/gettext/user-email
573 %{_aclocaldir}/build-to-host.m4
574 %{_aclocaldir}/gettext.m4
575 %{_aclocaldir}/host-cpu-c-abi.m4
576 %{_aclocaldir}/iconv.m4
577 %{_aclocaldir}/intlmacosx.m4
578 %{_aclocaldir}/lib-ld.m4
579 %{_aclocaldir}/lib-link.m4
580 %{_aclocaldir}/lib-prefix.m4
581 %{_aclocaldir}/nls.m4
582 %{_aclocaldir}/po.m4
583 %{_aclocaldir}/progtest.m4
584 %{_infodir}/gettext.info*
585 %{_mandir}/man1/gettextize.1*
586 %{_mandir}/man1/msg*.1*
587 %{_mandir}/man1/recode-sr-latin.1*
588 %{_mandir}/man1/xgettext.1*
589 %{_mandir}/man3/bind_textdomain_codeset.3*
590 %{_mandir}/man3/bindtextdomain.3*
591 %{_mandir}/man3/dcgettext.3*
592 %{_mandir}/man3/dcngettext.3*
593 %{_mandir}/man3/dgettext.3*
594 %{_mandir}/man3/dngettext.3*
595 %{_mandir}/man3/gettext.3*
596 %{_mandir}/man3/ngettext.3*
597 %{_mandir}/man3/textdomain.3*
598 %{_datadir}/gettext/ABOUT-NLS
599 %attr(755,root,root) %{_datadir}/gettext/config.rpath
600 %{_datadir}/gettext/gettext.h
601 %dir %{_datadir}/gettext/its
602 %{_datadir}/gettext/msgunfmt.tcl
603 %{_datadir}/gettext/po
604 %dir %{_datadir}/gettext/projects
605 %{_datadir}/gettext/projects/index
606 %attr(755,root,root) %{_datadir}/gettext/projects/team-address
607 %dir %{_datadir}/gettext/projects/GNOME
608 %{_datadir}/gettext/projects/GNOME/teams.*
609 %attr(755,root,root) %{_datadir}/gettext/projects/GNOME/team-address
610 %attr(755,root,root) %{_datadir}/gettext/projects/GNOME/trigger
611 %dir %{_datadir}/gettext/projects/KDE
612 %{_datadir}/gettext/projects/KDE/teams.*
613 %attr(755,root,root) %{_datadir}/gettext/projects/KDE/team-address
614 %attr(755,root,root) %{_datadir}/gettext/projects/KDE/trigger
615 %dir %{_datadir}/gettext/projects/TP
616 %{_datadir}/gettext/projects/TP/teams.*
617 %attr(755,root,root) %{_datadir}/gettext/projects/TP/team-address
618 %attr(755,root,root) %{_datadir}/gettext/projects/TP/trigger
619 %{_datadir}/gettext/styles
620 %dir %{_datadir}/gettext-%{dataver}
621 %{_datadir}/gettext-%{dataver}/its
622
623 %files demo
624 %defattr(644,root,root,755)
625 %{_examplesdir}/%{name}-%{version}
626
627 %files libs -f %{name}-tools.lang
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_libdir}/libgettextlib-%{intabi}.so
630 %attr(755,root,root) %{_libdir}/libgettextsrc-%{intabi}.so
631 %attr(755,root,root) %{_libdir}/libgettextpo.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libgettextpo.so.0
633
634 %files devel
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/libgettextlib.so
637 %attr(755,root,root) %{_libdir}/libgettextsrc.so
638 %attr(755,root,root) %{_libdir}/libgettextpo.so
639 %{_libdir}/libgettextlib.la
640 %{_libdir}/libgettextsrc.la
641 %{_libdir}/libgettextpo.la
642 %{_includedir}/gettext-po.h
643
644 %files static
645 %defattr(644,root,root,755)
646 %{_libdir}/libgettextlib.a
647 %{_libdir}/libgettextsrc.a
648 %{_libdir}/libgettextpo.a
649
650 %if %{with asprintf}
651 %files -n libasprintf
652 %defattr(644,root,root,755)
653 %doc gettext-runtime/libasprintf/{AUTHORS,ChangeLog,README}
654 %attr(755,root,root) %{_libdir}/libasprintf.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libasprintf.so.0
656
657 %files -n libasprintf-devel
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/libasprintf.so
660 %{_libdir}/libasprintf.la
661 %{_includedir}/autosprintf.h
662 %{_infodir}/autosprintf.info*
663
664 %files -n libasprintf-static
665 %defattr(644,root,root,755)
666 %{_libdir}/libasprintf.a
667 %endif
668
669 %files -n libtextstyle
670 %defattr(644,root,root,755)
671 %doc libtextstyle/{AUTHORS,NEWS,README}
672 %attr(755,root,root) %{_libdir}/libtextstyle.so.*.*.*
673 %attr(755,root,root) %ghost %{_libdir}/libtextstyle.so.0
674
675 %files -n libtextstyle-devel
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/libtextstyle.so
678 %{_libdir}/libtextstyle.la
679 %{_includedir}/textstyle.h
680 %{_includedir}/textstyle
681 %{_infodir}/libtextstyle.info*
682
683 %files -n libtextstyle-static
684 %defattr(644,root,root,755)
685 %{_libdir}/libtextstyle.a
686
687 %if %{build_java}
688 %files java
689 %defattr(644,root,root,755)
690 %{_datadir}/gettext/libintl.jar
691
692 %files java-devel
693 %defattr(644,root,root,755)
694 %doc gettext-runtime/intl-java/javadoc2
695 %if %{build_javaexe}
696 %attr(755,root,root) %{_libdir}/gettext/gnu.gettext.DumpResource
697 %attr(755,root,root) %{_libdir}/gettext/gnu.gettext.GetURL
698 %else
699 %{_datadir}/gettext/gettext.jar
700 %endif
701 %{_datadir}/gettext/javaversion.class
702 %endif
703
704 %if %{with xemacs}
705 %files -n xemacs-po-mode-pkg
706 %defattr(644,root,root,755)
707 %dir %{_datadir}/xemacs-packages/lisp/po-mode
708 %{_datadir}/xemacs-packages/lisp/po-mode/*.elc
709 %endif
710
711 %files autopoint
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_bindir}/autopoint
714 %{_datadir}/gettext/archive.dir.tar.xz
715 %{_mandir}/man1/autopoint.1*
716
717 %if %{with dotnet}
718 %files -n dotnet-gettext
719 %defattr(644,root,root,755)
720 %{_libdir}/GNU.Gettext.dll
721 %{_libdir}/gettext/msgfmt.net.exe
722 %{_libdir}/gettext/msgunfmt.net.exe
723 %endif
This page took 0.102914 seconds and 4 git commands to generate.