]> git.pld-linux.org Git - packages/gegl.git/commitdiff
- updated to 0.3.2
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 23 Nov 2015 14:55:47 +0000 (15:55 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 23 Nov 2015 14:55:47 +0000 (15:55 +0100)
- added format patch

gegl-format.patch [new file with mode: 0644]
gegl.spec

diff --git a/gegl-format.patch b/gegl-format.patch
new file mode 100644 (file)
index 0000000..8d79cae
--- /dev/null
@@ -0,0 +1,112 @@
+--- gegl-0.3.2/operations/external/tiff-load.c.orig    2015-11-21 03:52:39.000000000 +0100
++++ gegl-0.3.2/operations/external/tiff-load.c 2015-11-22 16:49:12.660225294 +0100
+@@ -131,7 +131,7 @@
+                                  NULL, &error);
+       if (read < 0)
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+         }
+     }
+@@ -162,7 +162,7 @@
+                                          NULL, &error);
+               if (read < 0)
+                 {
+-                  g_warning(error->message);
++                  g_warning("%s",error->message);
+                   g_error_free(error);
+                   break;
+                 }
+@@ -215,7 +215,7 @@
+         position = g_seekable_tell(G_SEEKABLE(p->stream));
+       else
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+         }
+     }
+@@ -257,7 +257,7 @@
+                                 NULL, &error);
+   if (!closed)
+     {
+-      g_warning(error->message);
++      g_warning("%s", error->message);
+       g_error_free(error);
+     }
+@@ -295,7 +295,7 @@
+                                NULL, &error);
+       if (info == NULL)
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+         }
+       else
+@@ -701,7 +701,7 @@
+         p->can_seek = g_seekable_can_seek(G_SEEKABLE(p->stream));
+       if (p->stream == NULL)
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+           cleanup(operation);
+           return;
+--- gegl-0.3.2/operations/external/tiff-save.c.orig    2015-11-21 04:22:59.000000000 +0100
++++ gegl-0.3.2/operations/external/tiff-save.c 2015-11-22 17:47:58.636818466 +0100
+@@ -117,7 +117,7 @@
+                                       NULL, &error);
+       if (written < 0)
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+         }
+     }
+@@ -165,7 +165,7 @@
+         position = g_seekable_tell(G_SEEKABLE(p->stream));
+       else
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+         }
+     }
+@@ -216,7 +216,7 @@
+                                           NULL, &error);
+           if (written < 0)
+             {
+-                  g_warning(error->message);
++                  g_warning("%s", error->message);
+                   g_error_free(error);
+                   break;
+             }
+@@ -229,7 +229,7 @@
+                                  NULL, &error);
+   if (!closed)
+     {
+-      g_warning(error->message);
++      g_warning("%s", error->message);
+       g_error_free(error);
+     }
+@@ -266,7 +266,7 @@
+                                NULL, &error);
+       if (info == NULL)
+         {
+-          g_warning(error->message);
++          g_warning("%s", error->message);
+           g_error_free(error);
+         }
+       else
+@@ -540,7 +540,7 @@
+   if (p->stream == NULL)
+     {
+       status = FALSE;
+-      g_warning(error->message);
++      g_warning("%s", error->message);
+       goto cleanup;
+     }
index befc58259591ab7414c802ac97eea40a63a66bde..c07ad14cf003755230d0dc4577109ec0828d2068 100644 (file)
--- a/gegl.spec
+++ b/gegl.spec
@@ -1,3 +1,4 @@
+# TODO: mrg (https://github.com/hodefoting/mrg/ ?)
 #
 # Conditional build:
 %bcond_with    mmx             # use MMX instructions
 Summary:       Generic image processing library
 Summary(pl.UTF-8):     Ogólna biblioteka przetwarzania obrazu
 Name:          gegl
-Version:       0.3.0
+Version:       0.3.2
 Release:       1
 License:       LGPL v3+
 Group:         Libraries
 Source0:       http://ftp.gimp.org/pub/gegl/0.3/%{name}-%{version}.tar.bz2
-# Source0-md5: 6d71daab78377d5074a74651bbf7a76a
+# Source0-md5: 6955dd2ac208448c8a2a4bc7c7f37869
 Patch0:                %{name}-lua.patch
+Patch1:                %{name}-format.patch
 Patch2:                %{name}-ruby1.9.patch
 Patch3:                %{name}-build.patch
 Patch5:                umfpack.patch
@@ -36,7 +38,7 @@ BuildRequires:        UMFPACK-devel
 BuildRequires: asciidoc
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake >= 1:1.11
-BuildRequires: babl-devel >= 0.1.12
+BuildRequires: babl-devel >= 0.1.14
 BuildRequires: cairo-devel
 BuildRequires: enscript
 BuildRequires: exiv2-devel
@@ -44,6 +46,7 @@ BuildRequires:        exiv2-devel
 BuildRequires: ffmpeg-devel >= 0.8
 BuildRequires: gdk-pixbuf2-devel >= 2.18.0
 BuildRequires: gettext-tools
+BuildRequires: gexiv2-devel
 BuildRequires: glib2-devel >= 1:2.36.0
 %{?with_introspection:BuildRequires:   gobject-introspection-devel >= 1.32.0}
 BuildRequires: graphviz
@@ -54,10 +57,11 @@ BuildRequires:      json-glib-devel
 BuildRequires: lcms2-devel >= 2.2
 BuildRequires: lensfun-devel >= 0.2.5
 BuildRequires: libjpeg-devel
-BuildRequires: libopenraw-devel >= 0.0.5
 BuildRequires: libpng-devel
+BuildRequires: libraw-devel >= 0.15.4
 BuildRequires: librsvg-devel >= 1:2.14.0
 BuildRequires: libspiro-devel
+BuildRequires: libtiff-devel >= 4.0.0
 BuildRequires: libtool >= 2:2.2
 BuildRequires: libv4l-devel >= 1.0.1
 BuildRequires: libwebp-devel
@@ -72,13 +76,14 @@ BuildRequires:      python-pygobject3-devel >= 3.2
 BuildRequires: poly2tri-c-devel
 BuildRequires: ruby >= 1.9
 %{?with_vala:BuildRequires:    vala >= 2:0.20.0}
-Requires:      babl >= 0.1.12
+Requires:      babl >= 0.1.14
 Requires:      gdk-pixbuf2 >= 2.18.0
 Requires:      glib2 >= 1:2.36.0
 Requires:      jasper-libs >= 1.900.1
 Requires:      lensfun >= 0.2.5
-Requires:      libopenraw >= 0.0.5
+Requires:      libraw >= 0.15.4
 Requires:      librsvg >= 1:2.14.0
+Requires:      libtiff >= 4.0.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -103,7 +108,7 @@ Summary:    Header files for gegl library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki gegl
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      babl-devel >= 0.1.12
+Requires:      babl-devel >= 0.1.14
 Requires:      glib2-devel >= 1:2.36.0
 
 %description devel
@@ -154,6 +159,7 @@ API języka Vala dla biblioteki gegl.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch5 -p1
@@ -190,7 +196,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.3/*.a
 %endif
 # examples with too common names
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/{hello-world,sdl-draw}
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/{frame-counter,hello-world,sdl-draw,video-invert}
 
 %find_lang %{name}-0.3
 
@@ -208,6 +214,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gegl-convert
 %attr(755,root,root) %{_bindir}/gegl-imgcmp
 %attr(755,root,root) %{_bindir}/gegl-slicer
+%attr(755,root,root) %{_bindir}/gegl-video
 %attr(755,root,root) %{_bindir}/gegl-tester
 %attr(755,root,root) %{_bindir}/geglbuffer-add-image
 %attr(755,root,root) %{_bindir}/geglbuffer-clock
This page took 0.075122 seconds and 4 git commands to generate.