- updated to 0.4.16 auto/th/gegl-0.4.16-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 12 Jun 2019 18:39:53 +0000 (20:39 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 12 Jun 2019 18:39:53 +0000 (20:39 +0200)
- removed obsolete Wformat-security patch

gegl-Wformat-security.patch [deleted file]
gegl.spec

diff --git a/gegl-Wformat-security.patch b/gegl-Wformat-security.patch
deleted file mode 100644 (file)
index a6dbc22..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- gegl-0.4.14/bin/ui-core.c~ 2019-03-01 13:59:14.000000000 +0100
-+++ gegl-0.4.14/bin/ui-core.c  2019-04-09 07:22:31.414887340 +0200
-@@ -763,7 +763,7 @@
-               G_SPAWN_SEARCH_PATH|G_SPAWN_SEARCH_PATH_FROM_ENVP,
-               NULL, NULL, &thumbnailer_pid, &error);
-           if (error)
--            g_warning (error->message);
-+            g_warning ("%s", error->message);
-         }
-         g_usleep (1000);
-       }
index bf7a667b2686b0b1a410f37d85d051524a635794..ea1e98dfa8cb5df0133c5c9c36fbf27e301c1efb 100644 (file)
--- a/gegl.spec
+++ b/gegl.spec
 Summary:       Generic image processing library
 Summary(pl.UTF-8):     Ogólna biblioteka przetwarzania obrazu
 Name:          gegl
-Version:       0.4.14
-Release:       3
+Version:       0.4.16
+Release:       1
 License:       LGPL v3+
 Group:         Libraries
 Source0:       https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.bz2
-# Source0-md5: 88004f3a204e2506cd0cc445eba8d63e
+# Source0-md5: cb17ac529a882f25f54c0115c63d4027
 Patch1:                %{name}-ruby1.9.patch
 Patch2:                %{name}-build.patch
 Patch3:                umfpack.patch
-Patch4:                %{name}-Wformat-security.patch
 Patch5:                %{name}-without-lua.patch
 URL:           http://www.gegl.org/
 BuildRequires: OpenEXR-devel >= 1.6.1
@@ -53,28 +52,28 @@ BuildRequires:      babl-devel >= %{babl_version}
 BuildRequires: cairo-devel >= 1.12.2
 BuildRequires: enscript
 BuildRequires: exiv2-devel >= 0.25
-# libavformat >= 55.48.100, libavcodec >= 55.69.100, libswscale >= 2.6.100
+# libavformat >= 55.48.100, libavcodec >= 55.69.100, libavutil >= 52.92.100, libswscale >= 2.6.100
 BuildRequires: ffmpeg-devel >= 2.3
 BuildRequires: gdk-pixbuf2-devel >= 2.32.0
-BuildRequires: gettext-tools
+BuildRequires: gettext-tools >= 0.19.8
 BuildRequires: gexiv2-devel
 BuildRequires: glib2-devel >= 1:2.44.0
 %{?with_introspection:BuildRequires:   gobject-introspection-devel >= 1.32.0}
 BuildRequires: graphviz
 BuildRequires: gtk-doc >= 1.0
-BuildRequires: intltool >= 0.40.1
 BuildRequires: jasper-devel >= 1.900.1
 BuildRequires: json-glib-devel
 BuildRequires: lcms2-devel >= 2.8
 BuildRequires: lensfun-devel >= 0.2.5
 BuildRequires: libjpeg-devel
-BuildRequires: libpng-devel
+BuildRequires: libpng-devel >= 2:1.6.0
 BuildRequires: libraw-devel >= 0.15.4
 BuildRequires: librsvg-devel >= 1:2.40.6
 BuildRequires: libspiro-devel
 BuildRequires: libtiff-devel >= 4.0.0
 BuildRequires: libtool >= 2:2.2
-BuildRequires: libv4l-devel >= 1.0.1
+# as of 0.4.16, internal copy of code is used
+#BuildRequires:        libv4l-devel >= 1.0.1
 BuildRequires: libwebp-devel >= 0.5.0
 %if %{with lua}
 BuildRequires: luajit-devel >= 2.0.4
@@ -82,7 +81,7 @@ BuildRequires:        lua51-devel >= 5.1.5-2
 %endif
 BuildRequires: mrg-devel >= %{mrg_version}
 BuildRequires: pango-devel >= 1:1.38.0
-BuildRequires: perl-base
+BuildRequires: perl-base >= 5
 BuildRequires: pkgconfig
 BuildRequires: poppler-glib-devel >= 0.71.0
 BuildRequires: python >= 1:2.5.0
@@ -92,16 +91,22 @@ BuildRequires:      python-pygobject3-devel >= 3.2
 BuildRequires: poly2tri-c-devel
 BuildRequires: ruby >= 1.9
 %{?with_vala:BuildRequires:    vala >= 2:0.20.0}
+BuildRequires: zlib-devel >= 1.2.0
 Requires:      babl >= %{babl_version}
+Requires:      cairo >= 1.12.2
 Requires:      gdk-pixbuf2 >= 2.32.0
 Requires:      glib2 >= 1:2.44.0
 Requires:      jasper-libs >= 1.900.1
+Requires:      lcms2 >= 2.8
 Requires:      lensfun >= 0.2.5
 Requires:      libraw >= 0.15.4
 Requires:      librsvg >= 1:2.40.6
 Requires:      libtiff >= 4.0.0
+Requires:      libwebp >= 0.5.0
 Requires:      mrg-libs >= %{mrg_version}
 Requires:      pango >= 1:1.38.0
+Requires:      poppler-glib >= 0.71.0
+Requires:      zlib >= 1.2.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -128,6 +133,8 @@ Group:              Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      babl-devel >= %{babl_version}
 Requires:      glib2-devel >= 1:2.44.0
+Requires:      json-glib-devel
+Requires:      poly2tri-c-devel
 
 %description devel
 Header files for gegl library.
@@ -182,7 +189,6 @@ API języka Vala dla biblioteki gegl.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
 
 %build
This page took 0.099919 seconds and 4 git commands to generate.