]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- added ruby1.9 patch (ruby 1.9 needs encoding specified)
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx     # use MMX instructions
4 %bcond_with     sse     # use SSE instructions
5 %bcond_without  doc     # apidocs
6 %bcond_without  vala    # Vala API
7 #
8 %ifarch %{x8664} athlon pentium3 pentium4
9 %define with_mmx        1
10 %endif
11 %ifarch %{x8664} pentium3 pentium4
12 %define with_sse        1
13 %endif
14 Summary:        Generic image processing library
15 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
16 Name:           gegl
17 Version:        0.1.8
18 Release:        1
19 License:        LGPL v3+
20 Group:          Libraries
21 Source0:        ftp://ftp.gimp.org/pub/gegl/0.1/%{name}-%{version}.tar.bz2
22 # Source0-md5:  c8279b86b3d584ee4f503839fc500425
23 Patch0:         %{name}-lua.patch
24 Patch1:         %{name}-ffmpeg.patch
25 Patch2:         %{name}-ruby1.9.patch
26 URL:            http://www.gegl.org/
27 BuildRequires:  OpenEXR-devel
28 BuildRequires:  SDL-devel
29 BuildRequires:  UMFPACK-devel
30 BuildRequires:  asciidoc
31 BuildRequires:  autoconf >= 2.54
32 BuildRequires:  automake >= 1:1.11
33 BuildRequires:  babl-devel >= 0.1.6
34 BuildRequires:  cairo-devel
35 BuildRequires:  enscript
36 BuildRequires:  exiv2-devel
37 BuildRequires:  ffmpeg-devel >= 0.8
38 BuildRequires:  gdk-pixbuf2-devel >= 2.18.0
39 BuildRequires:  glib2-devel >= 1:2.28.0
40 BuildRequires:  gobject-introspection-devel >= 0.10.0
41 BuildRequires:  graphviz
42 BuildRequires:  gtk-doc >= 1.0
43 BuildRequires:  jasper-devel >= 1.900.1
44 BuildRequires:  lensfun-devel >= 0.2.5
45 BuildRequires:  libjpeg-devel
46 BuildRequires:  libopenraw-devel >= 0.0.5
47 BuildRequires:  libpng-devel
48 BuildRequires:  librsvg-devel >= 1:2.14.0
49 BuildRequires:  libspiro-devel
50 BuildRequires:  libtool >= 2:2.2
51 BuildRequires:  libv4l-devel
52 BuildRequires:  lua51-devel >= 5.1.0
53 BuildRequires:  pango-devel >= 1:1.10
54 BuildRequires:  perl-base
55 BuildRequires:  pkgconfig
56 BuildRequires:  ruby >= 1.9
57 %{?with_vala:BuildRequires:     vala}
58 Requires:       babl >= 0.1.6
59 Requires:       glib2 >= 1:2.28.0
60 Requires:       gdk-pixbuf2 >= 2.18.0
61 Requires:       jasper-libs >= 1.900.1
62 Requires:       lensfun >= 0.2.5
63 Requires:       libopenraw >= 0.0.5
64 Requires:       librsvg >= 1:2.14.0
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 GEGL (Generic Graphics Library) is a graph based image processing
69 framework.
70
71 GEGL's original design was made to scratch GIMP's itches for a new
72 compositing and processing core. This core is being designed to have
73 minimal dependencies and a simple well defined API.
74
75 %description -l pl.UTF-8
76 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
77 przetwarzania obrazu.
78
79 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
80 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
81 projektowany tak, by miał minimalne zależności i proste, dobrze
82 zdefiniowane API.
83
84 %package devel
85 Summary:        Header files for gegl library
86 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       babl-devel >= 0.1.6
90 Requires:       glib2-devel >= 1:2.28.0
91
92 %description devel
93 Header files for gegl library.
94
95 %description devel -l pl.UTF-8
96 Pliki nagłówkowe biblioteki gegl.
97
98 %package static
99 Summary:        Static gegl library
100 Summary(pl.UTF-8):      Statyczna biblioteka gegl
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103
104 %description static
105 Static gegl library.
106
107 %description static -l pl.UTF-8
108 Statyczna biblioteka gegl.
109
110 %package apidocs
111 Summary:        gegl library API documentation
112 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
113 Group:          Documentation
114 Requires:       gtk-doc-common
115
116 %description apidocs
117 gegl library API documentation.
118
119 %description apidocs -l pl.UTF-8
120 Dokumentacja API biblioteki gegl.
121
122 %package -n vala-gegl
123 Summary:        Vala API for gegl library
124 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}-%{release}
127
128 %description -n vala-gegl
129 Vala API for gegl library.
130
131 %description -n vala-gegl -l pl.UTF-8
132 API języka Vala dla biblioteki gegl.
133
134 %prep
135 %setup -q
136 %patch0 -p1
137 %patch1 -p1
138 %patch2 -p1
139
140 %build
141 %{__libtoolize}
142 %{__aclocal} -I m4
143 %{__autoconf}
144 %{__autoheader}
145 %{__automake}
146 %configure \
147         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
148         --enable-docs%{!?with_doc:=no} \
149         %{!?with_mmx:--disable-mmx} \
150         %{!?with_sse:--disable-sse} \
151         --disable-silent-rules \
152         --enable-static
153 %{__make}
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157
158 %{__make} install \
159         DESTDIR=$RPM_BUILD_ROOT \
160         gtkdochtmldir=%{_gtkdocdir}/gegl
161
162 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.1/*.{a,la}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %files
171 %defattr(644,root,root,755)
172 %doc AUTHORS ChangeLog NEWS README
173 %attr(755,root,root) %{_bindir}/gegl
174 %attr(755,root,root) %{_libdir}/libgegl-0.1.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.1.so.0
176 %{_libdir}/girepository-1.0/Gegl-0.1.typelib
177 %dir %{_libdir}/gegl-0.1
178 %attr(755,root,root) %{_libdir}/gegl-0.1/*.so
179
180 %files devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libgegl-0.1.so
183 %{_libdir}/libgegl-0.1.la
184 %{_includedir}/gegl-0.1
185 %{_datadir}/gir-1.0/Gegl-0.1.gir
186 %{_pkgconfigdir}/gegl.pc
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/libgegl-0.1.a
191
192 %if %{with doc}
193 %files apidocs
194 %defattr(644,root,root,755)
195 %{_gtkdocdir}/gegl
196 %endif
197
198 %if %{with vala}
199 %files -n vala-gegl
200 %defattr(644,root,root,755)
201 %{_datadir}/vala/vapi/gegl-0.1.vapi
202 %endif
This page took 0.039608 seconds and 4 git commands to generate.