]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- updated to 0.1.8
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx     # use MMX instructions
4 %bcond_with     sse     # use SSE instructions
5 %bcond_with     doc     # apidocs (fail to build)
6 %bcond_without  vala    # Vala API
7 #
8 %ifarch %{x8664} athlon pentium3 pentium4
9 %define with_mmx        1
10 %endif
11 %ifarch %{x8664} pentium3 pentium4
12 %define with_sse        1
13 %endif
14 Summary:        Generic image processing library
15 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
16 Name:           gegl
17 Version:        0.1.8
18 Release:        1
19 License:        LGPL v3+
20 Group:          Libraries
21 Source0:        ftp://ftp.gimp.org/pub/gegl/0.1/%{name}-%{version}.tar.bz2
22 # Source0-md5:  c8279b86b3d584ee4f503839fc500425
23 Patch0:         %{name}-lua.patch
24 Patch1:         %{name}-ffmpeg.patch
25 URL:            http://www.gegl.org/
26 BuildRequires:  OpenEXR-devel
27 BuildRequires:  SDL-devel
28 BuildRequires:  UMFPACK-devel
29 BuildRequires:  asciidoc
30 BuildRequires:  autoconf >= 2.54
31 BuildRequires:  automake >= 1:1.11
32 BuildRequires:  babl-devel >= 0.1.6
33 BuildRequires:  cairo-devel
34 BuildRequires:  enscript
35 BuildRequires:  exiv2-devel
36 BuildRequires:  ffmpeg-devel >= 0.8
37 BuildRequires:  gdk-pixbuf2-devel >= 2.18.0
38 BuildRequires:  glib2-devel >= 1:2.28.0
39 BuildRequires:  gobject-introspection-devel >= 0.10.0
40 BuildRequires:  graphviz
41 BuildRequires:  gtk-doc >= 1.0
42 BuildRequires:  jasper-devel >= 1.900.1
43 BuildRequires:  lensfun-devel >= 0.2.5
44 BuildRequires:  libjpeg-devel
45 BuildRequires:  libopenraw-devel >= 0.0.5
46 BuildRequires:  libpng-devel
47 BuildRequires:  librsvg-devel >= 1:2.14.0
48 BuildRequires:  libspiro-devel
49 BuildRequires:  libtool >= 2:2.2
50 BuildRequires:  libv4l-devel
51 BuildRequires:  lua51-devel >= 5.1.0
52 BuildRequires:  pango-devel >= 1:1.10
53 BuildRequires:  perl-base
54 BuildRequires:  pkgconfig
55 BuildRequires:  ruby
56 %{?with_vala:BuildRequires:     vala}
57 Requires:       babl >= 0.1.6
58 Requires:       glib2 >= 1:2.28.0
59 Requires:       gdk-pixbuf2 >= 2.18.0
60 Requires:       jasper-libs >= 1.900.1
61 Requires:       lensfun >= 0.2.5
62 Requires:       libopenraw >= 0.0.5
63 Requires:       librsvg >= 1:2.14.0
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 GEGL (Generic Graphics Library) is a graph based image processing
68 framework.
69
70 GEGL's original design was made to scratch GIMP's itches for a new
71 compositing and processing core. This core is being designed to have
72 minimal dependencies and a simple well defined API.
73
74 %description -l pl.UTF-8
75 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
76 przetwarzania obrazu.
77
78 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
79 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
80 projektowany tak, by miał minimalne zależności i proste, dobrze
81 zdefiniowane API.
82
83 %package devel
84 Summary:        Header files for gegl library
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       babl-devel >= 0.1.6
89 Requires:       glib2-devel >= 1:2.28.0
90
91 %description devel
92 Header files for gegl library.
93
94 %description devel -l pl.UTF-8
95 Pliki nagłówkowe biblioteki gegl.
96
97 %package static
98 Summary:        Static gegl library
99 Summary(pl.UTF-8):      Statyczna biblioteka gegl
100 Group:          Development/Libraries
101 Requires:       %{name}-devel = %{version}-%{release}
102
103 %description static
104 Static gegl library.
105
106 %description static -l pl.UTF-8
107 Statyczna biblioteka gegl.
108
109 %package apidocs
110 Summary:        gegl library API documentation
111 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
112 Group:          Documentation
113 Requires:       gtk-doc-common
114
115 %description apidocs
116 gegl library API documentation.
117
118 %description apidocs -l pl.UTF-8
119 Dokumentacja API biblioteki gegl.
120
121 %package -n vala-gegl
122 Summary:        Vala API for gegl library
123 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
124 Group:          Development/Libraries
125 Requires:       %{name}-devel = %{version}-%{release}
126
127 %description -n vala-gegl
128 Vala API for gegl library.
129
130 %description -n vala-gegl -l pl.UTF-8
131 API języka Vala dla biblioteki gegl.
132
133 %prep
134 %setup -q
135 %patch0 -p1
136 %patch1 -p1
137
138 %build
139 %{__libtoolize}
140 %{__aclocal} -I m4
141 %{__autoconf}
142 %{__autoheader}
143 %{__automake}
144 %configure \
145         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
146         --enable-docs%{!?with_doc:=no} \
147         %{!?with_mmx:--disable-mmx} \
148         %{!?with_sse:--disable-sse} \
149         --disable-silent-rules \
150         --enable-static
151 %{__make}
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT \
158         help_dir=$RPM_BUILD_ROOT%{_gtkdocdir}/gegl
159
160 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.1/*.{a,la}
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   -p /sbin/ldconfig
166 %postun -p /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog NEWS README
171 %attr(755,root,root) %{_bindir}/gegl
172 %attr(755,root,root) %{_libdir}/libgegl-0.1.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.1.so.0
174 %{_libdir}/girepository-1.0/Gegl-0.1.typelib
175 %dir %{_libdir}/gegl-0.1
176 %attr(755,root,root) %{_libdir}/gegl-0.1/*.so
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libgegl-0.1.so
181 %{_libdir}/libgegl-0.1.la
182 %{_includedir}/gegl-0.1
183 %{_datadir}/gir-1.0/Gegl-0.1.gir
184 %{_pkgconfigdir}/gegl.pc
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libgegl-0.1.a
189
190 %if %{with doc}
191 %files apidocs
192 %defattr(644,root,root,755)
193 %{_gtkdocdir}/gegl
194 %endif
195
196 %if %{with vala}
197 %files -n vala-gegl
198 %defattr(644,root,root,755)
199 %{_datadir}/vala/vapi/gegl-0.1.vapi
200 %endif
This page took 0.038266 seconds and 4 git commands to generate.