]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- fix doc bcond
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx     # use MMX instructions
4 %bcond_with     sse     # use SSE instructions
5 %bcond_with     doc
6
7 %ifarch %{x8664} athlon pentium3 pentium4
8 %define with_mmx        1
9 %endif
10 %ifarch %{x8664} pentium3 pentium4
11 %define with_sse        1
12 %endif
13 Summary:        Generic image processing library
14 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
15 Name:           gegl
16 Version:        0.1.2
17 Release:        2
18 License:        LGPL v3+
19 Group:          Libraries
20 Source0:        ftp://ftp.gtk.org/pub/gegl/0.1/%{name}-%{version}.tar.bz2
21 # Source0-md5:  d35ffe17dc042652eca3205488ece262
22 Patch0:         %{name}-lua.patch
23 Patch1:         %{name}-ffmpeg.patch
24 Patch2:         %{name}-ffmpeg-0.8.patch
25 URL:            http://www.gegl.org/
26 BuildRequires:  OpenEXR-devel
27 BuildRequires:  SDL-devel
28 BuildRequires:  asciidoc
29 BuildRequires:  autoconf >= 2.54
30 BuildRequires:  automake
31 BuildRequires:  babl-devel >= 0.1.2
32 BuildRequires:  cairo-devel
33 BuildRequires:  enscript
34 BuildRequires:  ffmpeg-devel >= 0.8
35 BuildRequires:  gdk-pixbuf2-devel >= 2.12.0
36 BuildRequires:  glib2-devel >= 1:2.22.0
37 BuildRequires:  graphviz
38 BuildRequires:  gtk-doc >= 1.0
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libopenraw-devel >= 0.0.5
41 BuildRequires:  libpng-devel
42 BuildRequires:  librsvg-devel >= 1:2.14.0
43 BuildRequires:  libspiro-devel
44 BuildRequires:  libtool
45 BuildRequires:  lua51-devel >= 5.1.0
46 BuildRequires:  pango-devel >= 1:1.10
47 BuildRequires:  perl-base
48 BuildRequires:  pkgconfig
49 BuildRequires:  ruby
50 Requires:       babl >= 0.1.2
51 Requires:       glib2 >= 1:2.22.0
52 Requires:       libopenraw >= 0.0.5
53 Requires:       librsvg >= 1:2.14.0
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 GEGL (Generic Graphics Library) is a graph based image processing
58 framework.
59
60 GEGL's original design was made to scratch GIMP's itches for a new
61 compositing and processing core. This core is being designed to have
62 minimal dependencies and a simple well defined API.
63
64 %description -l pl.UTF-8
65 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
66 przetwarzania obrazu.
67
68 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
69 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
70 projektowany tak, by miał minimalne zależności i proste, dobrze
71 zdefiniowane API.
72
73 %package devel
74 Summary:        Header files for gegl library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       babl-devel >= 0.0.20
79 Requires:       glib2-devel >= 1:2.22.0
80
81 %description devel
82 Header files for gegl library.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki gegl.
86
87 %package static
88 Summary:        Static gegl library
89 Summary(pl.UTF-8):      Statyczna biblioteka gegl
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static gegl library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka gegl.
98
99 %package apidocs
100 Summary:        gegl library API documentation
101 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
102 Group:          Documentation
103 Requires:       gtk-doc-common
104
105 %description apidocs
106 gegl library API documentation.
107
108 %description apidocs -l pl.UTF-8
109 Dokumentacja API biblioteki gegl.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %build
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         --enable-docs%{!?with_doc:=no} \
125         %{!?with_mmx:--disable-mmx} \
126         %{!?with_sse:--disable-sse} \
127         --disable-silent-rules \
128         --enable-static
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT \
136         help_dir=$RPM_BUILD_ROOT%{_gtkdocdir}/gegl
137
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.1/*.{a,la}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog NEWS README
149 %attr(755,root,root) %{_bindir}/gegl
150 %attr(755,root,root) %{_libdir}/libgegl-0.1.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.1.so.0
152 %dir %{_libdir}/gegl-0.1
153 %attr(755,root,root) %{_libdir}/gegl-0.1/*.so
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libgegl-0.1.so
158 %{_libdir}/libgegl-0.1.la
159 %{_includedir}/gegl-0.1
160 %{_pkgconfigdir}/gegl.pc
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libgegl-0.1.a
165
166 %if %{with doc}
167 %files apidocs
168 %defattr(644,root,root,755)
169 %{_gtkdocdir}/gegl
170 %endif
This page took 0.070146 seconds and 4 git commands to generate.