]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- fixed file list for gegl 0.2.0
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx     # use MMX instructions
4 %bcond_with     sse     # use SSE instructions
5 %bcond_without  doc     # apidocs
6 # reenable when new babl will arrive that actually is able to build
7 %bcond_with     vala    # Vala API
8 #
9 %ifarch %{x8664} athlon pentium3 pentium4
10 %define with_mmx        1
11 %endif
12 %ifarch %{x8664} pentium3 pentium4
13 %define with_sse        1
14 %endif
15 Summary:        Generic image processing library
16 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
17 Name:           gegl
18 Version:        0.2.0
19 Release:        0.1
20 License:        LGPL v3+
21 Group:          Libraries
22 Source0:        ftp://ftp.gimp.org/pub/gegl/0.2/%{name}-%{version}.tar.bz2
23 # Source0-md5:  32b00002f1f1e316115c4ed922e1dec8
24 Patch0:         %{name}-lua.patch
25 Patch1:         %{name}-ffmpeg.patch
26 Patch2:         %{name}-ruby1.9.patch
27 Patch3:         %{name}-build.patch
28 URL:            http://www.gegl.org/
29 BuildRequires:  OpenEXR-devel
30 BuildRequires:  SDL-devel
31 BuildRequires:  UMFPACK-devel
32 BuildRequires:  asciidoc
33 BuildRequires:  autoconf >= 2.54
34 BuildRequires:  automake >= 1:1.11
35 BuildRequires:  babl-devel >= 0.1.10
36 BuildRequires:  cairo-devel
37 BuildRequires:  enscript
38 BuildRequires:  exiv2-devel
39 BuildRequires:  ffmpeg-devel >= 0.8
40 BuildRequires:  gdk-pixbuf2-devel >= 2.18.0
41 BuildRequires:  glib2-devel >= 1:2.28.0
42 BuildRequires:  gobject-introspection-devel >= 0.10.0
43 BuildRequires:  graphviz
44 BuildRequires:  gtk-doc >= 1.0
45 BuildRequires:  jasper-devel >= 1.900.1
46 BuildRequires:  lensfun-devel >= 0.2.5
47 BuildRequires:  libjpeg-devel
48 BuildRequires:  libopenraw-devel >= 0.0.5
49 BuildRequires:  libpng-devel
50 BuildRequires:  librsvg-devel >= 1:2.14.0
51 BuildRequires:  libspiro-devel
52 BuildRequires:  libtool >= 2:2.2
53 BuildRequires:  libv4l-devel
54 BuildRequires:  lua51-devel >= 5.1.0
55 BuildRequires:  pango-devel >= 1:1.10
56 BuildRequires:  perl-base
57 BuildRequires:  pkgconfig
58 BuildRequires:  ruby >= 1.9
59 %{?with_vala:BuildRequires:     vala}
60 Requires:       babl >= 0.1.10
61 Requires:       glib2 >= 1:2.28.0
62 Requires:       gdk-pixbuf2 >= 2.18.0
63 Requires:       jasper-libs >= 1.900.1
64 Requires:       lensfun >= 0.2.5
65 Requires:       libopenraw >= 0.0.5
66 Requires:       librsvg >= 1:2.14.0
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 GEGL (Generic Graphics Library) is a graph based image processing
71 framework.
72
73 GEGL's original design was made to scratch GIMP's itches for a new
74 compositing and processing core. This core is being designed to have
75 minimal dependencies and a simple well defined API.
76
77 %description -l pl.UTF-8
78 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
79 przetwarzania obrazu.
80
81 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
82 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
83 projektowany tak, by miał minimalne zależności i proste, dobrze
84 zdefiniowane API.
85
86 %package devel
87 Summary:        Header files for gegl library
88 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
89 Group:          Development/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       babl-devel >= 0.1.10
92 Requires:       glib2-devel >= 1:2.28.0
93
94 %description devel
95 Header files for gegl library.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe biblioteki gegl.
99
100 %package static
101 Summary:        Static gegl library
102 Summary(pl.UTF-8):      Statyczna biblioteka gegl
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static gegl library.
108
109 %description static -l pl.UTF-8
110 Statyczna biblioteka gegl.
111
112 %package apidocs
113 Summary:        gegl library API documentation
114 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
115 Group:          Documentation
116 Requires:       gtk-doc-common
117
118 %description apidocs
119 gegl library API documentation.
120
121 %description apidocs -l pl.UTF-8
122 Dokumentacja API biblioteki gegl.
123
124 %package -n vala-gegl
125 Summary:        Vala API for gegl library
126 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
127 Group:          Development/Libraries
128 Requires:       %{name}-devel = %{version}-%{release}
129
130 %description -n vala-gegl
131 Vala API for gegl library.
132
133 %description -n vala-gegl -l pl.UTF-8
134 API języka Vala dla biblioteki gegl.
135
136 %prep
137 %setup -q
138 %patch0 -p1
139 %patch1 -p1
140 %patch2 -p1
141 %patch3 -p1
142
143 %build
144 %{__libtoolize}
145 %{__aclocal} -I m4
146 %{__autoconf}
147 %{__autoheader}
148 %{__automake}
149 %configure \
150         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
151         --enable-docs%{!?with_doc:=no} \
152         %{!?with_mmx:--disable-mmx} \
153         %{!?with_sse:--disable-sse} \
154         --with%{!?with_vala:out}-vala \
155         --disable-silent-rules \
156         --enable-static
157 %{__make}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT \
164         gtkdochtmldir=%{_gtkdocdir}/gegl
165
166 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.2/*.{a,la}
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc AUTHORS ChangeLog NEWS README
177 %attr(755,root,root) %{_bindir}/gegl
178 %attr(755,root,root) %{_libdir}/libgegl-0.2.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.2.so.0
180 %{_libdir}/girepository-1.0/Gegl-0.2.typelib
181 %dir %{_libdir}/gegl-0.2
182 %attr(755,root,root) %{_libdir}/gegl-0.2/*.so
183
184 %files devel
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libgegl-0.2.so
187 %{_libdir}/libgegl-0.2.la
188 %{_includedir}/gegl-0.2
189 %{_datadir}/gir-1.0/Gegl-0.2.gir
190 %{_pkgconfigdir}/gegl.pc
191
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/libgegl-0.2.a
195
196 %if %{with doc}
197 %files apidocs
198 %defattr(644,root,root,755)
199 %{_gtkdocdir}/gegl
200 %endif
201
202 %if %{with vala}
203 %files -n vala-gegl
204 %defattr(644,root,root,755)
205 %{_datadir}/vala/vapi/gegl-0.2.vapi
206 %endif
This page took 0.041516 seconds and 4 git commands to generate.