]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- release 10 (by relup.sh)
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse             # use SSE instructions
5 %bcond_without  doc             # apidocs
6 # reenable when new babl will arrive that actually is able to build
7 %bcond_with     introspection   # API introspection
8 # reenable when new babl will arrive that actually is able to build
9 %bcond_with     vala            # Vala API
10
11 %ifarch %{x8664} athlon pentium3 pentium4
12 %define with_mmx        1
13 %endif
14 %ifarch %{x8664} pentium3 pentium4
15 %define with_sse        1
16 %endif
17 %if %{without introspection}
18 %undefine       with_vala
19 %endif
20 Summary:        Generic image processing library
21 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
22 Name:           gegl
23 Version:        0.2.0
24 Release:        10
25 License:        LGPL v3+
26 Group:          Libraries
27 Source0:        http://ftp.gimp.org/pub/gegl/0.2/%{name}-%{version}.tar.bz2
28 # Source0-md5:  32b00002f1f1e316115c4ed922e1dec8
29 Patch0:         %{name}-lua.patch
30 Patch1:         %{name}-ffmpeg.patch
31 Patch2:         %{name}-ruby1.9.patch
32 Patch3:         %{name}-build.patch
33 Patch4:         %{name}-introspection.patch
34 Patch5:         umfpack.patch
35 Patch6:         CVE-2012-4433.patch
36 URL:            http://www.gegl.org/
37 %{?with_introspection:BuildRequires:    /usr/share/gir-1.0/Babl-0.1.gir}
38 BuildRequires:  OpenEXR-devel
39 BuildRequires:  SDL-devel
40 BuildRequires:  UMFPACK-devel
41 BuildRequires:  asciidoc
42 BuildRequires:  autoconf >= 2.54
43 BuildRequires:  automake >= 1:1.11
44 BuildRequires:  babl-devel >= 0.1.10
45 BuildRequires:  cairo-devel
46 BuildRequires:  enscript
47 BuildRequires:  exiv2-devel
48 BuildRequires:  ffmpeg-devel >= 0.8
49 BuildRequires:  gdk-pixbuf2-devel >= 2.18.0
50 BuildRequires:  glib2-devel >= 1:2.28.0
51 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
52 BuildRequires:  graphviz
53 BuildRequires:  gtk-doc >= 1.0
54 BuildRequires:  intltool >= 0.40.1
55 BuildRequires:  jasper-devel >= 1.900.1
56 BuildRequires:  lensfun-devel >= 0.2.5
57 BuildRequires:  libjpeg-devel
58 BuildRequires:  libopenraw-devel >= 0.0.5
59 BuildRequires:  libpng-devel
60 BuildRequires:  librsvg-devel >= 1:2.14.0
61 BuildRequires:  libspiro-devel
62 BuildRequires:  libtool >= 2:2.2
63 BuildRequires:  libv4l-devel
64 BuildRequires:  lua51-devel >= 5.1.0
65 BuildRequires:  pango-devel >= 1:1.10
66 BuildRequires:  perl-base
67 BuildRequires:  pkgconfig
68 BuildRequires:  ruby >= 1.9
69 %{?with_vala:BuildRequires:     vala}
70 Requires:       babl >= 0.1.10
71 Requires:       gdk-pixbuf2 >= 2.18.0
72 Requires:       glib2 >= 1:2.28.0
73 Requires:       jasper-libs >= 1.900.1
74 Requires:       lensfun >= 0.2.5
75 Requires:       libopenraw >= 0.0.5
76 Requires:       librsvg >= 1:2.14.0
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 GEGL (Generic Graphics Library) is a graph based image processing
81 framework.
82
83 GEGL's original design was made to scratch GIMP's itches for a new
84 compositing and processing core. This core is being designed to have
85 minimal dependencies and a simple well defined API.
86
87 %description -l pl.UTF-8
88 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
89 przetwarzania obrazu.
90
91 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
92 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
93 projektowany tak, by miał minimalne zależności i proste, dobrze
94 zdefiniowane API.
95
96 %package devel
97 Summary:        Header files for gegl library
98 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       babl-devel >= 0.1.10
102 Requires:       glib2-devel >= 1:2.28.0
103
104 %description devel
105 Header files for gegl library.
106
107 %description devel -l pl.UTF-8
108 Pliki nagłówkowe biblioteki gegl.
109
110 %package static
111 Summary:        Static gegl library
112 Summary(pl.UTF-8):      Statyczna biblioteka gegl
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description static
117 Static gegl library.
118
119 %description static -l pl.UTF-8
120 Statyczna biblioteka gegl.
121
122 %package apidocs
123 Summary:        gegl library API documentation
124 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
125 Group:          Documentation
126 Requires:       gtk-doc-common
127 %if "%{_rpmversion}" >= "5"
128 BuildArch:      noarch
129 %endif
130
131 %description apidocs
132 gegl library API documentation.
133
134 %description apidocs -l pl.UTF-8
135 Dokumentacja API biblioteki gegl.
136
137 %package -n vala-gegl
138 Summary:        Vala API for gegl library
139 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
140 Group:          Development/Libraries
141 Requires:       %{name}-devel = %{version}-%{release}
142
143 %description -n vala-gegl
144 Vala API for gegl library.
145
146 %description -n vala-gegl -l pl.UTF-8
147 API języka Vala dla biblioteki gegl.
148
149 %prep
150 %setup -q
151 %patch0 -p1
152 %patch1 -p0
153 %patch2 -p1
154 %patch3 -p1
155 %patch4 -p1
156 %patch5 -p1
157 %patch6 -p1
158
159 %build
160 %{__libtoolize}
161 %{__aclocal} -I m4
162 %{__autoconf}
163 %{__autoheader}
164 %{__automake}
165 %configure \
166         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
167         --enable-docs%{!?with_doc:=no} \
168         %{?with_introspection:--enable-introspection} \
169         %{!?with_mmx:--disable-mmx} \
170         %{!?with_sse:--disable-sse} \
171         --disable-silent-rules \
172         --enable-static \
173         --with%{!?with_vala:out}-vala
174 %{__make}
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT \
181         gtkdochtmldir=%{_gtkdocdir}/gegl
182
183 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.2/*.{a,la}
184
185 %find_lang %{name}-0.2
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %post   -p /sbin/ldconfig
191 %postun -p /sbin/ldconfig
192
193 %files -f %{name}-0.2.lang
194 %defattr(644,root,root,755)
195 %doc AUTHORS ChangeLog NEWS README
196 %attr(755,root,root) %{_bindir}/gegl
197 %attr(755,root,root) %{_libdir}/libgegl-0.2.so.*.*.*
198 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.2.so.0
199 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.2.typelib}
200 %dir %{_libdir}/gegl-0.2
201 %attr(755,root,root) %{_libdir}/gegl-0.2/*.so
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libgegl-0.2.so
206 %{_libdir}/libgegl-0.2.la
207 %{_includedir}/gegl-0.2
208 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.2.gir}
209 %{_pkgconfigdir}/gegl-0.2.pc
210
211 %files static
212 %defattr(644,root,root,755)
213 %{_libdir}/libgegl-0.2.a
214
215 %if %{with doc}
216 %files apidocs
217 %defattr(644,root,root,755)
218 %{_gtkdocdir}/gegl
219 %endif
220
221 %if %{with vala}
222 %files -n vala-gegl
223 %defattr(644,root,root,755)
224 %{_datadir}/vala/vapi/gegl-0.2.vapi
225 %endif
This page took 0.084501 seconds and 4 git commands to generate.