]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- release 12 (by relup.sh)
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse             # use SSE instructions
5 %bcond_without  doc             # apidocs
6 %bcond_without  static_libs     # static library
7 # reenable when new babl will arrive that actually is able to build
8 %bcond_with     introspection   # API introspection
9 # reenable when new babl will arrive that actually is able to build
10 %bcond_with     vala            # Vala API
11
12 %ifarch %{x8664} athlon pentium3 pentium4
13 %define with_mmx        1
14 %endif
15 %ifarch %{x8664} pentium3 pentium4
16 %define with_sse        1
17 %endif
18 %if %{without introspection}
19 %undefine       with_vala
20 %endif
21 Summary:        Generic image processing library
22 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
23 Name:           gegl
24 Version:        0.2.0
25 Release:        12
26 License:        LGPL v3+
27 Group:          Libraries
28 Source0:        http://ftp.gimp.org/pub/gegl/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  32b00002f1f1e316115c4ed922e1dec8
30 Patch0:         %{name}-lua.patch
31 Patch1:         %{name}-ffmpeg.patch
32 Patch2:         %{name}-ruby1.9.patch
33 Patch3:         %{name}-build.patch
34 Patch4:         %{name}-introspection.patch
35 Patch5:         umfpack.patch
36 Patch6:         CVE-2012-4433.patch
37 URL:            http://www.gegl.org/
38 %{?with_introspection:BuildRequires:    /usr/share/gir-1.0/Babl-0.1.gir}
39 BuildRequires:  OpenEXR-devel
40 BuildRequires:  SDL-devel
41 BuildRequires:  UMFPACK-devel
42 BuildRequires:  asciidoc
43 BuildRequires:  autoconf >= 2.54
44 BuildRequires:  automake >= 1:1.11
45 BuildRequires:  babl-devel >= 0.1.10
46 BuildRequires:  cairo-devel
47 BuildRequires:  enscript
48 BuildRequires:  exiv2-devel
49 BuildRequires:  ffmpeg-devel >= 0.8
50 BuildRequires:  gdk-pixbuf2-devel >= 2.18.0
51 BuildRequires:  glib2-devel >= 1:2.28.0
52 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
53 BuildRequires:  graphviz
54 BuildRequires:  gtk-doc >= 1.0
55 BuildRequires:  intltool >= 0.40.1
56 BuildRequires:  jasper-devel >= 1.900.1
57 BuildRequires:  lensfun-devel >= 0.2.5
58 BuildRequires:  libjpeg-devel
59 BuildRequires:  libopenraw-devel >= 0.0.5
60 BuildRequires:  libpng-devel
61 BuildRequires:  librsvg-devel >= 1:2.14.0
62 BuildRequires:  libspiro-devel
63 BuildRequires:  libtool >= 2:2.2
64 BuildRequires:  libv4l-devel
65 BuildRequires:  lua51-devel >= 5.1.0
66 BuildRequires:  pango-devel >= 1:1.10
67 BuildRequires:  perl-base
68 BuildRequires:  pkgconfig
69 BuildRequires:  ruby >= 1.9
70 %{?with_vala:BuildRequires:     vala}
71 Requires:       babl >= 0.1.10
72 Requires:       gdk-pixbuf2 >= 2.18.0
73 Requires:       glib2 >= 1:2.28.0
74 Requires:       jasper-libs >= 1.900.1
75 Requires:       lensfun >= 0.2.5
76 Requires:       libopenraw >= 0.0.5
77 Requires:       librsvg >= 1:2.14.0
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 GEGL (Generic Graphics Library) is a graph based image processing
82 framework.
83
84 GEGL's original design was made to scratch GIMP's itches for a new
85 compositing and processing core. This core is being designed to have
86 minimal dependencies and a simple well defined API.
87
88 %description -l pl.UTF-8
89 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
90 przetwarzania obrazu.
91
92 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
93 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
94 projektowany tak, by miał minimalne zależności i proste, dobrze
95 zdefiniowane API.
96
97 %package devel
98 Summary:        Header files for gegl library
99 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
100 Group:          Development/Libraries
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       babl-devel >= 0.1.10
103 Requires:       glib2-devel >= 1:2.28.0
104
105 %description devel
106 Header files for gegl library.
107
108 %description devel -l pl.UTF-8
109 Pliki nagłówkowe biblioteki gegl.
110
111 %package static
112 Summary:        Static gegl library
113 Summary(pl.UTF-8):      Statyczna biblioteka gegl
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116
117 %description static
118 Static gegl library.
119
120 %description static -l pl.UTF-8
121 Statyczna biblioteka gegl.
122
123 %package apidocs
124 Summary:        gegl library API documentation
125 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
126 Group:          Documentation
127 Requires:       gtk-doc-common
128 %if "%{_rpmversion}" >= "5"
129 BuildArch:      noarch
130 %endif
131
132 %description apidocs
133 gegl library API documentation.
134
135 %description apidocs -l pl.UTF-8
136 Dokumentacja API biblioteki gegl.
137
138 %package -n vala-gegl
139 Summary:        Vala API for gegl library
140 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description -n vala-gegl
145 Vala API for gegl library.
146
147 %description -n vala-gegl -l pl.UTF-8
148 API języka Vala dla biblioteki gegl.
149
150 %prep
151 %setup -q
152 %patch0 -p1
153 %patch1 -p0
154 %patch2 -p1
155 %patch3 -p1
156 %patch4 -p1
157 %patch5 -p1
158 %patch6 -p1
159
160 %build
161 %{__libtoolize}
162 %{__aclocal} -I m4
163 %{__autoconf}
164 %{__autoheader}
165 %{__automake}
166 %configure \
167         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
168         --enable-docs%{!?with_doc:=no} \
169         %{?with_introspection:--enable-introspection} \
170         %{!?with_mmx:--disable-mmx} \
171         %{!?with_sse:--disable-sse} \
172         --disable-silent-rules \
173         %{?with_static_libs:--enable-static} \
174         --with-vala%{!?with_vala:=no}
175 %{__make}
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT \
182         gtkdochtmldir=%{_gtkdocdir}/gegl
183
184 # obsoleted by pkg-config
185 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgegl-0.2.la
186 # dlopened modules
187 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.2/*.la
188 %if %{with static_libs}
189 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.2/*.a
190 %endif
191
192 %find_lang %{name}-0.2
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %post   -p /sbin/ldconfig
198 %postun -p /sbin/ldconfig
199
200 %files -f %{name}-0.2.lang
201 %defattr(644,root,root,755)
202 %doc AUTHORS ChangeLog NEWS README
203 %attr(755,root,root) %{_bindir}/gegl
204 %attr(755,root,root) %{_libdir}/libgegl-0.2.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.2.so.0
206 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.2.typelib}
207 %dir %{_libdir}/gegl-0.2
208 %attr(755,root,root) %{_libdir}/gegl-0.2/*.so
209
210 %files devel
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/libgegl-0.2.so
213 %{_includedir}/gegl-0.2
214 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.2.gir}
215 %{_pkgconfigdir}/gegl-0.2.pc
216
217 %if %{with static_libs}
218 %files static
219 %defattr(644,root,root,755)
220 %{_libdir}/libgegl-0.2.a
221 %endif
222
223 %if %{with doc}
224 %files apidocs
225 %defattr(644,root,root,755)
226 %{_gtkdocdir}/gegl
227 %endif
228
229 %if %{with vala}
230 %files -n vala-gegl
231 %defattr(644,root,root,755)
232 %{_datadir}/vala/vapi/gegl-0.2.vapi
233 %endif
This page took 0.069097 seconds and 4 git commands to generate.