]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- release 5 (by relup.sh)
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse             # use SSE instructions
5 %bcond_without  doc             # apidocs
6 # reenable when new babl will arrive that actually is able to build
7 %bcond_with     introspection   # API introspection
8 # reenable when new babl will arrive that actually is able to build
9 %bcond_with     vala            # Vala API
10 #
11 %ifarch %{x8664} athlon pentium3 pentium4
12 %define with_mmx        1
13 %endif
14 %ifarch %{x8664} pentium3 pentium4
15 %define with_sse        1
16 %endif
17 %if %{without introspection}
18 %undefine       with_vala
19 %endif
20 Summary:        Generic image processing library
21 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
22 Name:           gegl
23 Version:        0.2.0
24 Release:        5
25 License:        LGPL v3+
26 Group:          Libraries
27 Source0:        ftp://ftp.gimp.org/pub/gegl/0.2/%{name}-%{version}.tar.bz2
28 # Source0-md5:  32b00002f1f1e316115c4ed922e1dec8
29 Patch0:         %{name}-lua.patch
30 Patch1:         %{name}-ffmpeg.patch
31 Patch2:         %{name}-ruby1.9.patch
32 Patch3:         %{name}-build.patch
33 Patch4:         %{name}-introspection.patch
34 URL:            http://www.gegl.org/
35 BuildRequires:  OpenEXR-devel
36 BuildRequires:  SDL-devel
37 BuildRequires:  UMFPACK-devel
38 BuildRequires:  asciidoc
39 BuildRequires:  autoconf >= 2.54
40 BuildRequires:  automake >= 1:1.11
41 BuildRequires:  babl-devel >= 0.1.10
42 %{?with_introspection:BuildRequires:    /usr/share/gir-1.0/Babl-0.1.gir}
43 BuildRequires:  cairo-devel
44 BuildRequires:  enscript
45 BuildRequires:  exiv2-devel
46 BuildRequires:  ffmpeg-devel >= 0.8
47 BuildRequires:  gdk-pixbuf2-devel >= 2.18.0
48 BuildRequires:  glib2-devel >= 1:2.28.0
49 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
50 BuildRequires:  graphviz
51 BuildRequires:  gtk-doc >= 1.0
52 BuildRequires:  intltool >= 0.40.1
53 BuildRequires:  jasper-devel >= 1.900.1
54 BuildRequires:  lensfun-devel >= 0.2.5
55 BuildRequires:  libjpeg-devel
56 BuildRequires:  libopenraw-devel >= 0.0.5
57 BuildRequires:  libpng-devel
58 BuildRequires:  librsvg-devel >= 1:2.14.0
59 BuildRequires:  libspiro-devel
60 BuildRequires:  libtool >= 2:2.2
61 BuildRequires:  libv4l-devel
62 BuildRequires:  lua51-devel >= 5.1.0
63 BuildRequires:  pango-devel >= 1:1.10
64 BuildRequires:  perl-base
65 BuildRequires:  pkgconfig
66 BuildRequires:  ruby >= 1.9
67 %{?with_vala:BuildRequires:     vala}
68 Requires:       babl >= 0.1.10
69 Requires:       glib2 >= 1:2.28.0
70 Requires:       gdk-pixbuf2 >= 2.18.0
71 Requires:       jasper-libs >= 1.900.1
72 Requires:       lensfun >= 0.2.5
73 Requires:       libopenraw >= 0.0.5
74 Requires:       librsvg >= 1:2.14.0
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 GEGL (Generic Graphics Library) is a graph based image processing
79 framework.
80
81 GEGL's original design was made to scratch GIMP's itches for a new
82 compositing and processing core. This core is being designed to have
83 minimal dependencies and a simple well defined API.
84
85 %description -l pl.UTF-8
86 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
87 przetwarzania obrazu.
88
89 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
90 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
91 projektowany tak, by miał minimalne zależności i proste, dobrze
92 zdefiniowane API.
93
94 %package devel
95 Summary:        Header files for gegl library
96 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       babl-devel >= 0.1.10
100 Requires:       glib2-devel >= 1:2.28.0
101
102 %description devel
103 Header files for gegl library.
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe biblioteki gegl.
107
108 %package static
109 Summary:        Static gegl library
110 Summary(pl.UTF-8):      Statyczna biblioteka gegl
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Static gegl library.
116
117 %description static -l pl.UTF-8
118 Statyczna biblioteka gegl.
119
120 %package apidocs
121 Summary:        gegl library API documentation
122 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
123 Group:          Documentation
124 Requires:       gtk-doc-common
125
126 %description apidocs
127 gegl library API documentation.
128
129 %description apidocs -l pl.UTF-8
130 Dokumentacja API biblioteki gegl.
131
132 %package -n vala-gegl
133 Summary:        Vala API for gegl library
134 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
135 Group:          Development/Libraries
136 Requires:       %{name}-devel = %{version}-%{release}
137
138 %description -n vala-gegl
139 Vala API for gegl library.
140
141 %description -n vala-gegl -l pl.UTF-8
142 API języka Vala dla biblioteki gegl.
143
144 %prep
145 %setup -q
146 %patch0 -p1
147 %patch1 -p0
148 %patch2 -p1
149 %patch3 -p1
150 %patch4 -p1
151
152 %build
153 %{__libtoolize}
154 %{__aclocal} -I m4
155 %{__autoconf}
156 %{__autoheader}
157 %{__automake}
158 %configure \
159         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
160         --enable-docs%{!?with_doc:=no} \
161         %{?with_introspection:--enable-introspection} \
162         %{!?with_mmx:--disable-mmx} \
163         %{!?with_sse:--disable-sse} \
164         --disable-silent-rules \
165         --enable-static \
166         --with%{!?with_vala:out}-vala
167 %{__make}
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT \
174         gtkdochtmldir=%{_gtkdocdir}/gegl
175
176 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.2/*.{a,la}
177
178 %find_lang %{name}-0.2
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post   -p /sbin/ldconfig
184 %postun -p /sbin/ldconfig
185
186 %files -f %{name}-0.2.lang
187 %defattr(644,root,root,755)
188 %doc AUTHORS ChangeLog NEWS README
189 %attr(755,root,root) %{_bindir}/gegl
190 %attr(755,root,root) %{_libdir}/libgegl-0.2.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.2.so.0
192 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.2.typelib}
193 %dir %{_libdir}/gegl-0.2
194 %attr(755,root,root) %{_libdir}/gegl-0.2/*.so
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libgegl-0.2.so
199 %{_libdir}/libgegl-0.2.la
200 %{_includedir}/gegl-0.2
201 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.2.gir}
202 %{_pkgconfigdir}/gegl-0.2.pc
203
204 %files static
205 %defattr(644,root,root,755)
206 %{_libdir}/libgegl-0.2.a
207
208 %if %{with doc}
209 %files apidocs
210 %defattr(644,root,root,755)
211 %{_gtkdocdir}/gegl
212 %endif
213
214 %if %{with vala}
215 %files -n vala-gegl
216 %defattr(644,root,root,755)
217 %{_datadir}/vala/vapi/gegl-0.2.vapi
218 %endif
This page took 0.126079 seconds and 4 git commands to generate.