]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- updated to 0.4.16
[packages/gegl.git] / gegl.spec
1 #
2 # TODO:
3 # - links against zstd (some of the BR: misses dep on zstd)
4 #
5 # Conditional build:
6 %bcond_with     mmx             # use MMX instructions
7 %bcond_with     sse             # use SSE instructions
8 %bcond_without  doc             # apidocs
9 %bcond_without  lua             # without lua support
10 %bcond_without  static_libs     # static library
11 %bcond_without  introspection   # API introspection
12 %bcond_without  vala            # Vala API
13
14 %ifarch %{x8664} athlon pentium3 pentium4
15 %define with_mmx        1
16 %endif
17 %ifarch %{x8664} pentium3 pentium4
18 %define with_sse        1
19 %endif
20 %if %{without introspection}
21 %undefine       with_vala
22 %endif
23
24 %ifarch x32
25 %undefine       with_lua
26 %endif
27
28 %define babl_version    0.1.62
29 %define mrg_version     0.1.2-1.20190322.1
30
31 Summary:        Generic image processing library
32 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
33 Name:           gegl
34 Version:        0.4.16
35 Release:        1
36 License:        LGPL v3+
37 Group:          Libraries
38 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.bz2
39 # Source0-md5:  cb17ac529a882f25f54c0115c63d4027
40 Patch1:         %{name}-ruby1.9.patch
41 Patch2:         %{name}-build.patch
42 Patch3:         umfpack.patch
43 Patch5:         %{name}-without-lua.patch
44 URL:            http://www.gegl.org/
45 BuildRequires:  OpenEXR-devel >= 1.6.1
46 BuildRequires:  SDL-devel >= 1.2.0
47 BuildRequires:  UMFPACK-devel
48 BuildRequires:  asciidoc
49 BuildRequires:  autoconf >= 2.54
50 BuildRequires:  automake >= 1:1.11
51 BuildRequires:  babl-devel >= %{babl_version}
52 BuildRequires:  cairo-devel >= 1.12.2
53 BuildRequires:  enscript
54 BuildRequires:  exiv2-devel >= 0.25
55 # libavformat >= 55.48.100, libavcodec >= 55.69.100, libavutil >= 52.92.100, libswscale >= 2.6.100
56 BuildRequires:  ffmpeg-devel >= 2.3
57 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
58 BuildRequires:  gettext-tools >= 0.19.8
59 BuildRequires:  gexiv2-devel
60 BuildRequires:  glib2-devel >= 1:2.44.0
61 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
62 BuildRequires:  graphviz
63 BuildRequires:  gtk-doc >= 1.0
64 BuildRequires:  jasper-devel >= 1.900.1
65 BuildRequires:  json-glib-devel
66 BuildRequires:  lcms2-devel >= 2.8
67 BuildRequires:  lensfun-devel >= 0.2.5
68 BuildRequires:  libjpeg-devel
69 BuildRequires:  libpng-devel >= 2:1.6.0
70 BuildRequires:  libraw-devel >= 0.15.4
71 BuildRequires:  librsvg-devel >= 1:2.40.6
72 BuildRequires:  libspiro-devel
73 BuildRequires:  libtiff-devel >= 4.0.0
74 BuildRequires:  libtool >= 2:2.2
75 # as of 0.4.16, internal copy of code is used
76 #BuildRequires: libv4l-devel >= 1.0.1
77 BuildRequires:  libwebp-devel >= 0.5.0
78 %if %{with lua}
79 BuildRequires:  luajit-devel >= 2.0.4
80 BuildRequires:  lua51-devel >= 5.1.5-2
81 %endif
82 BuildRequires:  mrg-devel >= %{mrg_version}
83 BuildRequires:  pango-devel >= 1:1.38.0
84 BuildRequires:  perl-base >= 5
85 BuildRequires:  pkgconfig
86 BuildRequires:  poppler-glib-devel >= 0.71.0
87 BuildRequires:  python >= 1:2.5.0
88 # either one?
89 #BuildRequires: python-pygobject-devel >= 2.26
90 BuildRequires:  python-pygobject3-devel >= 3.2
91 BuildRequires:  poly2tri-c-devel
92 BuildRequires:  ruby >= 1.9
93 %{?with_vala:BuildRequires:     vala >= 2:0.20.0}
94 BuildRequires:  zlib-devel >= 1.2.0
95 Requires:       babl >= %{babl_version}
96 Requires:       cairo >= 1.12.2
97 Requires:       gdk-pixbuf2 >= 2.32.0
98 Requires:       glib2 >= 1:2.44.0
99 Requires:       jasper-libs >= 1.900.1
100 Requires:       lcms2 >= 2.8
101 Requires:       lensfun >= 0.2.5
102 Requires:       libraw >= 0.15.4
103 Requires:       librsvg >= 1:2.40.6
104 Requires:       libtiff >= 4.0.0
105 Requires:       libwebp >= 0.5.0
106 Requires:       mrg-libs >= %{mrg_version}
107 Requires:       pango >= 1:1.38.0
108 Requires:       poppler-glib >= 0.71.0
109 Requires:       zlib >= 1.2.0
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %description
113 GEGL (Generic Graphics Library) is a graph based image processing
114 framework.
115
116 GEGL's original design was made to scratch GIMP's itches for a new
117 compositing and processing core. This core is being designed to have
118 minimal dependencies and a simple well defined API.
119
120 %description -l pl.UTF-8
121 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
122 przetwarzania obrazu.
123
124 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
125 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
126 projektowany tak, by miał minimalne zależności i proste, dobrze
127 zdefiniowane API.
128
129 %package devel
130 Summary:        Header files for gegl library
131 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
132 Group:          Development/Libraries
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       babl-devel >= %{babl_version}
135 Requires:       glib2-devel >= 1:2.44.0
136 Requires:       json-glib-devel
137 Requires:       poly2tri-c-devel
138
139 %description devel
140 Header files for gegl library.
141
142 %description devel -l pl.UTF-8
143 Pliki nagłówkowe biblioteki gegl.
144
145 %package static
146 Summary:        Static gegl library
147 Summary(pl.UTF-8):      Statyczna biblioteka gegl
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150
151 %description static
152 Static gegl library.
153
154 %description static -l pl.UTF-8
155 Statyczna biblioteka gegl.
156
157 %package apidocs
158 Summary:        gegl library API documentation
159 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
160 Group:          Documentation
161 Requires:       gtk-doc-common
162 %if "%{_rpmversion}" >= "5"
163 BuildArch:      noarch
164 %endif
165
166 %description apidocs
167 gegl library API documentation.
168
169 %description apidocs -l pl.UTF-8
170 Dokumentacja API biblioteki gegl.
171
172 %package -n vala-gegl
173 Summary:        Vala API for gegl library
174 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
175 Group:          Development/Libraries
176 Requires:       %{name}-devel = %{version}-%{release}
177 %if "%{_rpmversion}" >= "5"
178 BuildArch:      noarch
179 %endif
180
181 %description -n vala-gegl
182 Vala API for gegl library.
183
184 %description -n vala-gegl -l pl.UTF-8
185 API języka Vala dla biblioteki gegl.
186
187 %prep
188 %setup -q
189 %patch1 -p1
190 %patch2 -p1
191 %patch3 -p1
192 %patch5 -p1
193
194 %build
195 %{__libtoolize}
196 %{__aclocal} -I m4
197 %{__autoconf}
198 %{__autoheader}
199 %{__automake}
200 %configure \
201         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
202         --enable-docs%{!?with_doc:=no} \
203         %{?with_introspection:--enable-introspection} \
204         %{!?with_mmx:--disable-mmx} \
205         %{!?with_sse:--disable-sse} \
206         --disable-silent-rules \
207         %{?with_static_libs:--enable-static} \
208         --with-vala%{!?with_vala:=no} \
209         %{__with_without lua}
210 %{__make}
211
212 %install
213 rm -rf $RPM_BUILD_ROOT
214
215 %{__make} install \
216         DESTDIR=$RPM_BUILD_ROOT \
217         gtkdochtmldir=%{_gtkdocdir}/gegl
218
219 # obsoleted by pkg-config
220 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgegl*-0.4.la
221 # dlopened modules
222 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.4/*.la
223 %if %{with static_libs}
224 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.4/*.a
225 %endif
226
227 %find_lang %{name}-0.4
228
229 %clean
230 rm -rf $RPM_BUILD_ROOT
231
232 %post   -p /sbin/ldconfig
233 %postun -p /sbin/ldconfig
234
235 %files -f %{name}-0.4.lang
236 %defattr(644,root,root,755)
237 %doc AUTHORS ChangeLog NEWS README
238 %attr(755,root,root) %{_bindir}/gcut
239 %attr(755,root,root) %{_bindir}/gegl
240 %attr(755,root,root) %{_bindir}/gegl-imgcmp
241 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
242 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
243 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
244 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
245 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
246 %dir %{_libdir}/gegl-0.4
247 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
248 %{_libdir}/gegl-0.4/grey2.json
249
250 %files devel
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
253 %{_includedir}/gegl-0.4
254 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
255 %{_pkgconfigdir}/gegl-0.4.pc
256 %{_pkgconfigdir}/gegl-sc-0.4.pc
257
258 %if %{with static_libs}
259 %files static
260 %defattr(644,root,root,755)
261 %{_libdir}/libgegl-0.4.a
262 %{_libdir}/libgegl-npd-0.4.a
263 %{_libdir}/libgegl-sc-0.4.a
264 %endif
265
266 %if %{with doc}
267 %files apidocs
268 %defattr(644,root,root,755)
269 %{_gtkdocdir}/gegl
270 %endif
271
272 %if %{with vala}
273 %files -n vala-gegl
274 %defattr(644,root,root,755)
275 %{_datadir}/vala/vapi/gegl-0.4.deps
276 %{_datadir}/vala/vapi/gegl-0.4.vapi
277 %endif
This page took 0.072812 seconds and 4 git commands to generate.