]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
- added no-lua patch (fixes build without lua)
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # apidocs
4 %bcond_without  lua             # without lua support
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # API introspection
7 %bcond_without  vala            # Vala API
8
9 %if %{without introspection}
10 %undefine       with_vala
11 %endif
12
13 %ifarch x32
14 %undefine       with_lua
15 %endif
16
17 %define babl_version    0.1.72
18 %define mrg_version     0.1.2-1.20190322.1
19
20 Summary:        Generic image processing library
21 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
22 Name:           gegl
23 Version:        0.4.18
24 Release:        1
25 License:        LGPL v3+/GPL v3+
26 Group:          Libraries
27 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.xz
28 # Source0-md5:  567f9e6c0a0a1a4145a1a1b254ca9ac5
29 Patch1:         %{name}-ruby1.9.patch
30 Patch2:         %{name}-build.patch
31 Patch3:         umfpack.patch
32 Patch4:         %{name}-link.patch
33 Patch5:         %{name}-no-lua.patch
34 URL:            http://www.gegl.org/
35 BuildRequires:  OpenEXR-devel >= 1.6.1
36 BuildRequires:  SDL2-devel >= 2.0.5
37 BuildRequires:  UMFPACK-devel
38 BuildRequires:  asciidoc
39 BuildRequires:  babl-devel >= %{babl_version}
40 BuildRequires:  bash
41 BuildRequires:  cairo-devel >= 1.12.2
42 BuildRequires:  enscript
43 BuildRequires:  exiv2-devel >= 0.25
44 # libavformat >= 55.48.100, libavcodec >= 55.69.100, libavutil >= 52.92.100, libswscale >= 2.6.100
45 BuildRequires:  ffmpeg-devel >= 2.3
46 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
47 BuildRequires:  gettext-tools >= 0.19.8
48 BuildRequires:  gexiv2-devel
49 BuildRequires:  glib2-devel >= 1:2.44.0
50 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
51 BuildRequires:  graphviz
52 BuildRequires:  gtk-doc >= 1.0
53 BuildRequires:  jasper-devel >= 1.900.1
54 BuildRequires:  json-glib-devel >= 1.2.6
55 BuildRequires:  lcms2-devel >= 2.8
56 BuildRequires:  lensfun-devel >= 0.2.5
57 BuildRequires:  libjpeg-devel >= 1.0.0
58 BuildRequires:  libnsgif-devel
59 BuildRequires:  libpng-devel >= 2:1.6.0
60 BuildRequires:  libraw-devel >= 0.15.4
61 BuildRequires:  librsvg-devel >= 1:2.40.6
62 BuildRequires:  libspiro-devel >= 0.5.0
63 BuildRequires:  libtiff-devel >= 4.0.0
64 BuildRequires:  libv4l-devel >= 1.0.1
65 BuildRequires:  libwebp-devel >= 0.5.0
66 %if %{with lua}
67 BuildRequires:  luajit-devel >= 2.0.4
68 BuildRequires:  lua51-devel >= 5.1.5-2
69 %endif
70 BuildRequires:  meson >= 0.50.0
71 BuildRequires:  mrg-devel >= %{mrg_version}
72 BuildRequires:  ninja >= 1.5
73 BuildRequires:  pango-devel >= 1:1.38.0
74 BuildRequires:  perl-base >= 5
75 BuildRequires:  pkgconfig
76 BuildRequires:  poppler-glib-devel >= 0.71.0
77 BuildRequires:  python3 >= 1:3.2
78 %if %{with introspection}
79 # for tests only
80 #BuildRequires: python-pygobject3-devel >= 3.2.0
81 %endif
82 BuildRequires:  poly2tri-c-devel
83 BuildRequires:  rpmbuild(macros) >= 1.736
84 BuildRequires:  ruby >= 1.9
85 BuildRequires:  tar >= 1:1.22
86 %{?with_vala:BuildRequires:     vala >= 2:0.20.0}
87 BuildRequires:  xz
88 BuildRequires:  zlib-devel >= 1.2.0
89 Requires:       OpenEXR >= 1.6.1
90 Requires:       SDL2 >= 2.0.5
91 Requires:       babl >= %{babl_version}
92 Requires:       cairo >= 1.12.2
93 Requires:       gdk-pixbuf2 >= 2.32.0
94 Requires:       glib2 >= 1:2.44.0
95 Requires:       jasper-libs >= 1.900.1
96 Requires:       json-glib >= 1.2.6
97 Requires:       lcms2 >= 2.8
98 Requires:       lensfun >= 0.2.5
99 Requires:       libraw >= 0.15.4
100 Requires:       librsvg >= 1:2.40.6
101 Requires:       libspiro >= 0.5.0
102 Requires:       libtiff >= 4.0.0
103 Requires:       libwebp >= 0.5.0
104 Requires:       mrg-libs >= %{mrg_version}
105 Requires:       pango >= 1:1.38.0
106 Requires:       poppler-glib >= 0.71.0
107 Requires:       zlib >= 1.2.0
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %description
111 GEGL (Generic Graphics Library) is a graph based image processing
112 framework.
113
114 GEGL's original design was made to scratch GIMP's itches for a new
115 compositing and processing core. This core is being designed to have
116 minimal dependencies and a simple well defined API.
117
118 %description -l pl.UTF-8
119 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
120 przetwarzania obrazu.
121
122 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
123 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
124 projektowany tak, by miał minimalne zależności i proste, dobrze
125 zdefiniowane API.
126
127 %package devel
128 Summary:        Header files for gegl library
129 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
130 Group:          Development/Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       babl-devel >= %{babl_version}
133 Requires:       glib2-devel >= 1:2.44.0
134 Requires:       json-glib-devel >= 1.2.6
135 Requires:       poly2tri-c-devel
136
137 %description devel
138 Header files for gegl library.
139
140 %description devel -l pl.UTF-8
141 Pliki nagłówkowe biblioteki gegl.
142
143 %package static
144 Summary:        Static gegl library
145 Summary(pl.UTF-8):      Statyczna biblioteka gegl
146 Group:          Development/Libraries
147 Requires:       %{name}-devel = %{version}-%{release}
148
149 %description static
150 Static gegl library.
151
152 %description static -l pl.UTF-8
153 Statyczna biblioteka gegl.
154
155 %package apidocs
156 Summary:        gegl library API documentation
157 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
158 Group:          Documentation
159 Requires:       gtk-doc-common
160 %if "%{_rpmversion}" >= "5"
161 BuildArch:      noarch
162 %endif
163
164 %description apidocs
165 gegl library API documentation.
166
167 %description apidocs -l pl.UTF-8
168 Dokumentacja API biblioteki gegl.
169
170 %package -n vala-gegl
171 Summary:        Vala API for gegl library
172 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
173 Group:          Development/Libraries
174 Requires:       %{name}-devel = %{version}-%{release}
175 %if "%{_rpmversion}" >= "5"
176 BuildArch:      noarch
177 %endif
178
179 %description -n vala-gegl
180 Vala API for gegl library.
181
182 %description -n vala-gegl -l pl.UTF-8
183 API języka Vala dla biblioteki gegl.
184
185 %prep
186 %setup -q
187 %patch1 -p1
188 %patch2 -p1
189 %patch3 -p1
190 %patch4 -p1
191 %patch5 -p1
192
193 %build
194 CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack"
195 %meson build \
196         %{?with_doc:-Ddocs=true} \
197         %{!?with_introspection:-Dintrospection=false} \
198         %{!?with_lua:-Dlua=disabled} \
199         -Dworkshop=true
200
201 %ninja_build -C build
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205
206 %ninja_install -C build
207
208 %find_lang %{name}-0.4
209
210 %clean
211 rm -rf $RPM_BUILD_ROOT
212
213 %post   -p /sbin/ldconfig
214 %postun -p /sbin/ldconfig
215
216 %files -f %{name}-0.4.lang
217 %defattr(644,root,root,755)
218 %doc AUTHORS MAINTAINERS
219 %attr(755,root,root) %{_bindir}/gegl
220 %attr(755,root,root) %{_bindir}/gegl-imgcmp
221 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
222 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
223 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
224 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
225 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
226 %dir %{_libdir}/gegl-0.4
227 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
228 %{_libdir}/gegl-0.4/grey2.json
229 %if %{with lua}
230 %dir %{_datadir}/gegl-0.4
231 %{_datadir}/gegl-0.4/lua
232 %endif
233
234 %files devel
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
237 %{_includedir}/gegl-0.4
238 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
239 %{_pkgconfigdir}/gegl-0.4.pc
240 %{_pkgconfigdir}/gegl-sc-0.4.pc
241
242 %if %{with static_libs}
243 %files static
244 %defattr(644,root,root,755)
245 %{_libdir}/libgegl-0.4.a
246 %{_libdir}/libgegl-npd-0.4.a
247 %{_libdir}/libgegl-sc-0.4.a
248 %endif
249
250 %if %{with doc}
251 %files apidocs
252 %defattr(644,root,root,755)
253 %doc build/docs/{ophtml,*.html,*.png}
254 %{_gtkdocdir}/gegl
255 %endif
256
257 %if %{with vala}
258 %files -n vala-gegl
259 %defattr(644,root,root,755)
260 %{_datadir}/vala/vapi/gegl-0.4.deps
261 %{_datadir}/vala/vapi/gegl-0.4.vapi
262 %endif
This page took 0.0542820000000001 seconds and 3 git commands to generate.