]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
e56cac5fe83118e9c952951065815ac74f68e264
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse             # use SSE instructions
5 %bcond_without  doc             # apidocs
6 %bcond_without  lua             # without lua support
7 %bcond_without  static_libs     # static library
8 %bcond_without  introspection   # API introspection
9 %bcond_without  vala            # Vala API
10
11 %ifarch %{x8664} athlon pentium3 pentium4
12 %define with_mmx        1
13 %endif
14 %ifarch %{x8664} pentium3 pentium4
15 %define with_sse        1
16 %endif
17 %if %{without introspection}
18 %undefine       with_vala
19 %endif
20
21 %ifarch x32
22 %undefine       with_lua
23 %endif
24
25 %define babl_version    0.1.62
26 %define mrg_version     0.1.2-1.20190322.1
27
28 Summary:        Generic image processing library
29 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
30 Name:           gegl
31 Version:        0.4.14
32 Release:        1
33 License:        LGPL v3+
34 Group:          Libraries
35 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.bz2
36 # Source0-md5:  88004f3a204e2506cd0cc445eba8d63e
37 Patch1:         %{name}-ruby1.9.patch
38 Patch2:         %{name}-build.patch
39 Patch3:         umfpack.patch
40 Patch4:         %{name}-Wformat-security.patch
41 Patch5:         %{name}-without-lua.patch
42 URL:            http://www.gegl.org/
43 BuildRequires:  OpenEXR-devel >= 1.6.1
44 BuildRequires:  SDL-devel >= 1.2.0
45 BuildRequires:  UMFPACK-devel
46 BuildRequires:  asciidoc
47 BuildRequires:  autoconf >= 2.54
48 BuildRequires:  automake >= 1:1.11
49 BuildRequires:  babl-devel >= %{babl_version}
50 BuildRequires:  cairo-devel >= 1.12.2
51 BuildRequires:  enscript
52 BuildRequires:  exiv2-devel >= 0.25
53 # libavformat >= 55.48.100, libavcodec >= 55.69.100, libswscale >= 2.6.100
54 BuildRequires:  ffmpeg-devel >= 2.3
55 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
56 BuildRequires:  gettext-tools
57 BuildRequires:  gexiv2-devel
58 BuildRequires:  glib2-devel >= 1:2.44.0
59 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
60 BuildRequires:  graphviz
61 BuildRequires:  gtk-doc >= 1.0
62 BuildRequires:  intltool >= 0.40.1
63 BuildRequires:  jasper-devel >= 1.900.1
64 BuildRequires:  json-glib-devel
65 BuildRequires:  lcms2-devel >= 2.8
66 BuildRequires:  lensfun-devel >= 0.2.5
67 BuildRequires:  libjpeg-devel
68 BuildRequires:  libpng-devel
69 BuildRequires:  libraw-devel >= 0.15.4
70 BuildRequires:  librsvg-devel >= 1:2.40.6
71 BuildRequires:  libspiro-devel
72 BuildRequires:  libtiff-devel >= 4.0.0
73 BuildRequires:  libtool >= 2:2.2
74 BuildRequires:  libv4l-devel >= 1.0.1
75 BuildRequires:  libwebp-devel >= 0.5.0
76 %if %{with lua}
77 BuildRequires:  luajit-devel >= 2.0.4
78 BuildRequires:  lua51-devel >= 5.1.5-2
79 %endif
80 BuildRequires:  mrg-devel >= %{mrg_version}
81 BuildRequires:  pango-devel >= 1:1.38.0
82 BuildRequires:  perl-base
83 BuildRequires:  pkgconfig
84 BuildRequires:  poppler-glib-devel >= 0.71.0
85 BuildRequires:  python >= 1:2.5.0
86 # either one?
87 #BuildRequires: python-pygobject-devel >= 2.26
88 BuildRequires:  python-pygobject3-devel >= 3.2
89 BuildRequires:  poly2tri-c-devel
90 BuildRequires:  ruby >= 1.9
91 %{?with_vala:BuildRequires:     vala >= 2:0.20.0}
92 Requires:       babl >= %{babl_version}
93 Requires:       gdk-pixbuf2 >= 2.32.0
94 Requires:       glib2 >= 1:2.44.0
95 Requires:       jasper-libs >= 1.900.1
96 Requires:       lensfun >= 0.2.5
97 Requires:       libraw >= 0.15.4
98 Requires:       librsvg >= 1:2.40.6
99 Requires:       libtiff >= 4.0.0
100 Requires:       mrg-libs >= %{mrg_version}
101 Requires:       pango >= 1:1.38.0
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %description
105 GEGL (Generic Graphics Library) is a graph based image processing
106 framework.
107
108 GEGL's original design was made to scratch GIMP's itches for a new
109 compositing and processing core. This core is being designed to have
110 minimal dependencies and a simple well defined API.
111
112 %description -l pl.UTF-8
113 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
114 przetwarzania obrazu.
115
116 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
117 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
118 projektowany tak, by miał minimalne zależności i proste, dobrze
119 zdefiniowane API.
120
121 %package devel
122 Summary:        Header files for gegl library
123 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
124 Group:          Development/Libraries
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       babl-devel >= %{babl_version}
127 Requires:       glib2-devel >= 1:2.44.0
128
129 %description devel
130 Header files for gegl library.
131
132 %description devel -l pl.UTF-8
133 Pliki nagłówkowe biblioteki gegl.
134
135 %package static
136 Summary:        Static gegl library
137 Summary(pl.UTF-8):      Statyczna biblioteka gegl
138 Group:          Development/Libraries
139 Requires:       %{name}-devel = %{version}-%{release}
140
141 %description static
142 Static gegl library.
143
144 %description static -l pl.UTF-8
145 Statyczna biblioteka gegl.
146
147 %package apidocs
148 Summary:        gegl library API documentation
149 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
150 Group:          Documentation
151 Requires:       gtk-doc-common
152 %if "%{_rpmversion}" >= "5"
153 BuildArch:      noarch
154 %endif
155
156 %description apidocs
157 gegl library API documentation.
158
159 %description apidocs -l pl.UTF-8
160 Dokumentacja API biblioteki gegl.
161
162 %package -n vala-gegl
163 Summary:        Vala API for gegl library
164 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
165 Group:          Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167 %if "%{_rpmversion}" >= "5"
168 BuildArch:      noarch
169 %endif
170
171 %description -n vala-gegl
172 Vala API for gegl library.
173
174 %description -n vala-gegl -l pl.UTF-8
175 API języka Vala dla biblioteki gegl.
176
177 %prep
178 %setup -q
179 %patch1 -p1
180 %patch2 -p1
181 %patch3 -p1
182 %patch4 -p1
183 %patch5 -p1
184
185 %build
186 %{__libtoolize}
187 %{__aclocal} -I m4
188 %{__autoconf}
189 %{__autoheader}
190 %{__automake}
191 %configure \
192         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
193         --enable-docs%{!?with_doc:=no} \
194         %{?with_introspection:--enable-introspection} \
195         %{!?with_mmx:--disable-mmx} \
196         %{!?with_sse:--disable-sse} \
197         --disable-silent-rules \
198         %{?with_static_libs:--enable-static} \
199         --with-vala%{!?with_vala:=no} \
200         %{__with_without lua}
201 %{__make}
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205
206 %{__make} install \
207         DESTDIR=$RPM_BUILD_ROOT \
208         gtkdochtmldir=%{_gtkdocdir}/gegl
209
210 # obsoleted by pkg-config
211 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgegl*-0.4.la
212 # dlopened modules
213 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.4/*.la
214 %if %{with static_libs}
215 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.4/*.a
216 %endif
217
218 %find_lang %{name}-0.4
219
220 %clean
221 rm -rf $RPM_BUILD_ROOT
222
223 %post   -p /sbin/ldconfig
224 %postun -p /sbin/ldconfig
225
226 %files -f %{name}-0.4.lang
227 %defattr(644,root,root,755)
228 %doc AUTHORS ChangeLog NEWS README
229 %attr(755,root,root) %{_bindir}/gcut
230 %attr(755,root,root) %{_bindir}/gegl
231 %attr(755,root,root) %{_bindir}/gegl-imgcmp
232 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
233 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
234 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
235 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
236 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
237 %dir %{_libdir}/gegl-0.4
238 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
239 %{_libdir}/gegl-0.4/grey2.json
240
241 %files devel
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
244 %{_includedir}/gegl-0.4
245 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
246 %{_pkgconfigdir}/gegl-0.4.pc
247 %{_pkgconfigdir}/gegl-sc-0.4.pc
248
249 %if %{with static_libs}
250 %files static
251 %defattr(644,root,root,755)
252 %{_libdir}/libgegl-0.4.a
253 %{_libdir}/libgegl-npd-0.4.a
254 %{_libdir}/libgegl-sc-0.4.a
255 %endif
256
257 %if %{with doc}
258 %files apidocs
259 %defattr(644,root,root,755)
260 %{_gtkdocdir}/gegl
261 %endif
262
263 %if %{with vala}
264 %files -n vala-gegl
265 %defattr(644,root,root,755)
266 %{_datadir}/vala/vapi/gegl-0.4.deps
267 %{_datadir}/vala/vapi/gegl-0.4.vapi
268 %endif
This page took 0.034356 seconds and 2 git commands to generate.