- updated to 0.4.18; uses meson now
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # apidocs
4 %bcond_without  lua             # without lua support
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # API introspection
7 %bcond_without  vala            # Vala API
8
9 %if %{without introspection}
10 %undefine       with_vala
11 %endif
12
13 %ifarch x32
14 %undefine       with_lua
15 %endif
16
17 %define babl_version    0.1.72
18 %define mrg_version     0.1.2-1.20190322.1
19
20 Summary:        Generic image processing library
21 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
22 Name:           gegl
23 Version:        0.4.18
24 Release:        1
25 License:        LGPL v3+/GPL v3+
26 Group:          Libraries
27 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.xz
28 # Source0-md5:  567f9e6c0a0a1a4145a1a1b254ca9ac5
29 Patch1:         %{name}-ruby1.9.patch
30 Patch2:         %{name}-build.patch
31 Patch3:         umfpack.patch
32 Patch4:         %{name}-link.patch
33 URL:            http://www.gegl.org/
34 BuildRequires:  OpenEXR-devel >= 1.6.1
35 BuildRequires:  SDL2-devel >= 2.0.5
36 BuildRequires:  UMFPACK-devel
37 BuildRequires:  asciidoc
38 BuildRequires:  babl-devel >= %{babl_version}
39 BuildRequires:  bash
40 BuildRequires:  cairo-devel >= 1.12.2
41 BuildRequires:  enscript
42 BuildRequires:  exiv2-devel >= 0.25
43 # libavformat >= 55.48.100, libavcodec >= 55.69.100, libavutil >= 52.92.100, libswscale >= 2.6.100
44 BuildRequires:  ffmpeg-devel >= 2.3
45 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
46 BuildRequires:  gettext-tools >= 0.19.8
47 BuildRequires:  gexiv2-devel
48 BuildRequires:  glib2-devel >= 1:2.44.0
49 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
50 BuildRequires:  graphviz
51 BuildRequires:  gtk-doc >= 1.0
52 BuildRequires:  jasper-devel >= 1.900.1
53 BuildRequires:  json-glib-devel >= 1.2.6
54 BuildRequires:  lcms2-devel >= 2.8
55 BuildRequires:  lensfun-devel >= 0.2.5
56 BuildRequires:  libjpeg-devel >= 1.0.0
57 BuildRequires:  libnsgif-devel
58 BuildRequires:  libpng-devel >= 2:1.6.0
59 BuildRequires:  libraw-devel >= 0.15.4
60 BuildRequires:  librsvg-devel >= 1:2.40.6
61 BuildRequires:  libspiro-devel >= 0.5.0
62 BuildRequires:  libtiff-devel >= 4.0.0
63 BuildRequires:  libv4l-devel >= 1.0.1
64 BuildRequires:  libwebp-devel >= 0.5.0
65 %if %{with lua}
66 BuildRequires:  luajit-devel >= 2.0.4
67 BuildRequires:  lua51-devel >= 5.1.5-2
68 %endif
69 BuildRequires:  meson >= 0.50.0
70 BuildRequires:  mrg-devel >= %{mrg_version}
71 BuildRequires:  ninja >= 1.5
72 BuildRequires:  pango-devel >= 1:1.38.0
73 BuildRequires:  perl-base >= 5
74 BuildRequires:  pkgconfig
75 BuildRequires:  poppler-glib-devel >= 0.71.0
76 BuildRequires:  python3 >= 1:3.2
77 %if %{with introspection}
78 # for tests only
79 #BuildRequires: python-pygobject3-devel >= 3.2.0
80 %endif
81 BuildRequires:  poly2tri-c-devel
82 BuildRequires:  rpmbuild(macros) >= 1.736
83 BuildRequires:  ruby >= 1.9
84 BuildRequires:  tar >= 1:1.22
85 %{?with_vala:BuildRequires:     vala >= 2:0.20.0}
86 BuildRequires:  xz
87 BuildRequires:  zlib-devel >= 1.2.0
88 Requires:       OpenEXR >= 1.6.1
89 Requires:       SDL2 >= 2.0.5
90 Requires:       babl >= %{babl_version}
91 Requires:       cairo >= 1.12.2
92 Requires:       gdk-pixbuf2 >= 2.32.0
93 Requires:       glib2 >= 1:2.44.0
94 Requires:       jasper-libs >= 1.900.1
95 Requires:       json-glib >= 1.2.6
96 Requires:       lcms2 >= 2.8
97 Requires:       lensfun >= 0.2.5
98 Requires:       libraw >= 0.15.4
99 Requires:       librsvg >= 1:2.40.6
100 Requires:       libspiro >= 0.5.0
101 Requires:       libtiff >= 4.0.0
102 Requires:       libwebp >= 0.5.0
103 Requires:       mrg-libs >= %{mrg_version}
104 Requires:       pango >= 1:1.38.0
105 Requires:       poppler-glib >= 0.71.0
106 Requires:       zlib >= 1.2.0
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %description
110 GEGL (Generic Graphics Library) is a graph based image processing
111 framework.
112
113 GEGL's original design was made to scratch GIMP's itches for a new
114 compositing and processing core. This core is being designed to have
115 minimal dependencies and a simple well defined API.
116
117 %description -l pl.UTF-8
118 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
119 przetwarzania obrazu.
120
121 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
122 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
123 projektowany tak, by miał minimalne zależności i proste, dobrze
124 zdefiniowane API.
125
126 %package devel
127 Summary:        Header files for gegl library
128 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
129 Group:          Development/Libraries
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       babl-devel >= %{babl_version}
132 Requires:       glib2-devel >= 1:2.44.0
133 Requires:       json-glib-devel >= 1.2.6
134 Requires:       poly2tri-c-devel
135
136 %description devel
137 Header files for gegl library.
138
139 %description devel -l pl.UTF-8
140 Pliki nagłówkowe biblioteki gegl.
141
142 %package static
143 Summary:        Static gegl library
144 Summary(pl.UTF-8):      Statyczna biblioteka gegl
145 Group:          Development/Libraries
146 Requires:       %{name}-devel = %{version}-%{release}
147
148 %description static
149 Static gegl library.
150
151 %description static -l pl.UTF-8
152 Statyczna biblioteka gegl.
153
154 %package apidocs
155 Summary:        gegl library API documentation
156 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
157 Group:          Documentation
158 Requires:       gtk-doc-common
159 %if "%{_rpmversion}" >= "5"
160 BuildArch:      noarch
161 %endif
162
163 %description apidocs
164 gegl library API documentation.
165
166 %description apidocs -l pl.UTF-8
167 Dokumentacja API biblioteki gegl.
168
169 %package -n vala-gegl
170 Summary:        Vala API for gegl library
171 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174 %if "%{_rpmversion}" >= "5"
175 BuildArch:      noarch
176 %endif
177
178 %description -n vala-gegl
179 Vala API for gegl library.
180
181 %description -n vala-gegl -l pl.UTF-8
182 API języka Vala dla biblioteki gegl.
183
184 %prep
185 %setup -q
186 %patch1 -p1
187 %patch2 -p1
188 %patch3 -p1
189 %patch4 -p1
190
191 %build
192 CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack"
193 %meson build \
194         %{?with_doc:-Ddocs=true} \
195         %{!?with_introspection:-Dintrospection=false} \
196         %{!?with_lua:-Dlua=disabled} \
197         -Dworkshop=true
198
199 %ninja_build -C build
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203
204 %ninja_install -C build
205
206 %find_lang %{name}-0.4
207
208 %clean
209 rm -rf $RPM_BUILD_ROOT
210
211 %post   -p /sbin/ldconfig
212 %postun -p /sbin/ldconfig
213
214 %files -f %{name}-0.4.lang
215 %defattr(644,root,root,755)
216 %doc AUTHORS MAINTAINERS
217 %attr(755,root,root) %{_bindir}/gegl
218 %attr(755,root,root) %{_bindir}/gegl-imgcmp
219 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
220 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
221 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
222 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
223 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
224 %dir %{_libdir}/gegl-0.4
225 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
226 %{_libdir}/gegl-0.4/grey2.json
227 %if %{with lua}
228 %dir %{_datadir}/gegl-0.4
229 %{_datadir}/gegl-0.4/lua
230 %endif
231
232 %files devel
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
235 %{_includedir}/gegl-0.4
236 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
237 %{_pkgconfigdir}/gegl-0.4.pc
238 %{_pkgconfigdir}/gegl-sc-0.4.pc
239
240 %if %{with static_libs}
241 %files static
242 %defattr(644,root,root,755)
243 %{_libdir}/libgegl-0.4.a
244 %{_libdir}/libgegl-npd-0.4.a
245 %{_libdir}/libgegl-sc-0.4.a
246 %endif
247
248 %if %{with doc}
249 %files apidocs
250 %defattr(644,root,root,755)
251 %doc build/docs/{ophtml,*.html,*.png}
252 %{_gtkdocdir}/gegl
253 %endif
254
255 %if %{with vala}
256 %files -n vala-gegl
257 %defattr(644,root,root,755)
258 %{_datadir}/vala/vapi/gegl-0.4.deps
259 %{_datadir}/vala/vapi/gegl-0.4.vapi
260 %endif
This page took 0.11734 seconds and 3 git commands to generate.