]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
bf7a667b2686b0b1a410f37d85d051524a635794
[packages/gegl.git] / gegl.spec
1 #
2 # TODO:
3 # - links against zstd (some of the BR: misses dep on zstd)
4 #
5 # Conditional build:
6 %bcond_with     mmx             # use MMX instructions
7 %bcond_with     sse             # use SSE instructions
8 %bcond_without  doc             # apidocs
9 %bcond_without  lua             # without lua support
10 %bcond_without  static_libs     # static library
11 %bcond_without  introspection   # API introspection
12 %bcond_without  vala            # Vala API
13
14 %ifarch %{x8664} athlon pentium3 pentium4
15 %define with_mmx        1
16 %endif
17 %ifarch %{x8664} pentium3 pentium4
18 %define with_sse        1
19 %endif
20 %if %{without introspection}
21 %undefine       with_vala
22 %endif
23
24 %ifarch x32
25 %undefine       with_lua
26 %endif
27
28 %define babl_version    0.1.62
29 %define mrg_version     0.1.2-1.20190322.1
30
31 Summary:        Generic image processing library
32 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
33 Name:           gegl
34 Version:        0.4.14
35 Release:        3
36 License:        LGPL v3+
37 Group:          Libraries
38 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.bz2
39 # Source0-md5:  88004f3a204e2506cd0cc445eba8d63e
40 Patch1:         %{name}-ruby1.9.patch
41 Patch2:         %{name}-build.patch
42 Patch3:         umfpack.patch
43 Patch4:         %{name}-Wformat-security.patch
44 Patch5:         %{name}-without-lua.patch
45 URL:            http://www.gegl.org/
46 BuildRequires:  OpenEXR-devel >= 1.6.1
47 BuildRequires:  SDL-devel >= 1.2.0
48 BuildRequires:  UMFPACK-devel
49 BuildRequires:  asciidoc
50 BuildRequires:  autoconf >= 2.54
51 BuildRequires:  automake >= 1:1.11
52 BuildRequires:  babl-devel >= %{babl_version}
53 BuildRequires:  cairo-devel >= 1.12.2
54 BuildRequires:  enscript
55 BuildRequires:  exiv2-devel >= 0.25
56 # libavformat >= 55.48.100, libavcodec >= 55.69.100, libswscale >= 2.6.100
57 BuildRequires:  ffmpeg-devel >= 2.3
58 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
59 BuildRequires:  gettext-tools
60 BuildRequires:  gexiv2-devel
61 BuildRequires:  glib2-devel >= 1:2.44.0
62 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
63 BuildRequires:  graphviz
64 BuildRequires:  gtk-doc >= 1.0
65 BuildRequires:  intltool >= 0.40.1
66 BuildRequires:  jasper-devel >= 1.900.1
67 BuildRequires:  json-glib-devel
68 BuildRequires:  lcms2-devel >= 2.8
69 BuildRequires:  lensfun-devel >= 0.2.5
70 BuildRequires:  libjpeg-devel
71 BuildRequires:  libpng-devel
72 BuildRequires:  libraw-devel >= 0.15.4
73 BuildRequires:  librsvg-devel >= 1:2.40.6
74 BuildRequires:  libspiro-devel
75 BuildRequires:  libtiff-devel >= 4.0.0
76 BuildRequires:  libtool >= 2:2.2
77 BuildRequires:  libv4l-devel >= 1.0.1
78 BuildRequires:  libwebp-devel >= 0.5.0
79 %if %{with lua}
80 BuildRequires:  luajit-devel >= 2.0.4
81 BuildRequires:  lua51-devel >= 5.1.5-2
82 %endif
83 BuildRequires:  mrg-devel >= %{mrg_version}
84 BuildRequires:  pango-devel >= 1:1.38.0
85 BuildRequires:  perl-base
86 BuildRequires:  pkgconfig
87 BuildRequires:  poppler-glib-devel >= 0.71.0
88 BuildRequires:  python >= 1:2.5.0
89 # either one?
90 #BuildRequires: python-pygobject-devel >= 2.26
91 BuildRequires:  python-pygobject3-devel >= 3.2
92 BuildRequires:  poly2tri-c-devel
93 BuildRequires:  ruby >= 1.9
94 %{?with_vala:BuildRequires:     vala >= 2:0.20.0}
95 Requires:       babl >= %{babl_version}
96 Requires:       gdk-pixbuf2 >= 2.32.0
97 Requires:       glib2 >= 1:2.44.0
98 Requires:       jasper-libs >= 1.900.1
99 Requires:       lensfun >= 0.2.5
100 Requires:       libraw >= 0.15.4
101 Requires:       librsvg >= 1:2.40.6
102 Requires:       libtiff >= 4.0.0
103 Requires:       mrg-libs >= %{mrg_version}
104 Requires:       pango >= 1:1.38.0
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %description
108 GEGL (Generic Graphics Library) is a graph based image processing
109 framework.
110
111 GEGL's original design was made to scratch GIMP's itches for a new
112 compositing and processing core. This core is being designed to have
113 minimal dependencies and a simple well defined API.
114
115 %description -l pl.UTF-8
116 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
117 przetwarzania obrazu.
118
119 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
120 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
121 projektowany tak, by miał minimalne zależności i proste, dobrze
122 zdefiniowane API.
123
124 %package devel
125 Summary:        Header files for gegl library
126 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
127 Group:          Development/Libraries
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       babl-devel >= %{babl_version}
130 Requires:       glib2-devel >= 1:2.44.0
131
132 %description devel
133 Header files for gegl library.
134
135 %description devel -l pl.UTF-8
136 Pliki nagłówkowe biblioteki gegl.
137
138 %package static
139 Summary:        Static gegl library
140 Summary(pl.UTF-8):      Statyczna biblioteka gegl
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description static
145 Static gegl library.
146
147 %description static -l pl.UTF-8
148 Statyczna biblioteka gegl.
149
150 %package apidocs
151 Summary:        gegl library API documentation
152 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
153 Group:          Documentation
154 Requires:       gtk-doc-common
155 %if "%{_rpmversion}" >= "5"
156 BuildArch:      noarch
157 %endif
158
159 %description apidocs
160 gegl library API documentation.
161
162 %description apidocs -l pl.UTF-8
163 Dokumentacja API biblioteki gegl.
164
165 %package -n vala-gegl
166 Summary:        Vala API for gegl library
167 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
168 Group:          Development/Libraries
169 Requires:       %{name}-devel = %{version}-%{release}
170 %if "%{_rpmversion}" >= "5"
171 BuildArch:      noarch
172 %endif
173
174 %description -n vala-gegl
175 Vala API for gegl library.
176
177 %description -n vala-gegl -l pl.UTF-8
178 API języka Vala dla biblioteki gegl.
179
180 %prep
181 %setup -q
182 %patch1 -p1
183 %patch2 -p1
184 %patch3 -p1
185 %patch4 -p1
186 %patch5 -p1
187
188 %build
189 %{__libtoolize}
190 %{__aclocal} -I m4
191 %{__autoconf}
192 %{__autoheader}
193 %{__automake}
194 %configure \
195         CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack" \
196         --enable-docs%{!?with_doc:=no} \
197         %{?with_introspection:--enable-introspection} \
198         %{!?with_mmx:--disable-mmx} \
199         %{!?with_sse:--disable-sse} \
200         --disable-silent-rules \
201         %{?with_static_libs:--enable-static} \
202         --with-vala%{!?with_vala:=no} \
203         %{__with_without lua}
204 %{__make}
205
206 %install
207 rm -rf $RPM_BUILD_ROOT
208
209 %{__make} install \
210         DESTDIR=$RPM_BUILD_ROOT \
211         gtkdochtmldir=%{_gtkdocdir}/gegl
212
213 # obsoleted by pkg-config
214 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgegl*-0.4.la
215 # dlopened modules
216 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.4/*.la
217 %if %{with static_libs}
218 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gegl-0.4/*.a
219 %endif
220
221 %find_lang %{name}-0.4
222
223 %clean
224 rm -rf $RPM_BUILD_ROOT
225
226 %post   -p /sbin/ldconfig
227 %postun -p /sbin/ldconfig
228
229 %files -f %{name}-0.4.lang
230 %defattr(644,root,root,755)
231 %doc AUTHORS ChangeLog NEWS README
232 %attr(755,root,root) %{_bindir}/gcut
233 %attr(755,root,root) %{_bindir}/gegl
234 %attr(755,root,root) %{_bindir}/gegl-imgcmp
235 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
236 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
237 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
238 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
239 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
240 %dir %{_libdir}/gegl-0.4
241 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
242 %{_libdir}/gegl-0.4/grey2.json
243
244 %files devel
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
247 %{_includedir}/gegl-0.4
248 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
249 %{_pkgconfigdir}/gegl-0.4.pc
250 %{_pkgconfigdir}/gegl-sc-0.4.pc
251
252 %if %{with static_libs}
253 %files static
254 %defattr(644,root,root,755)
255 %{_libdir}/libgegl-0.4.a
256 %{_libdir}/libgegl-npd-0.4.a
257 %{_libdir}/libgegl-sc-0.4.a
258 %endif
259
260 %if %{with doc}
261 %files apidocs
262 %defattr(644,root,root,755)
263 %{_gtkdocdir}/gegl
264 %endif
265
266 %if %{with vala}
267 %files -n vala-gegl
268 %defattr(644,root,root,755)
269 %{_datadir}/vala/vapi/gegl-0.4.deps
270 %{_datadir}/vala/vapi/gegl-0.4.vapi
271 %endif
This page took 0.03179 seconds and 2 git commands to generate.