]> git.pld-linux.org Git - packages/gegl.git/blob - gegl.spec
63098fe00bfaa84ffbb8827b4b4f34fcab4623c5
[packages/gegl.git] / gegl.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # apidocs
4 %bcond_without  lua             # without lua support
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # API introspection
7 %bcond_without  vala            # Vala API
8
9 %if %{without introspection}
10 %undefine       with_vala
11 %endif
12
13 %ifarch x32
14 %undefine       with_lua
15 %endif
16
17 %define babl_version    0.1.72
18 %define mrg_version     0.1.2-1.20190322.1
19
20 Summary:        Generic image processing library
21 Summary(pl.UTF-8):      Ogólna biblioteka przetwarzania obrazu
22 Name:           gegl
23 Version:        0.4.18
24 Release:        3
25 License:        LGPL v3+/GPL v3+
26 Group:          Libraries
27 Source0:        https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.xz
28 # Source0-md5:  567f9e6c0a0a1a4145a1a1b254ca9ac5
29 Patch0:         %{name}-mrg.patch
30 Patch1:         %{name}-ruby1.9.patch
31 Patch2:         %{name}-build.patch
32 Patch3:         umfpack.patch
33 Patch4:         %{name}-link.patch
34 Patch5:         %{name}-no-lua.patch
35 URL:            http://www.gegl.org/
36 BuildRequires:  OpenEXR-devel >= 1.6.1
37 BuildRequires:  SDL2-devel >= 2.0.5
38 BuildRequires:  UMFPACK-devel
39 BuildRequires:  asciidoc
40 BuildRequires:  babl-devel >= %{babl_version}
41 BuildRequires:  bash
42 BuildRequires:  cairo-devel >= 1.12.2
43 BuildRequires:  enscript
44 BuildRequires:  exiv2-devel >= 0.25
45 # libavformat >= 55.48.100, libavcodec >= 55.69.100, libavutil >= 52.92.100, libswscale >= 2.6.100
46 BuildRequires:  ffmpeg-devel >= 2.3
47 BuildRequires:  gdk-pixbuf2-devel >= 2.32.0
48 BuildRequires:  gettext-tools >= 0.19.8
49 BuildRequires:  gexiv2-devel
50 BuildRequires:  glib2-devel >= 1:2.44.0
51 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
52 BuildRequires:  graphviz
53 BuildRequires:  gtk-doc >= 1.0
54 BuildRequires:  jasper-devel >= 1.900.1
55 BuildRequires:  json-glib-devel >= 1.2.6
56 BuildRequires:  lcms2-devel >= 2.8
57 BuildRequires:  lensfun-devel >= 0.2.5
58 BuildRequires:  libjpeg-devel >= 1.0.0
59 BuildRequires:  libnsgif-devel
60 BuildRequires:  libpng-devel >= 2:1.6.0
61 BuildRequires:  libraw-devel >= 0.15.4
62 BuildRequires:  librsvg-devel >= 1:2.40.6
63 BuildRequires:  libspiro-devel >= 0.5.0
64 BuildRequires:  libtiff-devel >= 4.0.0
65 BuildRequires:  libv4l-devel >= 1.0.1
66 BuildRequires:  libwebp-devel >= 0.5.0
67 %if %{with lua}
68 BuildRequires:  luajit-devel >= 2.0.4
69 BuildRequires:  lua51-devel >= 5.1.5-2
70 %endif
71 BuildRequires:  meson >= 0.50.0
72 BuildRequires:  mrg-devel >= %{mrg_version}
73 BuildRequires:  ninja >= 1.5
74 BuildRequires:  pango-devel >= 1:1.38.0
75 BuildRequires:  perl-base >= 5
76 BuildRequires:  pkgconfig
77 BuildRequires:  poppler-glib-devel >= 0.71.0
78 BuildRequires:  python3 >= 1:3.2
79 %if %{with introspection}
80 # for tests only
81 #BuildRequires: python-pygobject3-devel >= 3.2.0
82 %endif
83 BuildRequires:  poly2tri-c-devel
84 BuildRequires:  rpmbuild(macros) >= 1.736
85 BuildRequires:  ruby >= 1.9
86 BuildRequires:  tar >= 1:1.22
87 %{?with_vala:BuildRequires:     vala >= 2:0.20.0}
88 BuildRequires:  xz
89 BuildRequires:  zlib-devel >= 1.2.0
90 Requires:       OpenEXR >= 1.6.1
91 Requires:       SDL2 >= 2.0.5
92 Requires:       babl >= %{babl_version}
93 Requires:       cairo >= 1.12.2
94 Requires:       gdk-pixbuf2 >= 2.32.0
95 Requires:       glib2 >= 1:2.44.0
96 Requires:       jasper-libs >= 1.900.1
97 Requires:       json-glib >= 1.2.6
98 Requires:       lcms2 >= 2.8
99 Requires:       lensfun >= 0.2.5
100 Requires:       libraw >= 0.15.4
101 Requires:       librsvg >= 1:2.40.6
102 Requires:       libspiro >= 0.5.0
103 Requires:       libtiff >= 4.0.0
104 Requires:       libwebp >= 0.5.0
105 Requires:       mrg-libs >= %{mrg_version}
106 Requires:       pango >= 1:1.38.0
107 Requires:       poppler-glib >= 0.71.0
108 Requires:       zlib >= 1.2.0
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %description
112 GEGL (Generic Graphics Library) is a graph based image processing
113 framework.
114
115 GEGL's original design was made to scratch GIMP's itches for a new
116 compositing and processing core. This core is being designed to have
117 minimal dependencies and a simple well defined API.
118
119 %description -l pl.UTF-8
120 GEGL (Generic Graphics Library) to oparty na grafice szkielet do
121 przetwarzania obrazu.
122
123 Pierwotny projekt biblioteki GEGL powstał z myślą o nowym rdzeniu do
124 składania i przetwarzania obrazu w GIMP-ie. Rdzeń ten jest
125 projektowany tak, by miał minimalne zależności i proste, dobrze
126 zdefiniowane API.
127
128 %package devel
129 Summary:        Header files for gegl library
130 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gegl
131 Group:          Development/Libraries
132 Requires:       %{name} = %{version}-%{release}
133 Requires:       babl-devel >= %{babl_version}
134 Requires:       glib2-devel >= 1:2.44.0
135 Requires:       json-glib-devel >= 1.2.6
136 Requires:       poly2tri-c-devel
137
138 %description devel
139 Header files for gegl library.
140
141 %description devel -l pl.UTF-8
142 Pliki nagłówkowe biblioteki gegl.
143
144 %package static
145 Summary:        Static gegl library
146 Summary(pl.UTF-8):      Statyczna biblioteka gegl
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149
150 %description static
151 Static gegl library.
152
153 %description static -l pl.UTF-8
154 Statyczna biblioteka gegl.
155
156 %package apidocs
157 Summary:        gegl library API documentation
158 Summary(pl.UTF-8):      Dokumentacja API biblioteki gegl
159 Group:          Documentation
160 Requires:       gtk-doc-common
161 %if "%{_rpmversion}" >= "5"
162 BuildArch:      noarch
163 %endif
164
165 %description apidocs
166 gegl library API documentation.
167
168 %description apidocs -l pl.UTF-8
169 Dokumentacja API biblioteki gegl.
170
171 %package -n vala-gegl
172 Summary:        Vala API for gegl library
173 Summary(pl.UTF-8):      API języka Vala dla biblioteki gegl
174 Group:          Development/Libraries
175 Requires:       %{name}-devel = %{version}-%{release}
176 %if "%{_rpmversion}" >= "5"
177 BuildArch:      noarch
178 %endif
179
180 %description -n vala-gegl
181 Vala API for gegl library.
182
183 %description -n vala-gegl -l pl.UTF-8
184 API języka Vala dla biblioteki gegl.
185
186 %prep
187 %setup -q
188 %patch0 -p1
189 %patch1 -p1
190 %patch2 -p1
191 %patch3 -p1
192 %patch4 -p1
193 %patch5 -p1
194
195 %build
196 CPPFLAGS="%{rpmcppflags} -I/usr/include/umfpack"
197 %meson build \
198         %{?with_doc:-Ddocs=true} \
199         %{!?with_introspection:-Dintrospection=false} \
200         %{!?with_lua:-Dlua=disabled} \
201         -Dworkshop=true
202
203 %ninja_build -C build
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207
208 %ninja_install -C build
209
210 %find_lang %{name}-0.4
211
212 %clean
213 rm -rf $RPM_BUILD_ROOT
214
215 %post   -p /sbin/ldconfig
216 %postun -p /sbin/ldconfig
217
218 %files -f %{name}-0.4.lang
219 %defattr(644,root,root,755)
220 %doc AUTHORS MAINTAINERS
221 %attr(755,root,root) %{_bindir}/gegl
222 %attr(755,root,root) %{_bindir}/gegl-imgcmp
223 %attr(755,root,root) %{_libdir}/libgegl-0.4.so.*.*.*
224 %attr(755,root,root) %ghost %{_libdir}/libgegl-0.4.so.0
225 %attr(755,root,root) %{_libdir}/libgegl-npd-0.4.so
226 %attr(755,root,root) %{_libdir}/libgegl-sc-0.4.so
227 %{?with_introspection:%{_libdir}/girepository-1.0/Gegl-0.4.typelib}
228 %dir %{_libdir}/gegl-0.4
229 %attr(755,root,root) %{_libdir}/gegl-0.4/*.so
230 %{_libdir}/gegl-0.4/grey2.json
231 %if %{with lua}
232 %dir %{_datadir}/gegl-0.4
233 %{_datadir}/gegl-0.4/lua
234 %endif
235
236 %files devel
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_libdir}/libgegl-0.4.so
239 %{_includedir}/gegl-0.4
240 %{?with_introspection:%{_datadir}/gir-1.0/Gegl-0.4.gir}
241 %{_pkgconfigdir}/gegl-0.4.pc
242 %{_pkgconfigdir}/gegl-sc-0.4.pc
243
244 %if %{with static_libs}
245 %files static
246 %defattr(644,root,root,755)
247 %{_libdir}/libgegl-0.4.a
248 %{_libdir}/libgegl-npd-0.4.a
249 %{_libdir}/libgegl-sc-0.4.a
250 %endif
251
252 %if %{with doc}
253 %files apidocs
254 %defattr(644,root,root,755)
255 %doc build/docs/{ophtml,*.html,*.png}
256 %{_gtkdocdir}/gegl
257 %endif
258
259 %if %{with vala}
260 %files -n vala-gegl
261 %defattr(644,root,root,755)
262 %{_datadir}/vala/vapi/gegl-0.4.deps
263 %{_datadir}/vala/vapi/gegl-0.4.vapi
264 %endif
This page took 0.079906 seconds and 2 git commands to generate.