]> git.pld-linux.org Git - packages/geeqie.git/commitdiff
- up to 1.6
authorKrzysztof Mrozowicz <mrozowik@pld-linux.org>
Fri, 9 Apr 2021 08:05:11 +0000 (08:05 +0000)
committerKrzysztof Mrozowicz <mrozowik@pld-linux.org>
Fri, 9 Apr 2021 08:05:11 +0000 (08:05 +0000)
0001-Fix-829-segfault-with-clutter-gtk.patch [new file with mode: 0644]
geeqie.spec
libdir-fix.patch

diff --git a/0001-Fix-829-segfault-with-clutter-gtk.patch b/0001-Fix-829-segfault-with-clutter-gtk.patch
new file mode 100644 (file)
index 0000000..1e2609f
--- /dev/null
@@ -0,0 +1,35 @@
+From f34ea0700048c27319a2256408171adda32a7580 Mon Sep 17 00:00:00 2001
+From: Colin Clark <colin.clark@cclark.uk>
+Date: Sat, 9 Jan 2021 11:35:41 +0000
+Subject: [PATCH] Fix #829: segfault with clutter-gtk
+
+https://github.com/BestImageViewer/geeqie/issues/829
+
+This fix might cause other problems which might be cured by calling:
+LIBGL_ALWAYS_INDIRECT=1 geeqie
+
+or, worst case:
+geeqie --disable-clutter
+---
+ src/main.c | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/src/main.c b/src/main.c
+index f497240d..4af654fe 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -904,11 +904,6 @@ gint main(gint argc, gchar *argv[])
+ #ifdef HAVE_GTHREAD
+ #if !GLIB_CHECK_VERSION(2,32,0)
+       g_thread_init(NULL);
+-#endif
+-#ifdef HAVE_CLUTTER
+-/* FIXME: see below */
+-      putenv("LIBGL_ALWAYS_INDIRECT=1");
+-      XInitThreads();
+ #endif
+       gdk_threads_init();
+       gdk_threads_enter();
+-- 
+2.29.2
+
index 58d1d1460baef44e34194ef049c97d304ff9c2c1..a959af2dc17fc5bf74642e6f6cc33200fe6375ff 100644 (file)
@@ -12,41 +12,48 @@ Summary:    Graphics file browser utility
 Summary(hu.UTF-8):     Képfájl-böngésző eszköz
 Summary(pl.UTF-8):     Narzędzie do przeglądania plików graficznych
 Name:          geeqie
-Version:       1.4
-Release:       2
+Version:       1.6
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Graphics
 Source0:       http://www.geeqie.org/%{name}-%{version}.tar.xz
-# Source0-md5: 52a4d387093e02182201b1cc02d99cc9
+# Source0-md5: e7401c0e117c423456d5fab468c3149c
 Patch0:                libdir-fix.patch
 Patch1:                exiv2-0.27.patch
 Patch2:                no-changelog.patch
 Patch3:                x32.patch
+Patch4:                0001-Fix-829-segfault-with-clutter-gtk.patch
 URL:           http://www.geeqie.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_clutter:BuildRequires: clutter-devel >= 1.0}
 %{?with_clutter:BuildRequires: clutter-gtk-devel >= 1.0}
+BuildRequires: djvulibre-devel >= 3.5.27
 BuildRequires: exiv2-devel >= 0.11
+BuildRequires: ffmpegthumbnailer-devel >= 2.1.0
 BuildRequires: gdk-pixbuf2-devel >= 2
 BuildRequires: gettext-tools
 BuildRequires: glib2-devel >= 1:2.24.0
 BuildRequires: gnome-doc-utils
+BuildRequires: graphviz
 %{?with_gtk2:BuildRequires:    gtk+2-devel >= 2:2.20.0}
 %{!?with_gtk2:BuildRequires:   gtk+3-devel >= 3.0.0}
+
 BuildRequires: intltool >= 0.40.0
 BuildRequires: lcms2-devel >= 2.0
 %{?with_champlain:BuildRequires:       libchamplain-devel >= 0.12}
+BuildRequires: libheif-devel >= 1.3.2
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
 BuildRequires: lirc-devel
-BuildRequires: lua51-devel >= 5.1.5-2
+BuildRequires: lua53-devel >= 5.3
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+BuildRequires: yelp-tools
 Requires:      desktop-file-utils
 Requires:      exiv2-libs >= 0.11
 Requires:      glib2 >= 1:2.24.0
@@ -82,11 +89,11 @@ i opcje filtrowania, jak również wsparcie dla zewnętrznego edytora.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
+%patch4 -p1
 
 %build
+%{__sed} -i '1s,/usr/bin/awk,/bin/awk,' \
+       plugins/geocode-parameters/geocode-parameters.awk
 install -d auxdir
 %{__intltoolize}
 %{__aclocal}
@@ -96,7 +103,7 @@ install -d auxdir
 %configure \
        %{!?with_clutter:--disable-gpu-accel} \
        --enable-gtk3%{?with_gtk2:=no} \
-       %{?with_champlain:--enable-map}
+       %{?with_champlain:--enable-map} 
 
 %{__make}
 
@@ -129,8 +136,17 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/%{name}.desktop
 %{_pixmapsdir}/%{name}.png
 %dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/geeqie-import
+%attr(755,root,root) %{_libdir}/%{name}/geeqie-camera-import
+%attr(755,root,root) %{_libdir}/%{name}/geeqie-camera-import-hook-script
+%attr(755,root,root) %{_libdir}/%{name}/geeqie-export-jpeg
+%attr(755,root,root) %{_libdir}/%{name}/geeqie-image-crop
+%attr(755,root,root) %{_libdir}/%{name}/geeqie-random-image
 %attr(755,root,root) %{_libdir}/%{name}/geeqie-rotate
 %attr(755,root,root) %{_libdir}/%{name}/geeqie-symlink
+%attr(755,root,root) %{_libdir}/%{name}/geeqie-tethered-photography
+%attr(755,root,root) %{_libdir}/%{name}/geeqie-tethered-photography-hook-script
 %attr(755,root,root) %{_libdir}/%{name}/geeqie-ufraw
+%attr(755,root,root) %{_libdir}/%{name}/geocode-parameters.awk
+%attr(755,root,root) %{_libdir}/%{name}/lensID
 %{_libdir}/%{name}/geocode-parameters.awk
+%{_datadir}/metainfo/org.geeqie.Geeqie.appdata.xml
index 5f08fdcad46bf8f54e96205b0fffb82930b8c95a..b7193fbbfcc625c8d3eeb684476dbeafe00997a3 100644 (file)
@@ -1,6 +1,6 @@
---- geeqie-1.0/configure.in~   2010-02-17 22:21:23.000000000 +0100
-+++ geeqie-1.0/configure.in    2010-09-09 10:05:27.667671281 +0200
-@@ -227,7 +227,7 @@
+--- geeqie-1.6/configure.ac~   2020-11-20 21:36:33.000000000 +0000
++++ geeqie-1.6/configure.ac    2021-04-08 22:29:09.742491746 +0000
+@@ -253,7 +253,7 @@
  AC_DEFINE_UNQUOTED([GQ_APP_DIR], "$appdir", [Location of application data])
  AC_SUBST(appdir)
  
This page took 0.163698 seconds and 4 git commands to generate.