]> git.pld-linux.org Git - packages/geeqie.git/commitdiff
- up to 1.4 auto/th/geeqie-1.4-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 12 Feb 2019 22:39:07 +0000 (23:39 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 12 Feb 2019 22:39:07 +0000 (23:39 +0100)
exiv2-0.27.patch [new file with mode: 0644]
geeqie.spec
no-changelog.patch [new file with mode: 0644]

diff --git a/exiv2-0.27.patch b/exiv2-0.27.patch
new file mode 100644 (file)
index 0000000..306ecef
--- /dev/null
@@ -0,0 +1,90 @@
+X-Git-Url: http://geeqie.org/cgi-bin/gitweb.cgi?p=geeqie.git;a=blobdiff_plain;f=src%2Fexiv2.cc;h=2992740c497825f790d6be617f04f4729df7f8cd;hp=b3c806572b87998d6d047a12ac69520ca58760ab;hb=d309cc7c217eeb187ce59b7d5c9145112048182b;hpb=eedf0ad8550ad5ed95a48d9770669b80bde66b5d
+
+diff --git a/src/exiv2.cc b/src/exiv2.cc
+index b3c80657..2992740c 100644
+--- a/src/exiv2.cc
++++ b/src/exiv2.cc
+@@ -22,17 +22,25 @@
+ #ifdef HAVE_EXIV2
+-#include <exiv2/image.hpp>
+-#include <exiv2/exif.hpp>
++// Don't include the <exiv2/version.hpp> file directly
++// Early Exiv2 versions didn't have version.hpp and the macros.
++#include <exiv2/exiv2.hpp>
+ #include <iostream>
+ #include <string>
+ // EXIV2_TEST_VERSION is defined in Exiv2 0.15 and newer.
++#ifdef EXIV2_VERSION
+ #ifndef EXIV2_TEST_VERSION
+-# define EXIV2_TEST_VERSION(major,minor,patch) \
++#define EXIV2_TEST_VERSION(major,minor,patch) \
+       ( EXIV2_VERSION >= EXIV2_MAKE_VERSION(major,minor,patch) )
+ #endif
++#else
++#define EXIV2_TEST_VERSION(major,minor,patch) (false)
++#endif
++#if EXIV2_TEST_VERSION(0,27,0)
++#define HAVE_EXIV2_ERROR_CODE
++#endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
+@@ -40,27 +48,8 @@
+ #include <fcntl.h>
+ #include <sys/mman.h>
+-#if !EXIV2_TEST_VERSION(0,17,90)
+-#include <exiv2/tiffparser.hpp>
+-#include <exiv2/tiffcomposite.hpp>
+-#include <exiv2/tiffvisitor.hpp>
+-#include <exiv2/tiffimage.hpp>
+-#include <exiv2/cr2image.hpp>
+-#include <exiv2/crwimage.hpp>
+-#if EXIV2_TEST_VERSION(0,16,0)
+-#include <exiv2/orfimage.hpp>
+-#endif
+-#if EXIV2_TEST_VERSION(0,13,0)
+-#include <exiv2/rafimage.hpp>
+-#endif
+-#include <exiv2/futils.hpp>
+-#else
+-#include <exiv2/preview.hpp>
+-#endif
+-
+-#if EXIV2_TEST_VERSION(0,17,0)
+-#include <exiv2/convert.hpp>
+-#include <exiv2/xmpsidecar.hpp>
++#if EXIV2_TEST_VERSION(0,27,0)
++#define EXV_PACKAGE "exiv2"
+ #endif
+ extern "C" {
+@@ -374,7 +363,11 @@ public:
+ #endif
+                       Exiv2::Image *image = imageData_->image();
++#ifdef HAVE_EXIV2_ERROR_CODE
++                      if (!image) throw Exiv2::Error(Exiv2::ErrorCode::kerInputDataReadFailed);
++#else
+                       if (!image) Exiv2::Error(21);
++#endif
+                       image->setExifData(exifData_);
+                       image->setIptcData(iptcData_);
+ #if EXIV2_TEST_VERSION(0,16,0)
+@@ -394,8 +387,12 @@ public:
+                       sidecar->setXmpData(xmpData_);
+                       sidecar->writeMetadata();
+ #else
++#ifdef HAVE_EXIV2_ERROR_CODE
++                      throw Exiv2::Error(Exiv2::ErrorCode::kerNotAnImage, "xmp");
++#else
+                       throw Exiv2::Error(3, "xmp");
+ #endif
++#endif
+                       }
+       }
index f11e01ee80e421eb892782bd3d8f7a48d940373f..f1d86a000ac046b80b7150b3cec280b3c8eedd44 100644 (file)
@@ -12,13 +12,15 @@ Summary:    Graphics file browser utility
 Summary(hu.UTF-8):     Képfájl-böngésző eszköz
 Summary(pl.UTF-8):     Narzędzie do przeglądania plików graficznych
 Name:          geeqie
-Version:       1.3
-Release:       2
+Version:       1.4
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Graphics
 Source0:       http://www.geeqie.org/%{name}-%{version}.tar.xz
-# Source0-md5: 0339ad62946cae7009ec76ec21572065
+# Source0-md5: 52a4d387093e02182201b1cc02d99cc9
 Patch0:                libdir-fix.patch
+Patch1:                exiv2-0.27.patch
+Patch2:                no-changelog.patch
 URL:           http://www.geeqie.org/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
@@ -79,6 +81,8 @@ i opcje filtrowania, jak również wsparcie dla zewnętrznego edytora.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 install -d auxdir
@@ -117,7 +121,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS README TODO ChangeLog doc/html
+%doc AUTHORS README.md TODO doc/html
 %attr(755,root,root) %{_bindir}/%{name}
 %{_mandir}/man1/%{name}.1*
 %{_desktopdir}/%{name}.desktop
@@ -127,3 +131,4 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/geeqie-rotate
 %attr(755,root,root) %{_libdir}/%{name}/geeqie-symlink
 %attr(755,root,root) %{_libdir}/%{name}/geeqie-ufraw
+%{_libdir}/%{name}/geocode-parameters.awk
diff --git a/no-changelog.patch b/no-changelog.patch
new file mode 100644 (file)
index 0000000..1b8833b
--- /dev/null
@@ -0,0 +1,14 @@
+--- geeqie-1.4.orig/Makefile.am        2017-12-31 07:31:21.000000000 -0500
++++ geeqie-1.4/Makefile.am     2018-01-01 15:05:58.742068166 -0500
+@@ -10,9 +10,9 @@
+ readmedir = @readmedir@
+ if HAVE_MARKDOWN
+-readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS README.html ChangeLog.html
++readme_DATA = README.md COPYING TODO README.lirc AUTHORS README.html
+ else
+-readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS ChangeLog.html
++readme_DATA = README.md COPYING TODO README.lirc AUTHORS
+ endif
+ desktopdir = $(datadir)/applications
This page took 0.174598 seconds and 4 git commands to generate.