]> git.pld-linux.org Git - packages/framewave.git/commitdiff
- added templates patch (use explicit instantiation, with gcc 5+ local usage seems... auto/th/framewave-1.3.1-10
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 26 Jan 2016 17:49:26 +0000 (18:49 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 26 Jan 2016 17:49:26 +0000 (18:49 +0100)
- release 10

framewave-templates.patch [new file with mode: 0644]
framewave.spec

diff --git a/framewave-templates.patch b/framewave-templates.patch
new file mode 100644 (file)
index 0000000..f20f4c4
--- /dev/null
@@ -0,0 +1,32 @@
+--- FRAMEWAVE_1.3.1_SRC/Framewave/domain/fwImage/src/ResizeShift.cpp.orig      2009-07-09 11:15:33.000000000 +0200
++++ FRAMEWAVE_1.3.1_SRC/Framewave/domain/fwImage/src/ResizeShift.cpp   2016-01-26 18:11:53.844974171 +0100
+@@ -75,6 +75,10 @@
+               return fwStsNoErr;
+       }
++      template
++      FwStatus My_FW_ParaCheck<Fw8u>(const Fw8u*pSrc, FwiSize srcSize, int srcStep, FwiRect srcRoi,
++              Fw8u*pDst, int dstStep, FwiSize dstRoiSize, int channel);
++
+       template< class TS, CH chSrc, DispatchType disp >
+       extern FwStatus My_FW_Resize(const TS *pSrc, int srcStep, FwiRect srcRoi,       
+               TS*pDst, int dstStep, FwiSize dstRoiSize,
+--- FRAMEWAVE_1.3.1_SRC/Framewave/domain/fwImage/src/WarpAffine.cpp.orig       2009-07-09 11:15:34.000000000 +0200
++++ FRAMEWAVE_1.3.1_SRC/Framewave/domain/fwImage/src/WarpAffine.cpp    2016-01-26 18:12:25.553290744 +0100
+@@ -69,6 +69,16 @@
+               return fwStsNoErr;
+       }
++      template
++      FwStatus My_FW_ParaCheck2<Fw8u>(const Fw8u* pSrc, FwiSize srcSize, int srcStep, 
++              FwiRect srcRoi, Fw8u* pDst, int dstStep, 
++              FwiRect dstRoi, int channel);
++
++      template
++      FwStatus My_FW_ParaCheck2<Fw16u>(const Fw16u* pSrc, FwiSize srcSize, int srcStep, 
++              FwiRect srcRoi, Fw16u* pDst, int dstStep, 
++              FwiRect dstRoi, int channel);
++
+       //handle each point individually
+       template< class TS, DispatchType disp, int interpolation >
+       void My_FW_PointHandle(float xmap, float ymap, int x, int y,
index ecbed5f46594296eed32d8868b55d80341df2b3a..577e70b6c5380981da302467b60ce1ed373f9d28 100644 (file)
@@ -6,7 +6,7 @@ Summary:        Framewave - set of popular image and signal processing routines
 Summary(pl.UTF-8):     Framewave - zestaw popularnych funkcji do przetwarzania obrazu i sygnału
 Name:          framewave
 Version:       1.3.1
 Summary(pl.UTF-8):     Framewave - zestaw popularnych funkcji do przetwarzania obrazu i sygnału
 Name:          framewave
 Version:       1.3.1
-Release:       9
+Release:       10
 License:       Apache v2.0
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/framewave/FRAMEWAVE_%{version}_SRC.tar.gz
 License:       Apache v2.0
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/framewave/FRAMEWAVE_%{version}_SRC.tar.gz
@@ -14,6 +14,7 @@ Source0:      http://downloads.sourceforge.net/framewave/FRAMEWAVE_%{version}_SRC.tar
 Patch0:                %{name}-system-boost.patch
 Patch1:                %{name}-c++.patch
 Patch2:                no-forced-arch-bits.patch
 Patch0:                %{name}-system-boost.patch
 Patch1:                %{name}-c++.patch
 Patch2:                no-forced-arch-bits.patch
+Patch3:                %{name}-templates.patch
 URL:           http://framewave.sourceforge.net/
 BuildRequires: boost-devel >= 1.34
 BuildRequires: libstdc++-devel
 URL:           http://framewave.sourceforge.net/
 BuildRequires: boost-devel >= 1.34
 BuildRequires: libstdc++-devel
@@ -68,6 +69,7 @@ Statyczne biblioteki Framewave.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 # kill precompiled binaries
 %{__rm} BuildTools/bin/FwHeaderConvert_*
 
 # kill precompiled binaries
 %{__rm} BuildTools/bin/FwHeaderConvert_*
This page took 0.087562 seconds and 4 git commands to generate.