]> git.pld-linux.org Git - packages/foobillard.git/blob - foobillard.spec
- release 5 (by relup.sh)
[packages/foobillard.git] / foobillard.spec
1 #
2 # Conditional build:
3 %bcond_with     glut    # use glut instead of SDL
4 %bcond_with     nvidia  # enable NVidia specific extensions
5 #
6 Summary:        A free OpenGL game of playing billard
7 Summary(pl.UTF-8):      Wolnodostępna gra w bilard oparta na OpenGL
8 Name:           foobillard
9 Version:        3.0a
10 Release:        5
11 License:        GPL
12 Group:          X11/Applications/Games
13 Source0:        http://foobillard.sunsite.dk/dnl/%{name}-%{version}.tar.gz
14 # Source0-md5:  c2d92edeaaf8bfb18aa26f1c79931b7d
15 Source1:        %{name}.desktop
16 Source2:        %{name}.xpm
17 URL:            http://foobillard.sourceforge.net/
18 BuildRequires:  OpenGL-GLU-devel
19 %{!?with_glut:BuildRequires:    SDL-devel}
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  freetype-devel
23 %{?with_glut:BuildRequires:     glut-devel}
24 BuildRequires:  intltool
25 BuildRequires:  libpng-devel
26 BuildRequires:  libtool
27 %{?with_nvidia:BuildRequires:   xorg-driver-video-nvidia-devel}
28 BuildRequires:  xorg-lib-libXaw-devel
29 BuildRequires:  xorg-lib-libXi-devel
30 Requires:       OpenGL
31 %{?with_nvidia:Requires:        xorg-driver-video-nvidia}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
35
36 %description
37 FooBillard is an attempt to create a free OpenGL-billard for Linux.
38 Why foo? Well, actually I had this logo (F.B.-Florian Berger) and then
39 foo sounds a bit like pool (Somehow I wasn't quite attracted by the
40 name FoolBillard). Actually FooBillard is still under development but
41 the main physics is implemented. If you are a billard-pro and you're
42 missing some physics, please tell me. Cause I've implemented it like I
43 think it should work, which might differ from reality.
44
45 %description -l pl.UTF-8
46 FooBillard to próba stworzenia wolnodostępnego bilarda OpenGL dla
47 Linuksa. Dlaczego foo? Bo autor miał już to logo (F.B. - Florian
48 Berger) i "foo" brzmi trochę jak "pool" (a nazwa "FoolBillard" nie
49 brzmiała zbyt przyciągająco). FooBillard jest nadal w stadium rozwoju,
50 ale główna fizyka jest już zaimplementowana. Jeżeli w grze brakuje
51 jakiejś fizyki, dobrze jest zgłosić to autorowi, ponieważ on
52 zaimplementował ją tak, jak myślał, że powinna działać, co może się
53 nieco różnić od rzeczywistości.
54
55 %prep
56 %setup -q
57
58 %build
59 rm -f missing
60 X_LIBS='-I/usr/X11R6/include'; export X_LIBS
61 %{__libtoolize}
62 %{__aclocal}
63 %{__autoconf}
64 %{__automake}
65 %configure \
66 %if %{with glut}
67         --enable-glut \
68         --disable-SDL \
69 %else
70         --disable-glut \
71         --enable-SDL \
72 %endif
73         --%{?with_nvidia:en}%{!?with_nvidia:dis}able-nvidia \
74         --enable-sound
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
86 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS NEWS README ChangeLog TODO README.FONTS foobillardrc.example
94 %attr(755,root,root) %{_bindir}/*
95 %{_datadir}/foobillard
96 %{_desktopdir}/%{name}.desktop
97 %{_pixmapsdir}/*
This page took 0.084178 seconds and 3 git commands to generate.