]> git.pld-linux.org Git - packages/flatbuffers.git/blob - flatbuffers.spec
macros for %cmake
[packages/flatbuffers.git] / flatbuffers.spec
1 Summary:        Memory efficient serialization library
2 Name:           flatbuffers
3 Version:        22.12.06
4 Release:        1
5 License:        Apache v2.0
6 Group:          Applications
7 Source0:        https://github.com/google/flatbuffers/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  33977086e1e28bb73c53cdf0d0584eac
9 URL:            https://google.github.io/flatbuffers/
10 BuildRequires:  cmake >= 3.16
11 BuildRequires:  rpmbuild(macros) >= 1.605
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 FlatBuffers is an efficient cross platform serialization library for
16 C++, C#, C, Go, Java, JavaScript, Lobster, Lua, TypeScript, PHP,
17 Python, and Rust. It was originally created at Google for game
18 development and other performance-critical applications.
19
20 %package devel
21 Summary:        Header files for %{name} library
22 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
23 Group:          Development/Libraries
24
25 %description devel
26 Header files for %{name} library.
27
28 %prep
29 %setup -q
30
31 %build
32 install -d build
33 cd build
34 %cmake \
35         -DFLATBUFFERS_BUILD_FLATLIB=OFF \
36         -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
37         -DFLATBUFFERS_BUILD_TESTS=OFF \
38         ..
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 %{__make} -C build install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 # somewhy not installed by make
47 cd build
48 install -d $RPM_BUILD_ROOT%{_bindir}
49 install -p flatc flathash $RPM_BUILD_ROOT%{_bindir}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post   -p /sbin/ldconfig
55 %postun -p /sbin/ldconfig
56
57 %files
58 %defattr(644,root,root,755)
59 %attr(755,root,root) %{_libdir}/libflatbuffers.so.*.*.*
60 %attr(755,root,root) %ghost %{_libdir}/libflatbuffers.so.22
61
62 %files devel
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_bindir}/flatc
65 %attr(755,root,root) %{_bindir}/flathash
66 %{_includedir}/flatbuffers
67 %{_libdir}/cmake/flatbuffers
68 %{_libdir}/libflatbuffers.so
69 %{_pkgconfigdir}/flatbuffers.pc
This page took 0.110001 seconds and 3 git commands to generate.