]> git.pld-linux.org Git - packages/fish.git/blob - fish.spec
- updated to 3.6.4
[packages/fish.git] / fish.spec
1 Summary:        fish - A friendly interactive shell
2 Summary(pl.UTF-8):      fish - przyjazna interaktywna powłoka
3 Name:           fish
4 Version:        3.6.4
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/Shells
8 Source0:        https://github.com/fish-shell/fish-shell/releases/download/%{version}/%{name}-%{version}.tar.xz
9 # Source0-md5:  600c5d8ffa45b1d73b5263809cb5e6f5
10 URL:            http://fishshell.com/
11 BuildRequires:  cmake >= 3.2
12 BuildRequires:  gettext-tools
13 BuildRequires:  libstdc++-devel >= 6:4.8.1
14 BuildRequires:  ncurses-devel
15 BuildRequires:  pcre2-32-devel >= 10.21
16 BuildRequires:  rpm-build >= 4.6
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRequires:  sphinx-pdg
19 BuildRequires:  tar >= 1:1.22
20 BuildRequires:  xz
21 Requires:       pcre2-32 >= 10.21
22 Suggests:       python
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 fish is a shell geared towards interactive use. Its features are
27 focused on user friendlieness and discoverability. The language syntax
28 is simple but incompatible with other shell languages.
29
30 %description -l pl.UTF-8
31 fish jest powłoką nastawioną na interaktywne używanie. Jego cechą jest
32 przyjazne nastawienie dla użytkownika. Składnia języka jest prosta ale
33 nie jest zgodna z innymi językami powłoki.
34
35 %package devel
36 Summary:        Development files for fish
37 Summary(pl.UTF-8):      Pliki programistyczne dla fish
38 Group:          Development/Libraries
39 BuildArch:      noarch
40
41 %description devel
42 Development files for fish.
43
44 %description devel -l pl.UTF-8
45 Pliki programistyczne dla fish.
46
47 %prep
48 %setup -q
49
50 %{__sed} -i -e '1s,/usr/bin/env python3$,%{__python3},' share/tools/create_manpage_completions.py
51
52 %build
53 %cmake -B build
54
55 %{__make} -C build
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} -C build install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
63
64 %find_lang %{name}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post -p <lua>
70 %lua_add_etc_shells %{_bindir}/fish
71
72 %preun -p <lua>
73 if arg[2] == 0 then
74         %lua_remove_etc_shells %{_bindir}/fish
75 end
76
77 %files -f %{name}.lang
78 %defattr(644,root,root,755)
79 %doc CHANGELOG.rst CONTRIBUTING.rst README.rst user_doc/html/{*.html,*.js,cmds,_static}
80 %dir %{_sysconfdir}/fish
81 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fish/config.fish
82 %attr(755,root,root) %{_bindir}/fish
83 %attr(755,root,root) %{_bindir}/fish_indent
84 %attr(755,root,root) %{_bindir}/fish_key_reader
85 %{_mandir}/man1/fish.1*
86 %{_mandir}/man1/fish_indent.1*
87 %{_mandir}/man1/fish_key_reader.1*
88 %dir %{_datadir}/%{name}
89 %{_datadir}/%{name}/config.fish
90 %{_datadir}/%{name}/__fish_build_paths.fish
91 %dir %{_datadir}/%{name}/completions
92 %{_datadir}/%{name}/completions/*.fish
93 %dir %{_datadir}/%{name}/groff
94 %{_datadir}/%{name}/groff/fish.tmac
95 %dir %{_datadir}/%{name}/functions
96 %{_datadir}/%{name}/functions/*.fish
97 %{_datadir}/%{name}/man
98 %dir %{_datadir}/%{name}/tools
99 %attr(755,root,root) %{_datadir}/%{name}/tools/create_manpage_completions.py
100 %{_datadir}/%{name}/tools/deroff.py
101 %dir %{_datadir}/%{name}/tools/web_config
102 %{_datadir}/%{name}/tools/web_config/delete.png
103 %{_datadir}/%{name}/tools/web_config/favicon.png
104 %{_datadir}/%{name}/tools/web_config/fishconfig.css
105 %{_datadir}/%{name}/tools/web_config/index.html
106 %{_datadir}/%{name}/tools/web_config/js
107 %{_datadir}/%{name}/tools/web_config/partials
108 %{_datadir}/%{name}/tools/web_config/sample_prompts
109 %{_datadir}/%{name}/tools/web_config/themes
110 %attr(755,root,root) %{_datadir}/%{name}/tools/web_config/webconfig.py
111 %dir %{_datadir}/%{name}/vendor_completions.d
112 %dir %{_datadir}/%{name}/vendor_conf.d
113 %dir %{_datadir}/%{name}/vendor_functions.d
114
115 %files devel
116 %defattr(644,root,root,755)
117 %{_npkgconfigdir}/fish.pc
This page took 0.091447 seconds and 4 git commands to generate.